Welcome, Guest
Username: Password: Remember me
30 Oct 2016
INDI Development team is happy to announce the release of INDI Library v1.3.0 on Oct. 30th, 2016.
Read More...
  • Page:
  • 1

TOPIC: Problem donwloading image with CANON camera

Problem donwloading image with CANON camera 1 month 2 weeks ago #13603

  • jeam
  • jeam's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 14
  • Thank you received: 1
Hi to all,

I'm new in this forum.

I'm using Raspberry Pi 3 and Indi to connect to Canon 350D. It connects correctly but, when I take a photo Indi show me an error downloading image, because it doesn't find the Diretory. I check the path and it seems to be correct. I test from a remote indi client and the problem its the same. Log shows:

2017-01-05T17:57:47: Exposure failed to save image... Directory not found
2017-01-05T17:57:47: Error downloading image from camera: Directory not found
2017-01-05T17:57:46: Starting 1 sec exposure
2017-01-05T17:57:03: Device configuration applied.
2017-01-05T17:57:03: Error: Invalid range for X. Valid range is from 0 to -1. Requested value is 0
2017-01-05T17:57:03: Error: Invalid range for CCD_PIXEL_SIZE. Valid range is from 1 to 40. Requested value is 0
2017-01-05T17:57:03: Loading device configuration...
2017-01-05T17:57:03: Please update the camera pixel size in the Image Info section. The camera resolution will be updated after the first exposure is complete.
2017-01-05T17:57:03: Detected Canon Inc. Model Canon EOS 350D DIGITAL.
2017-01-05T17:57:03: Canon DSLR is online.

Any suggestion?

Best regards everyone.

Please Log in or Create an account to join the conversation.

Problem donwloading image with CANON camera 1 month 2 weeks ago #13627

  • jeam
  • jeam's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 14
  • Thank you received: 1
I try the same with Canon 450D and it works better. Localy indi can download the image, but when I change the configuration to client it couldn't download the image but no error is reply from indi. The log show this:

Client setings:

2017-01-06T23:21:07: Exposure done, downloading image...
2017-01-06T23:21:03: Starting 1 sec exposure

Local setings:
2017-01-06T23:07:35: Image saved to /home/jeam/IMAGE_001.fits
2017-01-06T23:07:30: Exposure done, downloading image...
2017-01-06T23:07:22: Starting 1 sec exposure

I don't get any error, and I can view the image automaticaly in KStars FITS View, but not in the client directory :(

Please Log in or Create an account to join the conversation.

Problem donwloading image with CANON camera 1 month 1 week ago #13675

Hi!

I also use a Canon 350D and RPi3 to run indi server, accessing it with ekos on a laptop indoors. And the 350D seems a bit quirky..... but it should work.

Have you set to download on client, server or both (in Indi control panel)? I've had similar problems, but cannot recall how I solved it. Often a reboot of both R-Pi and Canon solves such quirks.

Can you add a full log of the driver for the error? (Kstarts log + Indi driver log)

Magnus
The following user(s) said Thank You: jeam

Please Log in or Create an account to join the conversation.

Problem donwloading image with CANON camera 1 month 1 week ago #13719

jeam wrote: I try the same with Canon 450D and it works better. Localy indi can download the image, but when I change the configuration to client it couldn't download the image but no error is reply from indi. The log show this:

Client setings:

2017-01-06T23:21:07: Exposure done, downloading image...
2017-01-06T23:21:03: Starting 1 sec exposure

Local setings:
2017-01-06T23:07:35: Image saved to /home/jeam/IMAGE_001.fits
2017-01-06T23:07:30: Exposure done, downloading image...
2017-01-06T23:07:22: Starting 1 sec exposure

I don't get any error, and I can view the image automaticaly in KStars FITS View, but not in the client directory :(


Screenshot of your Ekos capture module?
The following user(s) said Thank You: jeam

Please Log in or Create an account to join the conversation.

Problem donwloading image with CANON camera 1 month 1 week ago #13763

  • jeam
  • jeam's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 14
  • Thank you received: 1
I've solved the problem!

My mistake was that I was trying to take the photo directly from Indi Control Panel on KStars:

If I take the photo from Ekos Sequence Queue on KStars I have no problem

Thanks for your replies

Please Log in or Create an account to join the conversation.

Problem donwloading image with CANON camera 1 month 1 week ago #13765

  • jeam
  • jeam's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 14
  • Thank you received: 1

mlarsson wrote: Hi!

I also use a Canon 350D and RPi3 to run indi server, accessing it with ekos on a laptop indoors. And the 350D seems a bit quirky..... but it should work.

Have you set to download on client, server or both (in Indi control panel)? I've had similar problems, but cannot recall how I solved it. Often a reboot of both R-Pi and Canon solves such quirks.

Can you add a full log of the driver for the error? (Kstarts log + Indi driver log)

Magnus


I can't use Canon 350D, it don't work fine in my case. I must to use 450D. When I connect 350D to RaspBerry Pi 3 the 350D screen show to me Busy message all the time. The camara connects but I can't take any photo. The Ekos log show this:

2017-01-13T20:18:24 Capture failed.
2017-01-13T20:18:23 Capturing image...
2017-01-13T20:18:22 Restarting capture attempt #1

I try to change in Canon menu Communication from Priter/PTP to Computer, but then Indi can't connect to the camera. Those are my quirky things! ;)

Other thig, Can I use Mirror lock with indi? I configure it on the canon 450D amb in the GPhoto CCD Main pannel but then it can't take the photo.

Please Log in or Create an account to join the conversation.

Problem donwloading image with CANON camera 1 month 1 week ago #13772

You must also enable mirror lock in the camera itself. Find out how to change your camera mirror lock settings.

Please Log in or Create an account to join the conversation.

Problem donwloading image with CANON camera 1 month 1 week ago #13779

  • jeam
  • jeam's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 14
  • Thank you received: 1

knro wrote: You must also enable mirror lock in the camera itself. Find out how to change your camera mirror lock settings.


It's enabled in the camera, but when I take the photo it doesn't work. I will try to send to you the log.

Please Log in or Create an account to join the conversation.

Problem donwloading image with CANON camera 1 month 1 week ago #13783

Hi!

As for the 350D: I have mine set to "computer", not PTP. What happens when you connect to the Raspberry Pi? What does for instance dmesg say, on the Raspberry, when you connect the camera?

On my 350D, I cannot get mirror lock to work.

Magnus
The following user(s) said Thank You: jeam

Please Log in or Create an account to join the conversation.

Problem donwloading image with CANON camera 1 month 1 week ago #13789

  • jeam
  • jeam's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 14
  • Thank you received: 1
Hi Magnus,
How can I get dmesg log?
Sorry but I'm very new with India and Raspberry Pi. Went I connect the camera with "computer" from Indi doesn't connect whith the camera, only connects when I configure the camera whith PTP option.

I find dmesg information!!!

With PTP option:

[ 433.200110] usb 1-1.5: new high-speed USB device number 6 using dwc_otg
[ 433.314742] usb 1-1.5: New USB device found, idVendor=04a9, idProduct=30ef
[ 433.314761] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 433.314775] usb 1-1.5: Product: Canon Digital Camera
[ 433.314788] usb 1-1.5: Manufacturer: Canon Inc.

With "computer" option:

[ 543.811277] usb 1-1.5: new high-speed USB device number 7 using dwc_otg
[ 543.925978] usb 1-1.5: New USB device found, idVendor=04a9, idProduct=30ee
[ 543.925999] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[ 543.926012] usb 1-1.5: Product: Canon Digital Camera
[ 543.926025] usb 1-1.5: Manufacturer: Canon Inc.

The same information, seems!!!

In Indi control pannel in KStars I get this message when I use "Computer" option:

2017-01-14T20:10:01: Can not open camera: Power OK? If camera is auto-mounted as external disk storage, please unmount it and disable auto-mount.
2017-01-14T20:10:01: Camera open error (-7): I/O problem

Thanks!

Please Log in or Create an account to join the conversation.

Last Edit: by jeam.
  • Page:
  • 1
Time to create page: 0.643 seconds

Login

3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!

Gallery

Replica

Why INDI

Replica