Welcome, Guest
Username: Password: Remember me
27 Feb 2017
INDI development team is happy to announce the release of INDI Library v1.4.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers. Several improvements and enhancements are included in this release including native support for Cygwin and MacOS platforms in addition to Linux, BSD, and Windows (Client only).
Read More...
  • Page:
  • 1

TOPIC: Color issues with ASI120MC

Color issues with ASI120MC 3 months 2 weeks ago #16040

  • oopfan
  • oopfan's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 79
  • Thank you received: 3
In a previous topic, rockstarbill wrote:
As for the color in your images, I would say that you should post up the same FITS images that have the issue so someone can look at them. Hard to troubleshoot a problem without a sample of the data in question.
Sorry for taking so long to respond -- I have been having lots of fun with my new camera!

I set up my camera on a tripod indoors and pointed at two 2-liter soda bottles: one Coca-Cola and the other Pepsi. I think that everyone recognizes that Coke is Red and Pepsi is Blue.

I performed two tests. Test #1 just used the INDI control panel. Test #2 used Ekos. Using my laptop with Ubuntu 16.04 and installing INDI/EKOS/KStars daily updates as they become available. Since I am running Linux I loaded the "compatible" version of firmware as recommended by Jasem and nmac.

First thing to know is that when the INDI server starts it always defaults to RAW8. I have to manually go to the Controls panel and change it to RGB24. (Perhaps there is a way to perform this automatically.)

For Test #1, after I set RGB24 as described above, I go to the Streaming panel and click Stream On. I took a snapshot of the window and attached with the name: "Screenshot of Streaming Video Window.png". You will see that the colors are wrong: Coca-Cola is Blue and Pepsi is Red. I can repeat this multiple times and I always get the same results. Then I tried "Record (Duration)" and "Record (Frames)" to a SER file. I get the same bad results.

For Test #2, I create a profile for the ZWO ASI CCD, I start INDI, connect, and then set RGB24 as described above. I click on the CCD panel. I set the exposure to 0.03. (I attached a screenshot with the name "Ekos-Panel.png") Then I click the "Live Video" button. (I attached a screenshot with the name "Ekos-Live-Video.png") Notice that the colors are not right. Then I click the "Preview" button. (I attached a screenshot with the name "Ekos-Preview.png") Aha the colors are correct. I closed the FITS viewer and clicked the "Preview" button again. Again it is OK (i.e. "Ekos-Preview-2.png") But the third time I get bad colors ("Ekos-Preview-3.png"). There doesnt seem to be a pattern. I may get 5 previews in a row that are good, and then the sixth is bad and then it reverts to a string of good images. One thing that seems to be consistent is "Live Video" is always bad.

I hope this helps.
The following user(s) said Thank You: knro

Please Log in or Create an account to join the conversation.

Color issues with ASI120MC 3 months 2 weeks ago #16047

  • oopfan
  • oopfan's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 79
  • Thank you received: 3
Just some added info:

SharpCap renders colors properly under Windows 7, with or without the "compatible" firmware. The only issue with running the "compatible" firmware under WIndows is lots of dropped frames but the colors are fine. When running "non-compatible" firmware with SharpCap under Windows produces proper colors and fast frame rates having very, very few dropped frames as per the advertised ZWO performance specs.

Please Log in or Create an account to join the conversation.

Color issues with ASI120MC 3 months 1 week ago #16075

I suspect it's RGB <--> BGR issue then when video streaming, I'll check it when I get home. For the bad colors in still mode, it appears some frames do get saturated. I'll try to investigate why.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
  • Page:
  • 1
Time to create page: 0.108 seconds

Login

3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!

Gallery

Replica

Why INDI

Replica