Welcome, Guest
Username: Password: Remember me
20 Aug 2017
INDI development team is happy to announce the release of INDI Library v1.5.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...
  • Page:
  • 1

TOPIC: ASI120MC-S underexposed band with 5s exposure

ASI120MC-S underexposed band with 5s exposure 4 months 6 days ago #17271

  • sunka
  • sunka's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
Hi,

I bought Raspberry Pi 3 model b to set up asi120mc-s as all sky camera. I installed indi server and SWIG and can successfuly connect to the camera from Python.

If I set exposure under 2s. everything is ok (check attachment 1s.jpeg). But if I go above, band of 183px is less exposed than the rest of the image (check attachment 5s.jpeg). Do you have any idea why this would happen? I also attachedcamera settings (asi120mc-s_indi_settings.txt). This is python code snippet for capture:
def takeExposure(self):
	self.logger.info("<<<<<<<< Exposure >>>>>>>>>")
	#get current exposure time
	exp = self.device.getNumber("CCD_EXPOSURE")
	# set exposure time to 5 seconds
	exp[0].value = 5
	self.sendNewNumber(exp)
def newBLOB(self, bp):
	self.logger.info("new BLOB "+ bp.name.decode())
	# get image data
	img = bp.getblobdata()
	import cStringIO
	# write image data to StringIO buffer
	blobfile = cStringIO.StringIO(img)
	# open a file and save buffer to disk
	with open("frame.fit", "wb") as f:
		f.write(blobfile.getvalue())

Thank you in advance and best regards!
Attachments:

Please Log in or Create an account to join the conversation.

Last Edit: by sunka.

ASI120MC-S underexposed band with 5s exposure 4 months 5 days ago #17276

  • sunka
  • sunka's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
I am in contact with ZWO, software fix might be needed.

Please Log in or Create an account to join the conversation.

ASI120MC-S underexposed band with 5s exposure 4 months 4 days ago #17285

Does it happen when you're in 16-bit RAW mode? Your settings show 8-bit.

Please Log in or Create an account to join the conversation.

Skywatcher 190MN - EQ6 Pro - ASI1600MM-Cooled - EFW7 - ASI120MM - WO f4 Guide Scope - Rigel nStep - Ekos chained to two Raspberry Pi 3's - KDE Neon - PixInsight

ASI120MC-S underexposed band with 5s exposure 4 months 4 days ago #17286

  • sunka
  • sunka's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
Hi Keith!

Yes, I tried switching to 16-bit raw mode and it happens too.

Please Log in or Create an account to join the conversation.

ASI120MC-S underexposed band with 5s exposure 4 months 4 days ago #17287

All I can suggest further is to try a different USB Cable and of course try using a powered USB hub instead of directly into the RPi3

Please Log in or Create an account to join the conversation.

Skywatcher 190MN - EQ6 Pro - ASI1600MM-Cooled - EFW7 - ASI120MM - WO f4 Guide Scope - Rigel nStep - Ekos chained to two Raspberry Pi 3's - KDE Neon - PixInsight

ASI120MC-S underexposed band with 5s exposure 4 months 4 days ago #17288

  • sunka
  • sunka's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
Good idea, I will try both and report back.

Thanks!

Please Log in or Create an account to join the conversation.

ASI120MC-S underexposed band with 5s exposure 4 months 2 days ago #17309

  • sunka
  • sunka's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
Solved.

For anyone with same problem, the issue was with wrong camera settings. HighSpeedMode must be turned off and than it works ok. Additionally, to turn this flag off, one must set exposure under 100ms first (I got that info from ZWO directly, because I could not change the flag). So to sum up, this is the fix:

indi_setprop "ZWO CCD ASI120MC-S.CCD_EXPOSURE.CCD_EXPOSURE_VALUE=0.05"
indi_setprop "ZWO CCD ASI120MC-S.CCD_CONTROLS.HighSpeedMode=0"

Please Log in or Create an account to join the conversation.

Last Edit: by sunka.
  • Page:
  • 1
Time to create page: 0.389 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica