Welcome, Guest
Username: Password: Remember me
20 Aug 2017
INDI development team is happy to announce the release of INDI Library v1.5.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...

TOPIC: Short exposures for ZWO cameras

Short exposures for ZWO cameras 2 weeks 3 days ago #20719

  • Gina
  • Gina's Avatar Topic Author
  • Away
  • Senior Boarder
  • Senior Boarder
  • Posts: 51
  • Karma: 1
  • Thank you received: 6
Firstly, thank you for a great collection of software :)

I'm using INDI/KStars/Ekos for my All Sky Camera and the standard ZWO INDI driver is fine for longer exposures with my ASI185MC camera but I would like to use this in daytime as well as at night. Now to the problem - the minimum exposure with the INDI driver is 1ms and with gain set to zero this is still too much. The camera goes down to 32µs and I'm wondering if the INDI driver source code could be edited to allow shorter exposures. Would this be just a matter of increasing the input text box or is it more complicated than this? Any help would be much appreciated. Thank you.
The following user(s) said Thank You: knro

Please Log in or Create an account to join the conversation.

Short exposures for ZWO cameras 2 weeks 3 days ago #20720

This can already be done in Ekos. I just took 64us exposure for ZWO 120mm. Just make sure you are using the latest KStars version (current is 2.8.7).
The following user(s) said Thank You: Gina

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Short exposures for ZWO cameras 2 weeks 1 day ago #20768

  • Gina
  • Gina's Avatar Topic Author
  • Away
  • Senior Boarder
  • Senior Boarder
  • Posts: 51
  • Karma: 1
  • Thank you received: 6
I replied to this using "Quick Reply" but my reply seems to have disappeared. Now trying "Reply".

I installed the latest KStars and upgraded the INDI drivers etc.to be sure everything was up-to-date and tried again but it's still the same. The exposure text box in Ekos won't let me enter any value less than ".001". I'm assuming the exposure is in seconds. Am I missing something?

Please Log in or Create an account to join the conversation.

Short exposures for ZWO cameras 2 weeks 14 hours ago #20772

Can you double check the KStars version? Any screenshot from the capture module?

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Short exposures for ZWO cameras 2 weeks 11 hours ago #20774

  • Gina
  • Gina's Avatar Topic Author
  • Away
  • Senior Boarder
  • Senior Boarder
  • Posts: 51
  • Karma: 1
  • Thank you received: 6
Thanks for your reply :)

KStars version 2.8.7. Screenshots of About KStars Version and Ekos attached.
Attachments:

Please Log in or Create an account to join the conversation.

Last Edit: by Gina.

Short exposures for ZWO cameras 2 weeks 11 hours ago #20775

Thanks. From the INDI control panel, go to the camera tab, then try to put the exposure value directly there under Exposure property and then press set. Try to put 0.00001 and see if it produces any error message.
The following user(s) said Thank You: Gina

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Short exposures for ZWO cameras 2 weeks 10 hours ago #20776

  • Gina
  • Gina's Avatar Topic Author
  • Away
  • Senior Boarder
  • Senior Boarder
  • Posts: 51
  • Karma: 1
  • Thank you received: 6
When I try to enter anything less than .001 the light goes red. That includes .00001 as you suggested and .0009

Please Log in or Create an account to join the conversation.

Short exposures for ZWO cameras 2 weeks 10 hours ago #20777

yes but what does it say below? there should be a message about the limits in the control panel log window

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Short exposures for ZWO cameras 2 weeks 9 hours ago #20778

  • Gina
  • Gina's Avatar Topic Author
  • Away
  • Senior Boarder
  • Senior Boarder
  • Posts: 51
  • Karma: 1
  • Thank you received: 6
The log window is empty - no error messages. But the exposure seems to be taken from the Ekos camera control panel and even with .0001 in the INDI control panel the exposure is the same.

Please Log in or Create an account to join the conversation.

Last Edit: by Gina.

Short exposures for ZWO cameras 2 weeks 8 hours ago #20780

Ok this is weird because I see message in the INDI Control Panel. I tried to enter 0.000001 directly there and received an error as you can see below.

Attachments:

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Short exposures for ZWO cameras 2 weeks 7 hours ago #20781

  • Gina
  • Gina's Avatar Topic Author
  • Away
  • Senior Boarder
  • Senior Boarder
  • Posts: 51
  • Karma: 1
  • Thank you received: 6
I'm not getting any messages in the log window of any sort. And that's strange. Also not getting any messages in the Astroberry Board control that I'm using to control a dew heater and camera cooler (separate Peltier TEC module cooling the camera casing). I feel sure I used to get messages with the older version of KStars etc. but I could be mistaken as I use other software with similar log windows.

I notice the Set button in your screenshot is blue whereas mine stays white (it goes grey when I click and hold). The general colour scheme is different too but that's probably to do with the OS in use. I'm using Linux Mint

Please Log in or Create an account to join the conversation.

Short exposures for ZWO cameras 1 week 6 days ago #20797

  • Gina
  • Gina's Avatar Topic Author
  • Away
  • Senior Boarder
  • Senior Boarder
  • Posts: 51
  • Karma: 1
  • Thank you received: 6
Thought I would try "sudo apt-get update && sudo apt-get upgrade && sudo reboot" on my Linux Mint client machine in case something there wasn't up-to-date but it's made no difference - still nothing in the log windows and minimum exposure is still .001s in Ekos. I would have thought this was set up in the INDI camera driver but that doesn't explain the absence of log messages. Also, if you're using the same INDI driver as it would seem (the driver is the same for the ASI178 as for the ASI185 - I have used both cameras in my ASC at different times).

Please Log in or Create an account to join the conversation.

Last Edit: by Gina.
Time to create page: 0.329 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica