Welcome, Guest
Username: Password: Remember me
25 Jul 2018
Glad to announce of release of INDI Library v1.7.4 on 2018-07-25. A few drivers were added in this release as we continue to improve & stabilize existing drivers.
Read More...

TOPIC: Pentax K-5 capture failed

Pentax K-5 capture failed 1 week 3 days ago #28339

Come to google chat (in gmail or hangouts).

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Pentax K-5 capture failed 1 week 2 days ago #28355

Ok issue appears fix. Please Pentax & Sony users, test the latest driver in the nightly PPA.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Pentax K-5 capture failed 1 week 1 day ago #28400

  • noste99
  • noste99's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 129
  • Thank you received: 5
Jasem,
I tested again on the laptop where we corrected yesterday the issues and I do not find any issue. I am confident it is working well.

Because my idea is to connect my gear (mount, guider and DSLR) to my RPi3 as remote indiserver, and run on my laptop KSTARS pointing to the remote mRPi3 for communicating with the instruments, the mount and the guider work perfectly. The DSLR (PENTAX K-5) however not at all. The same issue as we started from yesterday evening. I updated/upgraded from the nightly PPA on the RPi3 but no result.

On the laptop I did not dare updating/upgrading fearing that I would overwrite the modifications we made yesterday.

Please Log in or Create an account to join the conversation.

Pentax K-5; Samyang 800mm F8.0;Sky-Watcher ED80 D=80mm F=600mm;ZWO ASI120MC

Pentax K-5 capture failed 1 week 1 day ago #28411

Will test on my K5IIs and report back later. :)

Please Log in or Create an account to join the conversation.

Pentax K-5 capture failed 1 week 1 day ago #28415

My K5Iis is good to go with capture DNG and fits. No problem at all.

Please Log in or Create an account to join the conversation.

Pentax K-5 capture failed 1 week 16 hours ago #28423

  • noste99
  • noste99's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 129
  • Thank you received: 5
Have tried to reinstall on RPi3 as you did on laptop but without success. I can use gphoto2 and set shutterspeed, take pictures and check exiv2 parameters. Setting shutterspeed works for strings of the type '1/100' etc. 2s doesn't work.

Starting indiserver from the command-line gives me for all drivers I intend to use the following error:

2018-08-09T20:42:26: Driver indi_eqmod_telescope: indi_eqmod_telescope: symbol lookup error: indi_eqmod_telescope: undefined symbol: _ZN4INDI9Telescope13ISSnoopDeviceEP8_xml_ele

No logs available in .indi.

Please Log in or Create an account to join the conversation.

Pentax K-5; Samyang 800mm F8.0;Sky-Watcher ED80 D=80mm F=600mm;ZWO ASI120MC

Pentax K-5 capture failed 1 week 4 hours ago #28434

Probably an update issue, try to update and install indi-eqmod again.
The following user(s) said Thank You: noste99

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Pentax K-5 capture failed 6 days 18 hours ago #28445

  • noste99
  • noste99's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 129
  • Thank you received: 5
OK I updated the RPi3 and the driver works now but gives a strange message on stdout, namely:

indiserver -m 100 -p 8000 indi_eqmod_telescope
2018-08-10T18:37:12: startup: indiserver -m 100 -p 8000 indi_eqmod_telescope
2018-08-10T18:37:12: Driver indi_eqmod_telescope: Using prefix /usr/share/indi//indi_eqmod_sk.xml
2018-08-10T18:37:12: Driver indi_eqmod_telescope: Using prefix /usr/share/indi//indi_align_sk.xml
2018-08-10T18:37:12: Driver indi_eqmod_telescope: Using prefix /usr/share/indi//indi_eqmod_simulator_sk.xml
2018-08-10T18:37:12: Driver indi_eqmod_telescope: Using prefix /usr/share/indi//indi_eqmod_scope_limits_sk.xml
2018-08-10T18:37:12: Driver indi_eqmod_telescope: EnumeratePlugins - found plugin SVD Math Plugin
The double / or is a typo somewhere, or there is an issue with a environment variable that should be set and is not. Not nice but not an issue because the driver works.

For the indi_pentax_ccd the situation is different.
I get the following message and the process died and goes to 10 restarts
indiserver -m 100 -p 8000 indi_pentax_ccd
2018-08-10T18:49:56: startup: indiserver -m 100 -p 8000 indi_pentax_ccd
2018-08-10T18:49:56: Driver indi_pentax_ccd: 2018-08-10T18:49:56: Driver indi_pentax_ccd: execlp: No such file or directory
Child process 1388 died
2018-08-10T18:49:56: Driver indi_pentax_ccd: stderr EOF
2018-08-10T18:49:56: Driver indi_pentax_ccd: restart #1
After 10 restarts and every time the same issue indiserver gives up.
So Pentax DSLR on RPi3 is not working at all: He does not find a directory while yesterday the issue was as reported for the eqmod_telescope.
Looking to the previously mentioned aesthetics issue, for the Pentax it may be that the double / makes that a file or directory cannot be found.

I remain online in case there would be a need for more info.
Stefan

Please Log in or Create an account to join the conversation.

Pentax K-5; Samyang 800mm F8.0;Sky-Watcher ED80 D=80mm F=600mm;ZWO ASI120MC

Pentax K-5 capture failed 6 days 17 hours ago #28446

  • noste99
  • noste99's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 129
  • Thank you received: 5
Jasem, I deleted all, purged the ppa and reinstalled the kstars-bleeding (even not used on RPi3) and indi-full.
For the indi_asi_ccd and indi_eqmod_telescope work perfectly well without strange messages.
indi_pentax_ccd launches without messages (fine !!!) but connecting KStars to it does not allow taking frames. The indicator starts turning but no reaction of the DSLR.
When running the sequence the following message is logged:

Driver indi_pentax_ccd: indi_pentax_ccd dispatch error: Property CCD_ABORT_EXPOSURE is not defined in Pentax DSLR K5D 0.
Driver indi_pentax_ccd: indi_pentax_ccd dispatch error: Property CCD_EXPOSURE is not defined in Pentax DSLR K5D 0.

Please Log in or Create an account to join the conversation.

Pentax K-5; Samyang 800mm F8.0;Sky-Watcher ED80 D=80mm F=600mm;ZWO ASI120MC

Pentax K-5 capture failed 6 days 5 hours ago #28456

  • noste99
  • noste99's Avatar Topic Author
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 129
  • Thank you received: 5
This morning I reinstalled the machine completely, OS, Kstars-bleeding, indi-full and libgphoto2, the latter two from the indinightly ppa.
I can report that the indi_pentax_ccd driver works now fine on an RPi3 as remote machine connected to my laptop running kstars-bleeding.
Lesson learned: once you tried many things, it is best possible that you screwed up the OS. Best solution is to do a brute-force reinstall from scratch.

Sorry for insisting the last few posts.
I will put my gear out this evening and start actively using all the features. In the case of issues, I will report back.

Stefan

Please Log in or Create an account to join the conversation.

Pentax K-5; Samyang 800mm F8.0;Sky-Watcher ED80 D=80mm F=600mm;ZWO ASI120MC
Time to create page: 0.341 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica