Welcome, Guest
Username: Password: Remember me
25 Jul 2018
Glad to announce of release of INDI Library v1.7.4 on 2018-07-25. A few drivers were added in this release as we continue to improve & stabilize existing drivers.
Read More...
  • Page:
  • 1
  • 2

TOPIC: Canon T6i, Connection problem

Canon T6i, Connection problem 3 months 1 week ago #26566

Hi, we are trying to put to work a canon T6i DSLR camera, and when we start INDI sever in local mode we get the following error:

"No cameras detected.Check power and make sure camera is not mounted by other programs and try again."

We attach the logs:
2018-06-14T15:59:14: [INFO] Location updated: Longitude (-74.1) Latitude (4.63306)
2018-06-14T15:59:14: [INFO] Device configuration saved.
2018-06-14T15:59:14: [INFO] Saving device configuration...
2018-06-14T15:59:14: [INFO] Device configuration applied.
2018-06-14T15:59:14: [INFO] Location updated: Longitude (-74.1) Latitude (4.63306)
2018-06-14T15:59:14: [INFO] Loading device configuration...
2018-06-14T15:59:14: [INFO] Mount is unparked.
2018-06-14T15:59:14: [INFO] Telescope simulator is online.


2018-06-14T10:59:19 Unable to establish:
+ Canon DSLR
Please ensure the device is connected and powered on.
2018-06-14T10:59:14 Guider port from Telescope Simulator is ready.
2018-06-14T10:59:14 Telescope Simulator is online.
2018-06-14T10:59:14 INDI services started on port 7624.
2018-06-14T10:59:14 Starting INDI services...
Attachments:

Please Log in or Create an account to join the conversation.

Canon T6i, Connection problem 3 months 1 week ago #26569

Is it getting detected by the OS? is battery OK near full? any other programs using the camera? What OS?

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Canon T6i, Connection problem 3 months 1 week ago #26570

Hi, thanks for the fast reply,

yes we are using DarkTable and we get image whit the camera, the battery looks full, we close the program and the error still shows up. the OS Is Linux 16.04 LTS

In console we use gphoto2 and it works:
piaktipik@piaktipik-MacBookPro:~$ gphoto2 --capture-image
New file is in location /capt0000.cr2 on the camera
New file is in location /capt0000.jpg on the camera

Please Log in or Create an account to join the conversation.

Canon T6i, Connection problem 3 months 6 days ago #26651

some ideas of what can we do to identify the exact problem?

Please Log in or Create an account to join the conversation.

Canon T6i, Connection problem 3 months 6 days ago #26652

You said you use linux and then on console shows MacBookPro? so which is which?

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Canon T6i, Connection problem 3 months 6 days ago #26658

Yes, sorry for not be clear, we test the camera in a Linux OS mounted in a MacBookPro, and in other computer (asus) whit Linux too, but we get the same results

Please Log in or Create an account to join the conversation.

Canon T6i, Connection problem 3 months 5 days ago #26659

You should try in OS X KStars on the MacBook Pro in a local indiserver and see if you get the same results.
The following user(s) said Thank You: knro

Please Log in or Create an account to join the conversation.

Canon T6i, Connection problem 3 months 5 days ago #26670

We dont have OS X available. We want use Linux 16.04 LTS to control the camera canon T6i and a Meade telescope. So far we have been able to control the telescope, but the camera is not reachable yet. A further step will be to have all controls though a raspberry pi, but we need to be able to control the canon dslr.

We managed to get a different problem (not sure it is an error yet). Here I attached two screenshots and a log file on the start up of the Kstars control system.

The camera has a full battery, it is in manual mode, no other software is being used or is loaded, darktable was used to test the camera and got pictures, console commands were able to take photos too.

2018-06-19T19:00:30: [INFO] Location updated: Longitude (0) Latitude (51.4683)
2018-06-19T19:00:30: [INFO] Device configuration saved.
2018-06-19T19:00:30: [INFO] Saving device configuration...
2018-06-19T19:00:29: [INFO] Device configuration applied.
Attachments:

Please Log in or Create an account to join the conversation.

Canon T6i, Connection problem 3 months 4 days ago #26674

Try this and post the debug file:
gphoto2 --debug --debug-logfile=gphoto.txt  --capture-image-and-download 

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Canon T6i, Connection problem 3 months 2 days ago #26717

Hi,

We run the command as you say:
gphoto2 --debug --debug-logfile=gphoto.txt --capture-image-and-download

The log file zipped is attached.
Attachments:

Please Log in or Create an account to join the conversation.

Canon T6i, Connection problem 3 months 2 days ago #26718

Hmm it appears OK, however, the libgphoto2 version is a bit old. Try to use a more recent version from the PPA:
sudo add-apt-repository ppa:mutlaqja/libgphoto2
sudo apt-get update
sudo apt-get -y dist-upgrade

Then try the driver again.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Canon T6i, Connection problem 2 months 4 weeks ago #26780

Hi, We update the libgphoto2 as you say, and we still get the same problem, the logs:

- INDI Control Panel:
2018-06-22T19:53:41: [INFO] Location updated: Longitude (0) Latitude (51.4683)
2018-06-22T19:53:41: [INFO] Device configuration saved.
2018-06-22T19:53:41: [INFO] Saving device configuration...
2018-06-22T19:53:41: [INFO] Device configuration applied.
2018-06-22T19:53:41: [INFO] Location updated: Longitude (0) Latitude (51.4683)
2018-06-22T19:53:41: [INFO] Loading device configuration...
2018-06-22T19:53:41: [INFO] Mount is unparked.
2018-06-22T19:53:41: [INFO] Telescope simulator is online.

-Ekos:
2018-06-22T14:53:45 Unable to establish:

+ Canon DSLR
Please ensure the device is connected and powered on.
2018-06-22T14:53:41 Guider port from Telescope Simulator is ready.
2018-06-22T14:53:41 Telescope Simulator is online.
2018-06-22T14:53:41 INDI services started on port 7624.
2018-06-22T14:53:41 Starting INDI services...
2018-06-22T14:53:06 INDI services stopped.
2018-06-22T14:53:04 Telescope Simulator is disconnected.
2018-06-22T14:53:03 Disconnecting INDI devices...
2018-06-22T14:50:49 Unable to establish:

+ Canon DSLR
Please ensure the device is connected and powered on.
2018-06-22T14:50:45 Guider port from Telescope Simulator is ready.
2018-06-22T14:50:45 Telescope Simulator is online.
2018-06-22T14:50:45 INDI services started on port 7624.
2018-06-22T14:50:45 Starting INDI services...

The camera is connected, battery full, manual mode, and darktable can use it normally but is close.

we attach the log file of the command:
gphoto2 --debug --debug-logfile=gphoto.txt --capture-image-and-download
Attachments:

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • 2
Time to create page: 0.155 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica