Welcome, Guest
Username: Password: Remember me
08 Apr 2018
INDI development team is happy to announce the release of INDI Library v1.7.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...

TOPIC: Ekos crash on Startup on MacOs High Sierra

Ekos crash on Startup on MacOs High Sierra 4 months 20 hours ago #23614

Do you have KStars logs to see exactly what was going on?

If you use the other Mac, does it do the same thing?

Please Log in or Create an account to join the conversation.

Re:Ekos crash on Startup on MacOs High Sierra 4 months 20 hours ago #23615

rlancaste wrote: Do you have KStars logs to see exactly what was going on?

If you use the other Mac, does it do the same thing?


I will starts test when i have more time. I‘ll install it new again and activate the logs. Maybe that will help. In the meantime i will use the macbook snd see if the problem occurs there too.

One idea i have is that maybe the setup with a second monitor could be the problem...


Gesendet von iPhone mit Tapatalk

Please Log in or Create an account to join the conversation.

Re:Ekos crash on Startup on MacOs High Sierra 4 months 20 hours ago #23616

I don't know, but I am currently using a big monitor connected via USB C with kstars right now. But it is not set to extend the displays, my laptop is closed and its showing the whole display.

Please Log in or Create an account to join the conversation.

Re:Ekos crash on Startup on MacOs High Sierra 3 months 2 weeks ago #23871

I have experienced an identical problem. I was getting familiar with Ekos on 1st March - 2nd March Stars crashed on startup. I found this discussion and followed the suggestions and deleted files from my (user) application support and preference folders. When I tried to start Kstars I did not get the dialogue and it crashed when it was on "URLs". I have found an unsatisfactory workaround, I have created a new user and kstars seems to run on that (at the moment) but I have not had much chance to see how robust it is.

It does seem to suggest that something has been left behind when I deleted the files.

Also, when I tried to re-download I got nothing from Safari and Chrome just said that the page does not work. I used the old disc image which I had in a back up.

I would like to get back to using Kstars/Ekos on my main user account (I also have a separate "Administrator" account for security.

Thanks,

JH

Please Log in or Create an account to join the conversation.

Re:Ekos crash on Startup on MacOs High Sierra 3 months 2 weeks ago #23872

2.9.3 for Mac is available for download, try again.
The following user(s) said Thank You: nmac

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Re:Ekos crash on Startup on MacOs High Sierra 3 months 2 weeks ago #23877

So the real issue here is that kstars requires certain files to be present to run, the files in the data directory and the kstarsrc preferences file. There are also language and astrometry files but they are optional. The preferences file is recreated if it is not found but the data directory needs to be copied to the right place with all of its files inside. I wrote some code awhile back that checks if the data directory is present and if not it gives you the option to copy it from inside the app to the right place. But of course if some files inside the data directory got deleted somehow but the directory is still present, it won’t work. So far this is the first two times this has happened since I ported kstars to Mac. I would like to know which files got deleted and why. Try emptying the trash.
The following user(s) said Thank You: Cornishman

Please Log in or Create an account to join the conversation.

Re:Ekos crash on Startup on MacOs High Sierra 3 months 2 weeks ago #23880

rlancaste wrote: So the real issue here is that kstars requires certain files to be present to run, the files in the data directory and the kstarsrc preferences file. There are also language and astrometry files but they are optional. The preferences file is recreated if it is not found but the data directory needs to be copied to the right place with all of its files inside. I wrote some code awhile back that checks if the data directory is present and if not it gives you the option to copy it from inside the app to the right place. But of course if some files inside the data directory got deleted somehow but the directory is still present, it won’t work. So far this is the first two times this has happened since I ported kstars to Mac. I would like to know which files got deleted and why. Try emptying the trash.


Don‘t know if it helps.
I managed to force kstars to ask for copying the data file again by deleting it and emptying the trash. This was, because kstars kept crashing to desktop when i wanted to start it again.
Then i had a session WITHOUT a crash, some hours maybe...
Another session crashed then after about 1 hour. The funny thing about this is, that NOW, i was able to start without crash now. And that is the status quo right now.
I do admit, that i have not yet installed the latest version.
What i want to say is, that i am not able to somehow reproduce the crash. Unfortunately it crashes totally random...

Cheers
Niki


Gesendet von iPhone mit Tapatalk

Please Log in or Create an account to join the conversation.

Re:Ekos crash on Startup on MacOs High Sierra 3 months 2 weeks ago #23881

Just checking, when you installed kstars, you didn't try to run it from the dmg correct? You just dragged the app from the dmg to your applications folder right?

Please Log in or Create an account to join the conversation.

Re:Ekos crash on Startup on MacOs High Sierra 3 months 2 weeks ago #23882

rlancaste wrote: Just checking, when you installed kstars, you didn't try to run it from the dmg correct? You just dragged the app from the dmg to your applications folder right?


Yes, drag and drop to applications.


Gesendet von iPhone mit Tapatalk

Please Log in or Create an account to join the conversation.

Time to create page: 0.124 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica