Welcome, Guest
Username: Password: Remember me
08 Apr 2018
INDI development team is happy to announce the release of INDI Library v1.7.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...
  • Page:
  • 1

TOPIC: AP experimental

AP experimental 1 month 3 weeks ago #25709

  • manu
  • manu's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
Hi,

My name is Emmanuel and I am new on this forum.

While setting up my installation, I've encountered a problem with the park position 3 and the experimental AP driver.
When using the park position 3, the park / unpark cycle does not work properly. The unpark from p3 is OK, but during the park to P3, the mount slews to some position it fails to reach because the travel is going through altitude below 0... This has to do with the Azimuth set to 0:00:00. if I set the same Az value than the one used by the ascom driver (359:59:50) it works flawlessly with the indi driver. the park/unpark works as expected. I can reproduce the problem without indi using the bookmark feature of the ascom driver. I reported this subject to AP support which basically says it is normal...

Before to submit a pull request that would prevent the default to be set to az:0:0:0, I'd like to know if anyone has encountered this problem and if we can consider the ascom workaround as an acceptable way to go.

thanks
Manu

Please Log in or Create an account to join the conversation.

AP experimental 1 month 3 weeks ago #25712

Manu, I haven't encountered this with Park3 but have with Park 1 and Park 4 and your solution makes sense to me. In fact I can fix my problems with Park1 and Park 4 by simply changing the AZ to be slightly off the Meridian in a direction that will force the mount onto the correct side of the pier. I've tested your coordinate for Park 3 and it works for me. I think the root of the problem is an Az directly on the meridian is indeterminate to which side of the pier the mount choses.

Hopefully @mikefulb the author will see this and chime in.

If you do end up doing your pull request I would ask that you update the Park 1 and Park 4 positions to be as ASCOM as well.

THANK YOU!!
David

Please Log in or Create an account to join the conversation.

Last Edit: by deisenlord.

AP experimental 1 month 1 week ago #25973

have just verified that that latest build of the Astro-Physics Experimental driver fixes the problem I had with Park Positions. They are all correct for me with a CP3 and V level firmware. I did my test on a source code build under OSX. My stellarmate is still on the old code and still has the problem.

Thanks @mikefulb !!
The following user(s) said Thank You: knro

Please Log in or Create an account to join the conversation.

Last Edit: by deisenlord.
  • Page:
  • 1
Time to create page: 0.161 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica