Welcome, Guest
Username: Password: Remember me
20 Aug 2017
INDI development team is happy to announce the release of INDI Library v1.5.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...

TOPIC: Items from last night's INDI/Ekos/Kstars session

Items from last night's INDI/Ekos/Kstars session 3 weeks 3 days ago #19760

Update your RPI3 to latest libindi. Change EQMod guide rate to 0.5 instead of 0.3 (I made 0.5 the default now). Increase pulse width to 1500ms or 2000ms. Make sure you have good polar alignment. Download latest KStars 2.8.4 (Just released few minutes ago).
The following user(s) said Thank You: tseckler, pcxz, HelgeMK
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
The topic has been locked.

Items from last night's INDI/Ekos/Kstars session 3 weeks 3 days ago #19762

Will do ahead of the next session!

Would you have any idea on the log file? Can I influence that path from the windows laptop-client? Hitting the log button does not trigger anything - or is this addressed with the latest KStars update you mentioned?

Thanks once again!
The topic has been locked.

Items from last night's INDI/Ekos/Kstars session 3 weeks 2 days ago #19769

Currently, only way is to login to your RPI3 and move the log file to your main machine. Maybe use something like FileZilla.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
The topic has been locked.

Items from last night's INDI/Ekos/Kstars session 3 weeks 2 days ago #19779

  • maudy
  • maudy's Avatar
  • Away
  • Gold Boarder
  • Gold Boarder
  • Posts: 308
  • Karma: 2
  • Thank you received: 23
Perhaps these two scripts can help gather the logs up on RPI3/Ubuntu. They are not pretty; I am not good at bash, or command line.

pkg_logs.sh - will put all the logs into a zip file
sudo zip -r ./`date +"%Y%m%d"`_kstar_ekos_logs.zip ~/.local/share/kstars/logs /root/.indi/logs ~/.indi/logs ~/PHD2

renew_logs.sh - will remove the logs, which you may wish to do to isolate reproducing something,
sudo rm -rf /root/.indi/logs
sudo rm -rf ~/.local/share/kstars/logs
sudo rm -rf ~/.indi/logs
sudo rm -rf ~/tmp/logs
sudo rm -rf ~/PHD2


I have been looking to run these are startup and shutdown scripts, and just have not got there yet.
The topic has been locked.

Items from last night's INDI/Ekos/Kstars session 2 weeks 4 days ago #19875

HelgeMK wrote that he could not produce log files, because there aren't any. I have exactly the same problem. My setup is WIndows 10 KStars 2.8.3 and a Raspberry Pi 3 with Ubuntu Mate16.04.
When checking the Pi, there is no logs folder in .indi. In KStars the button "Show Indi Logs" does nothing. KStars session log on the Windows machine is OK.

I have also the problem that Remote solving with Astrometry driver in my profile, does not report back to KStars. If the .fits is resolved I cannot check, because there are no logs.

Any thoughts?
Windows 10 64-bit with KStars 2.8.4, Embedded Raspberry PI 3 with Ubuntu Mate 16.4, Skywatcher HEQ5 PRO Synscan, Robtics 80mm F7 doublet apochromaat refractor, ZWO ASI174MC-Cool
The topic has been locked.

Items from last night's INDI/Ekos/Kstars session 2 weeks 4 days ago #19876

Dear berendj,

My first problem was that I was not familiar with the concept of "hidden files", so eventually I found them. Another issue was, that I missed out to activate "To log file" under the options tab.

As regards Astrometry: Did you chose "Astrometry" under Aux 1 in the Ekos Profile?

Best, Helge

Not sure if that may help?
The topic has been locked.

Items from last night's INDI/Ekos/Kstars session 2 weeks 3 days ago #19881

Dear Helge,

The hidden files is not my problem. The hidden .indi folder is there, but it contains only the profiles.db.

The other problem is solved. I installed yesterday evening the KStars 2.8.4 on my windows machine and reloaded the latest daily indi release. Remote solving is now working. I have indeed Astronomy under Aux 1 in the profile.

So my problem remains: why is non of the drivers writing its log. The logs folder and the files are not even created. The chmod value of .indi is 775.

Regards, Bert
Windows 10 64-bit with KStars 2.8.4, Embedded Raspberry PI 3 with Ubuntu Mate 16.4, Skywatcher HEQ5 PRO Synscan, Robtics 80mm F7 doublet apochromaat refractor, ZWO ASI174MC-Cool
The topic has been locked.

Items from last night's INDI/Ekos/Kstars session 2 weeks 3 days ago #19882

Well, not to state the obvious, but did you enable logging for the drivers in INDI Control Panel and selected to File?
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
The topic has been locked.

Items from last night's INDI/Ekos/Kstars session 2 weeks 3 days ago #19885

Hi Jasem,

I noticed the absence of log files a few nights ago when working with the real stuff. But due to bad weather I'm using the simulators (remote on the Pi) to reproduce the problem. To keep things simple I only use three drivers Telescope Simulator, CCD Simulator and Astrometry.

In all three drivers I have checked Debug Enabled (without it the Logging Levels are not shown) and Logging Levels set to Errors, Warnings, Messages and Driver Debug. In the telescope also Scope Verbose.

Log output is set to "To Log File". in all three drivers, but the .indi map on the Pi stays empty but for the profiles.db, so no logs folder nor log files.

Regards, Bert
Windows 10 64-bit with KStars 2.8.4, Embedded Raspberry PI 3 with Ubuntu Mate 16.4, Skywatcher HEQ5 PRO Synscan, Robtics 80mm F7 doublet apochromaat refractor, ZWO ASI174MC-Cool
Last Edit: by berendj.
The topic has been locked.

Items from last night's INDI/Ekos/Kstars session 2 weeks 3 days ago #19889

After getting a new micro SD card and loading it with my Raspberry Jessie image, I suddenly had logs!
I saw that on the pi the log is created in /home/pi/.indi, but when I switch to the sd card with Ubuntu Mate the logs are created in /root/.indi, while my root is /home/bert and this must be the reason that the logs are not created.

The question is now, where (in which file) is this root defined?

I hope that with this explanation an answer will come up.

Regards, Bert
Windows 10 64-bit with KStars 2.8.4, Embedded Raspberry PI 3 with Ubuntu Mate 16.4, Skywatcher HEQ5 PRO Synscan, Robtics 80mm F7 doublet apochromaat refractor, ZWO ASI174MC-Cool
The topic has been locked.

Items from last night's INDI/Ekos/Kstars session 2 weeks 2 days ago #19896

I think you ran INDI Web Manager as root and this is why it was writing to to /root/.indi and not $HOME/.indi

This is why it is recomended NOT to run the Web Manager as root.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
The topic has been locked.

Items from last night's INDI/Ekos/Kstars session 2 weeks 2 days ago #19898

Same problem here with two QHYCCD cameras. But they arent working together undependant of the driver settings. If i choose one driver for both...nope.
If i choose qhyccd for CCD an qhyccd for Guider, only one of the cameras operates (if i am lucky).
Seems that EKOS indi is not in a stable condition. Hope that these problems dont occur when you are operating your observatory remote and are a few (hundred) miles
away, which is one of the main reasons for indi. :-(
I havent tried to use a second rpi3 and attach the second camera to that device. Could be a cheap workaround until the driver problems are solved.
Robert
Last Edit: by astrorob.
The topic has been locked.
Time to create page: 0.366 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica