Welcome, Guest
Username: Password: Remember me
27 Feb 2017
INDI development team is happy to announce the release of INDI Library v1.4.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers. Several improvements and enhancements are included in this release including native support for Cygwin and MacOS platforms in addition to Linux, BSD, and Windows (Client only).
Read More...

TOPIC: Solver fails consistently

Solver fails consistently 2 weeks 1 day ago #17677

  • gbeaton
  • gbeaton's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 31
  • Thank you received: 0
Online capture&solve is working but not polar align. So is WCS required? Because its not enabled in solver options, nor on CCD options, yet the solver complains its missing or not enabled. Turned on WCS and got this - also have position checked and previously correctly guider FL to 176mm: some error certainly due to unaligned guide cam.

2017-07-06T22:59:15 Solution coordinates: RA (15h 14m 41s) DEC (-7° 32' 01") Telescope Coordinates: RA (15h 17m 57s) DEC (-9° 26' 42")
2017-07-06T22:59:15 WCS information updated. Images captured from this point forward shall have valid WCS.
2017-07-06T22:59:15 Solver completed in 61 seconds.

Cool! Now I see the FOV box on the Kstars sky chart.


Then tried Polar align:

2017-07-06T23:09:24 Error parsing parity.
2017-07-06T23:09:21 Uploading file...
2017-07-06T23:09:21 Image received.
2017-07-06T23:09:20 Capturing image...
2017-07-06T23:09:20 Solver timed out
2017-07-06T23:06:23 Upload complete. Waiting for astrometry.net solver to complete...
2017-07-06T23:06:20 Uploading file...
2017-07-06T23:06:20 Image received.
2017-07-06T23:06:19 Capturing image...
2017-07-06T23:06:19 Solver timed out
2017-07-06T23:03:23 Upload complete. Waiting for astrometry.net solver to complete...
2017-07-06T23:03:19 Uploading file...
2017-07-06T23:03:19 Image received.
2017-07-06T23:03:17 Capturing image...
2017-07-06T23:02:29 Clearing mount Alignment Model...

When I went back to the capture&solve, it worked again so something wrong with polar align.

Please Log in or Create an account to join the conversation.

Last Edit: by gbeaton.

Solver fails consistently 2 weeks 1 day ago #17678

  • gbeaton
  • gbeaton's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 31
  • Thank you received: 0
Whoa!!! Offline solver only took 4 seconds!!!:

2017-07-06T23:16:23 Solution coordinates: RA (15h 14m 39s) DEC (-7° 35' 44") Telescope Coordinates: RA (15h 17m 57s) DEC (-9° 26' 42")
2017-07-06T23:16:23 Solver completed in 4 seconds.
2017-07-06T23:16:19 Starting solver...
2017-07-06T23:16:19 Index file index-4204 is missing. Astrometry.net would not be able to adequately solve plates until you install the missing index files. Download the index files from www.astrometry.net
2017-07-06T23:16:19 Image received.
2017-07-06T23:16:18 Capturing image...


But offline polar align does not work either:

2017-07-06T23:21:51 Solver aborted after 52 seconds
2017-07-06T23:20:59 Starting solver...
2017-07-06T23:20:59 Image received.
2017-07-06T23:20:58 Capturing image...
2017-07-06T23:20:58 Solver timed out
2017-07-06T23:17:58 Starting solver...
2017-07-06T23:17:58 Image received.
2017-07-06T23:17:56 Capturing image...
2017-07-06T23:17:50 Clearing mount Alignment Model...

Please Log in or Create an account to join the conversation.

Last Edit: by gbeaton.

Solver fails consistently 1 week 3 days ago #17808

Is Ekos solver using astrometry engine (same as AstroTortilla) ? Because I see a couple of switches that AstroTortilla uses that are not used in Ekos

For exemple :

--sigma 1 : defines the noise tolerance in analysing your captured image for plate solving

-r : sort the stars in order of brightest first, therefore allowing to optimise the plate solving process as it starts with the brightest stars in your image

--objs 100 : to use a maximum of 100 stars for the plate solving (the developers generally recommend between 100 and 200 stars)

Also I noticed that -O and --no-plots are not checked in the "edit solver options" window but appear in the line [Options] under the "Solver Options" section is this by design ?

Please Log in or Create an account to join the conversation.

Solver fails consistently 1 week 3 days ago #17810

I can answer a couple of these questions.

Gbeaton, i dont know about any issues with the polar align function, since I use my polar scope, but i can say that sometimes there can be problems plate solving near the pole. It can help to try a couple of locations a little farther from the pole.

Also gbeaton, yes offline solver is often much faster and more reliable than the online one but requires tweaking. Once you get its settings configured well for your system, it can often solve in even less time than the 4 seconds you stated.

Vox45, ekos uses the astrometry.net software which i do think is what astrotortilla uses. As for the missing options, you could try them out and see if they help. Astrometry.net has lots of capabilities and options, no Ekos does not have all of them built in as checkboxes but they can still be used in ekos by typing them in the options line in or tested by running it from the command line.

The -O option is required in Ekos since the -o option overwrites the previous solution files and if that were not included, it would fail to solve the next image since it cannot overwrite. And the noplots option is required since ekos does not use the plots produced and they just take more time to produce.

Please Log in or Create an account to join the conversation.

Solver fails consistently 1 week 3 days ago #17812

Thank you for your answer.

(1) "The -O option is required in Ekos since the -o option overwrites the previous solution files and if that were not included"

-> what I meant is that when I open the "edit solver options" the checkbox for the -O is not cheked, yet the option appears in the option line. This is odd and I was wondering if this is to be expected, maybe some kind of refresh needs to happen ?

(2) "Astrometry.net has lots of capabilities and options, no Ekos does not have all of them built in as checkboxes but they can still be used"

-> that is nice to know :) While I was poking around I noticed that the infobox on the "custom" field in the Solver options says : "additional optional astrometry.net options" so that settles it :)

I have to say that the more I learn about Ekos/Kstars the more impressed I am ... I think I am a bit of pain in the b**t by asking so many pointed questions but I need to know a lot of the details as I will train some club members on it in a couple of weeks and I'm sure I will be bombarded with the same kind of questions...

Thank you for taking the time to reply !

Please Log in or Create an account to join the conversation.

Last Edit: by Vox45.

Solver fails consistently 1 week 3 days ago #17816

@gbeaton, @rlancaste

I am also seeing that PAA never completes. It takes the 3rd image, completes the solve, then just hangs there with the 'Capture' button greyed out. Or the entire KStars will crash sometimes. I see this with the CCD simulator and telescope simulator, so not a driver issue.

I reported this here .

Meanwhile, the regular Capture and Solve works fine, with the Sync action, all that works fine.

PAA was working fine until around the 4th of July or so.

Also, I see the same thing regarding WCS: if I disable WCS in the solver options and in INDI, but still the code tries to do it, and the code crashes in a method called loadWCS, which points to where the issue may lie.

Please Log in or Create an account to join the conversation.

Solver fails consistently 1 week 2 days ago #17832

Vox45 wrote: Thank you for your answer.

(1) "The -O option is required in Ekos since the -o option overwrites the previous solution files and if that were not included"

-> what I meant is that when I open the "edit solver options" the checkbox for the -O is not cheked, yet the option appears in the option line. This is odd and I was wondering if this is to be expected, maybe some kind of refresh needs to happen ?


The -O option is supposed to be a disabled checkbox that is permanently checked. That one and the noplots option. Is it not that way on your system? I can take a look and see if that was changed recently. You should not be able to uncheck it.

Please Log in or Create an account to join the conversation.

Solver fails consistently 1 week 2 days ago #17833

kbahey wrote: @gbeaton, @rlancaste

I am also seeing that PAA never completes. It takes the 3rd image, completes the solve, then just hangs there with the 'Capture' button greyed out. Or the entire KStars will crash sometimes. I see this with the CCD simulator and telescope simulator, so not a driver issue.

I reported this here .

Meanwhile, the regular Capture and Solve works fine, with the Sync action, all that works fine.

PAA was working fine until around the 4th of July or so.

Also, I see the same thing regarding WCS: if I disable WCS in the solver options and in INDI, but still the code tries to do it, and the code crashes in a method called loadWCS, which points to where the issue may lie.


Yes, Jasem made a change to wcs so that it does not always load when an image is loaded, but instead is loaded when needed. This also broke a couple of the methods that I had written, but I have since corrected them. I dont have much experience with the polar alignment helper, maybe Jasem can help.

Please Log in or Create an account to join the conversation.

Solver fails consistently 1 week 2 days ago #17834

The problem is now resolved in KStars GIT.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Solver fails consistently 1 week 2 days ago #17836

I am no dev and this could be completely irrelevant but it would be a shame not to report this if in the end it was relevant ...

So I was looking at Astrometry GitHb and saw that the release 0.67 (which is the current one I get from the ppa) has this note attached:

@dstndstn dstndstn released this on 25 Jan 2016 · 279 commits to master since this release
only minor changes since 0.66; tagging this release to pick up new python API calls for WCS parsing from fitsio headers.

github.com/dstndstn/astrometry.net/releases

I could not help notice that it mentions WCS so ... Please humour me, maybe it is nothing but I thougth I should raise a flag.

Please Log in or Create an account to join the conversation.

Last Edit: by Vox45.

Solver fails consistently 1 week 2 days ago #17837

  • gbeaton
  • gbeaton's Avatar Topic Author
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 31
  • Thank you received: 0

knro wrote: The problem is now resolved in KStars GIT.


Great news!

I eagerly await the next release - thanks!

Please Log in or Create an account to join the conversation.

Solver fails consistently 1 week 1 day ago #17861

Does kstars-bleeding 5:17.04+201707072129~ubuntu17.04.1 have this fix or will it come through in a day or two?

Please Log in or Create an account to join the conversation.

Time to create page: 0.398 seconds

Login

3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!

Gallery

Replica

Why INDI

Replica