Welcome, Guest
Username: Password: Remember me
20 Aug 2017
INDI development team is happy to announce the release of INDI Library v1.5.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...
  • Page:
  • 1
  • 2

TOPIC: Auto focus failed after meridian flip

Auto focus failed after meridian flip 3 months 3 days ago #18626

Hi everybody,

I'm facing a curious problem. I scheduled a projet with the ekos scheduler to be able to sleep while my setup is imaging :D . Everything works fine : unpark, slew and tracking, focus, astrometry and guiding and then starting the sequence defined shots.
I checked the box to do the meridian flip if ha is > to 0.1.
The mount does the meridian flip but after that it tries to launch autofocus sequence, it take a first capture and then... nothing. So the process is stuck and no more images are taken... In autofocus I let ekos choose a star to perform focus.

Is somebody experiencing the same problem ?

Regards,

Davy

Please Log in or Create an account to join the conversation.

Davy Hubert
Setup : 200/900 Newtonian Scope; Orion Atlas Eq-G mount; Trius-SX694 CCD; SX-Lodestar X2 guide cam; SX FilterWheel; Moonlite Focuser
Last Edit: by boulabytes.

Auto focus failed after meridian flip 3 months 3 days ago #18637

Got logs from the night?

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Auto focus failed after meridian flip 3 months 3 days ago #18641

Hi Jasem,
Thank you for your response.
A new session is launched right now. I'll send you the logs tomorrow. :)

Please Log in or Create an account to join the conversation.

Davy Hubert
Setup : 200/900 Newtonian Scope; Orion Atlas Eq-G mount; Trius-SX694 CCD; SX-Lodestar X2 guide cam; SX FilterWheel; Moonlite Focuser
Last Edit: by boulabytes.

Auto focus failed after meridian flip 3 months 2 days ago #18642

Hi Jasem,

Here are the logs of this night.

File Attachment:

File Name: logs_ekos.txt.tar.gz
File Size: 487 KB
Attachments:

Please Log in or Create an account to join the conversation.

Davy Hubert
Setup : 200/900 Newtonian Scope; Orion Atlas Eq-G mount; Trius-SX694 CCD; SX-Lodestar X2 guide cam; SX FilterWheel; Moonlite Focuser

Auto focus failed after meridian flip 3 months 1 day ago #18682

Thanks that was quite helpful and I'm investigating it. Can you please attach the sequence file you used (.esq) ?
The following user(s) said Thank You: boulabytes

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Auto focus failed after meridian flip 3 months 1 day ago #18690

Isn't that related to this issue , which has been just fixed?

Please Log in or Create an account to join the conversation.

Auto focus failed after meridian flip 3 months 1 day ago #18693

Negative, it's a different issue.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Auto focus failed after meridian flip 3 months 1 day ago #18699

Hi,

Thank you :) .

Here is my sequence file :

File Attachment:

File Name: Projet_IC1396_OHS.esq.tar.gz
File Size: 1 KB


Regards,

Davy
Attachments:

Please Log in or Create an account to join the conversation.

Davy Hubert
Setup : 200/900 Newtonian Scope; Orion Atlas Eq-G mount; Trius-SX694 CCD; SX-Lodestar X2 guide cam; SX FilterWheel; Moonlite Focuser

Auto focus failed after meridian flip 3 months 1 day ago #18706

Thanks, so it looks like that focus actually completed just fine after meridian flip with the threshold being below the ones specified at the file (~2.1). However, it is still perplexing why it failed later on, there are no error indications. I added more extensive debugging statements to focus module which should be in the next release and should hopefully catch any issues if they even occur.

Seems it is very hard to reproduce this.. if you find a way to reproduce this behavior with the simulators, please let me know.
The following user(s) said Thank You: boulabytes

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Auto focus failed after meridian flip 3 months 22 hours ago #18711

Ok, I'tried to repoduce it with simulator but it failed to flip... anyway I give you the logs

File Attachment:

File Name: simulators_log.txt.tar.gz
File Size: 76 KB


However, I faced this issue each time I launched the scheduler with my real setup. You're right, the focus completed just fine, but in fact the capture module was stuck waiting the end of the focus procedure.
The thing that blow my mind is trying to figure out why this phenomenon happens only after the meridian flip... if I remember well, the sequence was :
1. meridian flip
2. astrometry
3. guiding
4. focusing
I noticed that after the focus completed the guiding process was correctly resumed (I checked the "suspend guiding" box in the focus module), but... not the capture.
Attachments:

Please Log in or Create an account to join the conversation.

Davy Hubert
Setup : 200/900 Newtonian Scope; Orion Atlas Eq-G mount; Trius-SX694 CCD; SX-Lodestar X2 guide cam; SX FilterWheel; Moonlite Focuser

Auto focus failed after meridian flip 3 months 16 hours ago #18721

yes something is amiss but I'm not exactly sure how to locate it. With the extra logs in 2.8.2 I think we would be able to pin the issue. Thank you for your patience! 2.8.2 should be out in a couple of days.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Auto focus failed after meridian flip 3 months 14 hours ago #18723

Hi,

It's ok for me, obviously, I can wait :-) .
Thank you for your job :)

Davy

Please Log in or Create an account to join the conversation.

Davy Hubert
Setup : 200/900 Newtonian Scope; Orion Atlas Eq-G mount; Trius-SX694 CCD; SX-Lodestar X2 guide cam; SX FilterWheel; Moonlite Focuser
  • Page:
  • 1
  • 2
Time to create page: 0.177 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica