Welcome, Guest
Username: Password: Remember me
20 Aug 2017
INDI development team is happy to announce the release of INDI Library v1.5.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...
  • Page:
  • 1

TOPIC: Can't open ekos in kstars

Can't open ekos in kstars 1 month 4 weeks ago #20133

  • astro_g
  • astro_g's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 13
  • Thank you received: 1
Hi,

This is weird. I compiled the last version of kstars from git. Ekos and indi are "gone": there are no icons for them. I thought something funny was going on with the toolbar, but if I edit it, there are no actions available (for ekos or indi). Also, in the menus, I can't find any entry for them.

Otherwise kstars runs fine.

Previously, I had already compiled the last version of libindi from git.

Obviously I must be doing something wrong because I seem to be the only one who has this bug. I can't find any other reference.

Ideas?

Thank you very much.

Please Log in or Create an account to join the conversation.

Can't open ekos in kstars 1 month 4 weeks ago #20134

When you compiled KStars, it didn't detect INDI and therefore no Ekos. Make sure your INDI is correctly installed (cmake -DCMAKE_INSTALL_PREFIX=/usr) and make sure there is no INDI /usr/local

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Can't open ekos in kstars 1 month 4 weeks ago #20138

  • astro_g
  • astro_g's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 13
  • Thank you received: 1
Yes, i use cmake with -DCMAKE_INSTALL_PREFIX=/usr both for libindi and kstars.

When compiling and installing libindi everythings seems ok to me:
(...)
[ 99%] Built target indi_paramount_telescope
[100%] Built target indi_gemini_focus
Install the project...
-- Install configuration: "Debug"
-- Installing: /usr/bin/indiserver
-- Installing: /usr/lib/x86_64-linux-gnu/libindiclient.a
-- Installing: /usr/include/libindi/baseclient.h
-- Installing: /usr/lib/x86_64-linux-gnu/libindidriver.a
-- Installing: /usr/lib/x86_64-linux-gnu/libindidriver.so.1.5.0
-- Installing: /usr/lib/x86_64-linux-gnu/libindidriver.so.1
-- Installing: /usr/lib/x86_64-linux-gnu/libindidriver.so
-- Installing: /usr/bin/indi_imager_agent
-- Set runtime path of "/usr/bin/indi_imager_agent" to ""
(...)

The libraries seem to be there:
xxx@yyy:~$ ls -l /usr/lib/x86_64-linux-gnu/libindidriver.so.1.5.0 /usr/lib/x86_64-linux-gnu/libindiclient.a
-rw-r--r-- 1 root root 5467400 oct 12 18:18 /usr/lib/x86_64-linux-gnu/libindidriver.so.1.5.0
-rw-r--r-- 1 root root 1310550 oct 12 18:18 /usr/lib/x86_64-linux-gnu/libindiclient.a

Later, when doing cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Debug ../../kstars/ :
(...)
-- Checking for module 'libindi'
--   Found libindi, version 1.5.0
-- Found INDI: , /usr/include/libindi
-- Found INDI Client Library: /usr/lib/x86_64-linux-gnu/libindiclient.a
-- Found INDI: /usr/lib/x86_64-linux-gnu/libindiclient.a, /usr/include/libindi
(...)

When compiling, I'm not under the impression it's compiling anything ekos-related.

Also, I can't see references to anything indi in the executable:
xxx@yyy:~$ ldd /usr/bin/kstars|grep -i indi
xxx@yyy:~$ 

┬┐Anything else I can check?

Thank you.

Please Log in or Create an account to join the conversation.

Can't open ekos in kstars 1 month 4 weeks ago #20139

I am not following up with Raspbian, I just have one that is building the package and it's Jessie. If I upgrade that to Stretch then Jessie packages stopped. Is it safe to assume most users on Stretch now?

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Can't open ekos in kstars 1 month 4 weeks ago #20141

  • astro_g
  • astro_g's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 13
  • Thank you received: 1
This is a regular PC running Debian testing (buster), it's not a raspberry pi.

Please Log in or Create an account to join the conversation.

Can't open ekos in kstars 1 month 4 weeks ago #20143

sorry that was a reply to another thread that somehow ended up here. Did you make install kstars? it was installed to /usr/bin ?

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Can't open ekos in kstars 1 month 4 weeks ago #20145

  • astro_g
  • astro_g's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 13
  • Thank you received: 1
Nevermind, it resolved itself when I started from scratch, completely removing the build directories for indi and kstars and starting again with cmake, make, make install. Whatever the problem was, it went away with the old builds.

Now I have a second system with exactly the same problem and I hope to apply the same "solution".

Thank you!

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.144 seconds

Login

3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!
´╗┐

Gallery

Replica

Why INDI

Replica