Welcome, Guest
Username: Password: Remember me
08 Apr 2018
INDI development team is happy to announce the release of INDI Library v1.7.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...

TOPIC: Keep getting 'device or resource busy' error when connecting

Keep getting 'device or resource busy' error when connecting 3 months 1 week ago #23980

  • nmac
  • nmac's Avatar
  • Away
  • Gold Boarder
  • Gold Boarder
  • Posts: 305
  • Karma: 2
  • Thank you received: 60
Onde simple thing tha drived me almost nuts!
Change the rfcomm0 device permissions to your user and try again, I had to do just that, even if the user is in the dialout group.

"sudo chown user:user /dev/rfcomm0", where user is your username.

This after the pair and trust and before the connect.

Please Log in or Create an account to join the conversation.

(PT) SC@ROS Observatory
x86_64 Atom PC / TS 6" F4 Newtonian / Canon 550D / GPU CC / Datyson T7M / Arduino Moonlite DC Clone- HEQ5 Pro
x86_64 C2D / Explore Scientific ES80480 / Atik 420m / ES FF 2" / ASI120MM - Arduino Moonlite DC Clone - Vixen GPD2
www.flickr.com/photos/139335144@N03/

Keep getting 'device or resource busy' error when connecting 3 months 1 week ago #23983

nmac wrote: Onde simple thing tha drived me almost nuts!
Change the rfcomm0 device permissions to your user and try again, I had to do just that, even if the user is in the dialout group.

"sudo chown user:user /dev/rfcomm0", where user is your username.

This after the pair and trust and before the connect.


Worth a try, but nothing changed, same exact responses when trying to connect.

HelgeMK wrote: Hm... did you try only to connect to the BT Adapter, leaving the cameras outside?

I had once an identification-problem with the serial ports when using Eq mount and Arduino based focuser, resolved with this approach:

indilib.org/support/tutorials/157-persis...al-port-mapping.html


Same results with nothing except the mount attached (It did complain about not finding the camera and guide camera).

Please Log in or Create an account to join the conversation.

Keep getting 'device or resource busy' error when connecting 3 months 1 week ago #23984

It somehow strikes me that it is not working. I have both the Shoestring BT adapters for eq5 and eq6 managed to get running with the instructions shared (I am using the astroberry image).

The only issue I was running into was that initially I bought the EqDir Adapter and got annoyed that I could not receive any signal - thought it was the BT Adapter... so maybe two other options:

Are you 100% sure about the address and did not pick up accidentally another BT device in your neighborhood?

Start with a fresh image and try again the procedure.

Please Log in or Create an account to join the conversation.

Keep getting 'device or resource busy' error when connecting 3 months 1 week ago #23986

HelgeMK wrote: It somehow strikes me that it is not working. I have both the Shoestring BT adapters for eq5 and eq6 managed to get running with the instructions shared (I am using the astroberry image).

The only issue I was running into was that initially I bought the EqDir Adapter and got annoyed that I could not receive any signal - thought it was the BT Adapter... so maybe two other options:

Are you 100% sure about the address and did not pick up accidentally another BT device in your neighborhood?

Start with a fresh image and try again the procedure.


The MAC address don't lie. I've verified it on other laptops, it's the correct BT device that's being connected. I've started with clean Ubuntu installs almost daily. With all the different things I've tried, I didn't want to take any chance of just continuing to work on a broken install.

Please Log in or Create an account to join the conversation.

Keep getting 'device or resource busy' error when connecting 3 months 1 week ago #23988

What version of Linux are you using?
Ubuntu Mate is popular here, even recommended. I use LUbuntu because I find it's a bit lighter weight and I like the plain theme. Perhaps try a different distro?

Please Log in or Create an account to join the conversation.

Keep getting 'device or resource busy' error when connecting 3 months 1 week ago #23989

Ihoujin wrote: What version of Linux are you using?
Ubuntu Mate is popular here, even recommended. I use LUbuntu because I find it's a bit lighter weight and I like the plain theme. Perhaps try a different distro?


Ubuntu Mate 16.04.2 for Raspberry Pi. I do have a laptop with Linux Mint but...going to try that and see if I can connect.

(EDIT) I fired up my Linux Mint laptop and had ZERO issues connecting and controlling the mount via Ekos. First I removed modemmanager, then used the Mint BT manager, connected and paired with that, then just just a quick and dirty command line rfcomm bind to /dev/rfcomm0. Fired up Ekos and the mount connected immediately. Was able to slew with manual controls and even pick targets and slew to them in Kstars (although it was all off target, it worked).

So. There has to be some issue with the Raspberry Pi. Windows doesn't have a prob connecting, Linux Mint doesn't have a prob connecting, but no matter what I do in Ubuntu Mate on the Pi3, I get errors.

(SECOND EDIT)

So I have a second Rasperry Pi 3 running another home project. I took that SD card out, installed Ubuntu Mate on a new SD and tried again. Same exact results as the other RPI. So my BT dongle works with no issues in Windows and Linux Mint, but fails the exact same way on 2 different Raspberry Pi's running Ubuntu Mate.

Please Log in or Create an account to join the conversation.

Last Edit: by TheRealEleven.

Keep getting 'device or resource busy' error when connecting 3 months 1 week ago #24009

TheRealEleven wrote: So I have a second Rasperry Pi 3 running another home project. I took that SD card out, installed Ubuntu Mate on a new SD and tried again. Same exact results as the other RPI. So my BT dongle works with no issues in Windows and Linux Mint, but fails the exact same way on 2 different Raspberry Pi's running Ubuntu Mate.


A few questions before we nail it ;-)
1. Do you have any custom changes to /boot/config.txt on you RPi system?
2. Do you use built-in BT or external dongle?
3. Can you connect to EQMod with miniterm /dev/rfcomm0 or any other serial terminal?
4. Can you connect to any other BT device with a serial terminal?

Regards

Radek

Please Log in or Create an account to join the conversation.

Keep getting 'device or resource busy' error when connecting 3 months 1 week ago #24010

Kaczorek wrote:

TheRealEleven wrote: So I have a second Rasperry Pi 3 running another home project. I took that SD card out, installed Ubuntu Mate on a new SD and tried again. Same exact results as the other RPI. So my BT dongle works with no issues in Windows and Linux Mint, but fails the exact same way on 2 different Raspberry Pi's running Ubuntu Mate.


A few questions before we nail it ;-)
1. Do you have any custom changes to /boot/config.txt on you RPi system?
2. Do you use built-in BT or external dongle?
3. Can you connect to EQMod with miniterm /dev/rfcomm0 or any other serial terminal?
4. Can you connect to any other BT device with a serial terminal?

Regards

Radek


My son and his GF are visiting for Spring Break so I broke the mount/scope down. I can bring out the RPI and test those things though, thanks for the suggestions. I'll just edit this post as I do the test. As for what I can tell you now:

1. The only changes I've ever made to /boot/config.txt is to add rfcomm bind hci0 MACADDRESS 1 &

2. I use the external dongle from Shoestring Astronomy LINK

3. I did try rfcomm1 once, but usually with the /boot/config.txt or even binding via command line it defaulted to rfcomm0.

4. I'll break out the RPI and try to connect my phone, I'd never considered something like that.

Please Log in or Create an account to join the conversation.

Keep getting 'device or resource busy' error when connecting 3 months 1 week ago #24011

TheRealEleven wrote: 1. The only changes I've ever made to /boot/config.txt is to add rfcomm bind hci0 MACADDRESS 1 &

I mean /boot/config.txt NOT /etc/rc.local. This is the place where you enable various overlays for RPi. One of them is to disable BT (internal), and this one can give you hard time. Just review the very end of the file and paste here these a few lines that are sitting there.

TheRealEleven wrote: 2. I use the external dongle from Shoestring Astronomy LINK

This might be the root cause of your problems. If you use Raspberry Pi 3 it has bluetooth built-in. Use it instead of an external dongle. If it is Raspberry Pi 2 you need to stick to a dongle, it does not have bluetooth device. In any case you need to pair the devices before successful binding. To do this start bluetoothctl in your terminal and run:
scan on
agent on
pair XX:XX:XX:XX:XX:XX
trust XX:XX:XX:XX:XX:XX

TheRealEleven wrote: 3. I did try rfcomm1 once, but usually with the /boot/config.txt or even binding via command line it defaulted to rfcomm0.

Either it is /dev/rfcomm0 or /dev/rfcomm1 depends on what is you bind command. I think now you mix internal BT device with external BT dongle. For RPi3 just disconnect the dongle and stick to internal BT device and bind it to /dev/rfcomm0 as you have already done.

TheRealEleven wrote: 4. I'll break out the RPI and try to connect my phone, I'd never considered something like that.

I don't think you can just connect to your phone. You need a BT serial device. If you don't have anything like this at you hand just skip this step.


PS. If you will not be able to get it through let me know. I can do it for you remotely.

Please Log in or Create an account to join the conversation.

Last Edit: by Kaczorek.

Keep getting 'device or resource busy' error when connecting 3 months 1 week ago #24025

Kaczorek wrote:

TheRealEleven wrote: 1. The only changes I've ever made to /boot/config.txt is to add rfcomm bind hci0 MACADDRESS 1 &

I mean /boot/config.txt NOT /etc/rc.local. This is the place where you enable various overlays for RPi. One of them is to disable BT (internal), and this one can give you hard time. Just review the very end of the file and paste here these a few lines that are sitting there.

TheRealEleven wrote: 2. I use the external dongle from Shoestring Astronomy LINK

This might be the root cause of your problems. If you use Raspberry Pi 3 it has bluetooth built-in. Use it instead of an external dongle. If it is Raspberry Pi 2 you need to stick to a dongle, it does not have bluetooth device. In any case you need to pair the devices before successful binding. To do this start bluetoothctl in your terminal and run:
scan on
agent on
pair XX:XX:XX:XX:XX:XX
trust XX:XX:XX:XX:XX:XX

TheRealEleven wrote: 3. I did try rfcomm1 once, but usually with the /boot/config.txt or even binding via command line it defaulted to rfcomm0.

Either it is /dev/rfcomm0 or /dev/rfcomm1 depends on what is you bind command. I think now you mix internal BT device with external BT dongle. For RPi3 just disconnect the dongle and stick to internal BT device and bind it to /dev/rfcomm0 as you have already done.

TheRealEleven wrote: 4. I'll break out the RPI and try to connect my phone, I'd never considered something like that.

I don't think you can just connect to your phone. You need a BT serial device. If you don't have anything like this at you hand just skip this step.


PS. If you will not be able to get it through let me know. I can do it for you remotely.


Ah yea I confused /etc/rc.local with /boot/config.txt. The only changes I make to config.txt is the normal headless settings. hdmi_force_hotplug=1 hdmi_group=2, and hdmi_mode=82. Nothing else is changed there.

As for the dongle, its the device that's plugged into my mount. I do use the RPI3's built in bluetooth to connect to my mount. I DO NOT use any external BT devices on the RPI itself.

Please Log in or Create an account to join the conversation.

Keep getting 'device or resource busy' error when connecting 3 months 1 week ago #24113

Perhaps install a different distribution of Linux on the Raspberry Pi. That may eliminate specific hardware issues.
I run lubuntu. Give that a shot.
The following user(s) said Thank You: TheRealEleven

Please Log in or Create an account to join the conversation.

Keep getting 'device or resource busy' error when connecting 3 months 1 week ago #24163

I got this tip from the INDI Support FAQ

You have read and write permissions to the port. In some Linux distros, this is not the default setting. Under Ubuntu, you need to add your user to the dialout group:

sudo adduser $USER dialout
Then you must restart your PC for this to take effect and try again.

Please Log in or Create an account to join the conversation.

Time to create page: 0.177 seconds

Login

3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica