Welcome, Guest
Username: Password: Remember me
08 Apr 2018
INDI development team is happy to announce the release of INDI Library v1.7.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...
  • Page:
  • 1

TOPIC: QSI and Lodestar cameras not able to be found

QSI and Lodestar cameras not able to be found 2 weeks 1 day ago #24867

Current build on Raspbian.

Nothing is being written to the log files but the following is displayed. Other devices are being found.

2018-04-08T11:42:06 Unable to establish the following devices:
+ QSI CCD
+ SX CCD
Please ensure each device is connected and powered on.
2018-04-08T11:42:04 WunderGround is online.
2018-04-08T11:42:03 Losmandy Gemini focuser is online.
2018-04-08T11:42:03 Guider port from Losmandy Gemini is ready.
2018-04-08T11:42:02 Losmandy Gemini is online.
2018-04-08T11:42:02 Microtouch focuser is online.
2018-04-08T11:42:00 INDI services started on port 7624.
2018-04-08T11:42:00 Starting INDI services...
2018-04-08T11:41:34 INDI services stopped.
2018-04-08T11:41:32 Microtouch is disconnected.
2018-04-08T11:41:32 Losmandy Gemini is disconnected.
2018-04-08T11:41:32 WunderGround is disconnected.
2018-04-08T11:41:32 Disconnecting INDI devices...
2018-04-08T11:34:29 WunderGround is online.
2018-04-08T11:28:35 Unable to establish the following devices:
+ QSI CCD
+ SX CCD
Please ensure each device is connected and powered on.
2018-04-08T11:28:32 WunderGround is disconnected.
2018-04-08T11:28:32 Losmandy Gemini focuser is online.
2018-04-08T11:28:32 Guider port from Losmandy Gemini is ready.
2018-04-08T11:28:32 Losmandy Gemini is online.
2018-04-08T11:28:31 Microtouch focuser is online.
2018-04-08T11:28:30 INDI services started on port 7624.
2018-04-08T11:28:29 Starting INDI services...
2018-04-08T11:28:02 INDI services stopped.
2018-04-08T11:27:59 Microtouch is disconnected.
2018-04-08T11:27:57 Losmandy Gemini is disconnected.
2018-04-08T11:27:57 Disconnecting INDI devices...
2018-04-08T11:22:56 Losmandy Gemini focuser is online.
2018-04-08T11:22:55 Guider port from Losmandy Gemini is ready.
2018-04-08T11:22:55 Unable to establish the following devices:
+ QSI CCD
+ SX CCD
Please ensure each device is connected and powered on.
2018-04-08T11:22:54 Losmandy Gemini is online.
2018-04-08T11:22:52 WunderGround is disconnected.
2018-04-08T11:22:51 Microtouch focuser is online.
2018-04-08T11:22:50 INDI services started on port 7624.
2018-04-08T11:22:50 Starting INDI services...

Please Log in or Create an account to join the conversation.

QSI and Lodestar cameras not able to be found 2 weeks 1 day ago #24868

How are these drivers started? locally on the RPI? via Web manager? Can you start them manually via the Device Manager?

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

QSI and Lodestar cameras not able to be found 2 weeks 1 day ago #24877

All devices are directly connected to the Raspberry Pi.

I assume something related to cameras has changed.

I get the following when trying to connect the QSI camera using the device manager.

2018-04-08T06:33:09: startup: /usr/bin/indiserver -v -p 7624 -f /tmp/indififoa931a3fe
2018-04-08T06:33:09: listening to port 7624 on fd 3
FIFO: start indi_qsi_ccd -n "QSI CCD"
With name: QSI CCD
FIFO: Starting driver indi_qsi_ccd
2018-04-08T06:33:09: Driver indi_qsi_ccd: pid=842 rfd=4 wfd=7 efd=8
2018-04-08T06:33:09: Client 5: new arrival from 127.0.0.1:33832 - welcome!
2018-04-08T06:33:09: Driver indi_qsi_ccd: indi_qsi_ccd: symbol lookup error: indi_qsi_ccd: undefined symbol: _ZN4INDI13DefaultDevice8SetTimerEi
2018-04-08T06:33:09: Driver indi_qsi_ccd: indi_qsi_ccd: symbol lookup error: indi_qsi_ccd: undefined symbol: _ZN4INDI13DefaultDevice8SetTimerEi
2018-04-08T06:33:09: Driver indi_qsi_ccd: stderr EOF
Child process 844 died
2018-04-08T06:33:09: Driver indi_qsi_ccd: restart #2
2018-04-08T06:33:09: Driver indi_qsi_ccd: pid=845 rfd=4 wfd=8 efd=9
2018-04-08T06:33:09: Driver indi_qsi_ccd: indi_qsi_ccd: symbol lookup error: indi_qsi_ccd: undefined symbol: _ZN4INDI13DefaultDevice8SetTimerEi
2018-04-08T06:33:09: Driver indi_qsi_ccd: stderr EOF
Child process 845 died
2018-04-08T06:33:09: Driver indi_qsi_ccd: restart #3
2018-04-08T06:33:09: Driver indi_qsi_ccd: pid=846 rfd=4 wfd=8 efd=9
Child process 846 died
2018-04-08T06:33:09: Driver indi_qsi_ccd: indi_qsi_ccd: symbol lookup error: indi_qsi_ccd: undefined symbol: _ZN4INDI13DefaultDevice8SetTimerEi
2018-04-08T06:33:09: Driver indi_qsi_ccd: stdin EOF
2018-04-08T06:33:09: Driver indi_qsi_ccd: restart #4
2018-04-08T06:33:09: Driver indi_qsi_ccd: pid=847 rfd=4 wfd=8 efd=9
2018-04-08T06:33:09: Driver indi_qsi_ccd: indi_qsi_ccd: symbol lookup error: indi_qsi_ccd: undefined symbol: _ZN4INDI13DefaultDevice8SetTimerEi
2018-04-08T06:33:09: Driver indi_qsi_ccd: stderr EOF
Child process 847 died
2018-04-08T06:33:09: Driver indi_qsi_ccd: restart #5
2018-04-08T06:33:09: Driver indi_qsi_ccd: pid=848 rfd=4 wfd=8 efd=9
2018-04-08T06:33:09: Driver indi_qsi_ccd: indi_qsi_ccd: symbol lookup error: indi_qsi_ccd: undefined symbol: _ZN4INDI13DefaultDevice8SetTimerEi
2018-04-08T06:33:09: Driver indi_qsi_ccd: stderr EOF
Child process 848 died
2018-04-08T06:33:09: Driver indi_qsi_ccd: restart #6
2018-04-08T06:33:09: Driver indi_qsi_ccd: pid=849 rfd=4 wfd=8 efd=9
2018-04-08T06:33:09: Driver indi_qsi_ccd: indi_qsi_ccd: symbol lookup error: indi_qsi_ccd: undefined symbol: _ZN4INDI13DefaultDevice8SetTimerEi
2018-04-08T06:33:09: Driver indi_qsi_ccd: stderr EOF
2018-04-08T06:33:09: Driver indi_qsi_ccd: restart #7
2018-04-08T06:33:09: Driver indi_qsi_ccd: pid=850 rfd=4 wfd=8 efd=9
Child process 849 died
2018-04-08T06:33:09: Driver indi_qsi_ccd: indi_qsi_ccd: symbol lookup error: indi_qsi_ccd: undefined symbol: _ZN4INDI13DefaultDevice8SetTimerEi
2018-04-08T06:33:09: Driver indi_qsi_ccd: stderr EOF
Child process 850 died
2018-04-08T06:33:09: Driver indi_qsi_ccd: restart #8
2018-04-08T06:33:09: Driver indi_qsi_ccd: pid=851 rfd=4 wfd=8 efd=9
2018-04-08T06:33:09: Driver indi_qsi_ccd: indi_qsi_ccd: symbol lookup error: indi_qsi_ccd: undefined symbol: _ZN4INDI13DefaultDevice8SetTimerEi
2018-04-08T06:33:09: Driver indi_qsi_ccd: stderr EOF
2018-04-08T06:33:09: Driver indi_qsi_ccd: restart #9
2018-04-08T06:33:09: Driver indi_qsi_ccd: pid=852 rfd=4 wfd=8 efd=9
Child process 851 died
2018-04-08T06:33:09: Driver indi_qsi_ccd: indi_qsi_ccd: symbol lookup error: indi_qsi_ccd: undefined symbol: _ZN4INDI13DefaultDevice8SetTimerEi
2018-04-08T06:33:09: Driver indi_qsi_ccd: stderr EOF
Child process 852 died
2018-04-08T06:33:09: Driver indi_qsi_ccd: restart #10
2018-04-08T06:33:09: Driver indi_qsi_ccd: pid=853 rfd=4 wfd=8 efd=9
2018-04-08T06:33:09: Driver indi_qsi_ccd: indi_qsi_ccd: symbol lookup error: indi_qsi_ccd: undefined symbol: _ZN4INDI13DefaultDevice8SetTimerEi
2018-04-08T06:33:09: Driver indi_qsi_ccd: stderr EOF
2018-04-08T06:33:09: Driver indi_qsi_ccd: Terminated after #10 restarts.
Child process 853 died
2018-04-08T06:33:09: Driver indi_qsi_ccd: stderr EOF
Child process 842 died
2018-04-08T06:33:09: Driver indi_qsi_ccd: restart #1
2018-04-08T06:33:09: Driver indi_qsi_ccd: pid=844 rfd=4 wfd=8 efd=9

Please Log in or Create an account to join the conversation.

QSI and Lodestar cameras not able to be found 2 weeks 1 day ago #24878

Looks like a build error, you got those from Stable PPA?

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

QSI and Lodestar cameras not able to be found 2 weeks 1 day ago #24879

Built by running git pull and make install for libindi, 3rdparty and kstars.

Please Log in or Create an account to join the conversation.

Last Edit: by phomer60.

QSI and Lodestar cameras not able to be found 2 weeks 1 day ago #24881

Then it was not built properly, make sure you have nothing INDI related in /usr/local/

Then delete ALL builds directories for libindi & indi-qsi & indi-sx and build them again. Start with libindi, then sudo make install, then proceed to indi-qsi and indi-sx

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

QSI and Lodestar cameras not able to be found 2 weeks 4 hours ago #24910

I am going to do a complete build, however, I updated the Ubuntu Mate version today using apt-get to try and solve a problem with guidiing aborting after a few images.

Just to clarify the situation - the most recent apt-get update is now having the same problem with the QSI 583 camera but the lodestar is working.

Please Log in or Create an account to join the conversation.

Last Edit: by phomer60. Reason: updated

QSI and Lodestar cameras not able to be found 1 week 6 days ago #24939

phomer60 wrote: I am going to do a complete build, however, I updated the Ubuntu Mate version today using apt-get to try and solve a problem with guidiing aborting after a few images.

Just to clarify the situation - the most recent apt-get update is now having the same problem with the QSI 583 camera but the lodestar is working.


Is this possibly just an issue on ARM?

Please Log in or Create an account to join the conversation.

Last Edit: by phomer60.

QSI and Lodestar cameras not able to be found 1 week 6 days ago #24940

Nope. My home observatory uses QSI583 and Lodestar X2 connected to StellarMate, and it's all working fine. Start looking for older libindi libraries in /usr/local

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

QSI and Lodestar cameras not able to be found 1 week 3 days ago #25054

I have eliminated a number of things

1) It happens when the QSI583 is the only device connecting.
2) It happens when connecting all my devices mount/camera/guide camera/focuser and Wunderground.
3) It does not happen with older versions of kstars/INDI/ekos.
4) Every copy I have upgraded from a number of different versions (some about 6 months old) fail after the update.
5) I cannot see anything related in /usr/local.

Please Log in or Create an account to join the conversation.

Last Edit: by phomer60.

QSI and Lodestar cameras not able to be found 1 week 2 days ago #25071

Further update.
Although I haven't finished my testing - the latest build on Raspbian is today recognising the QSI583 camera.

The apt-get version on Ubuntu Mate is still crashing.

Please Log in or Create an account to join the conversation.

QSI and Lodestar cameras not able to be found 1 week 2 days ago #25075

Today, I rebuilt Ubuntu Mate from scratch on a new card and installed indi-full but it would not start up. After trying a number of things I decided to use the bleeding edge and kstars then started. After all this I am still having the same issue with my QSI538 not connecting.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.152 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica