Welcome, Guest
Username: Password: Remember me
25 Jul 2018
Glad to announce of release of INDI Library v1.7.4 on 2018-07-25. A few drivers were added in this release as we continue to improve & stabilize existing drivers.
Read More...
  • Page:
  • 1
  • 2

TOPIC: Kstars crashes on OSX

Kstars crashes on OSX 4 months 3 weeks ago #25456

  • Florian
  • Florian's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 11
  • Thank you received: 0
Hi,

since yesterday i was a very happy user of kstars and ekos on my Macbook. Now Kstars crashes immediately on startup (see attached OSX protocol). I didn't changed anything since yesterday. I tried to delete the app and reinstall new 2.9.4 without any success.

Any suggestions what this could be?

kind regards

Flo
Attachments:

Please Log in or Create an account to join the conversation.

Kstars crashes on OSX 4 months 3 weeks ago #25459

Please Log in or Create an account to join the conversation.

Modded Canon EOS 700D with a WO ZS 71 ED on a SW HEQ5-Pro /
QHY9 CCD and filter wheel with an 8" RC on a SW EQ6-R

Kstars crashes on OSX 4 months 3 weeks ago #25460

  • Florian
  • Florian's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 11
  • Thank you received: 0
Thanks for your comment.
As I wrote I am using kstars 2.9.3 and 2.9.4. Not 2.9.5. So this is something different I think.

Please Log in or Create an account to join the conversation.

Kstars crashes on OSX 4 months 3 weeks ago #25462

2.9.4 has issues on the Mac. Backup to 2.9.3 until 2.9.5 is re-released.

Please Log in or Create an account to join the conversation.

Kstars crashes on OSX 4 months 3 weeks ago #25467

2.9.5 is now out again, grab it and test it please.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Kstars crashes on OSX 4 months 3 weeks ago #25469

I took the download from the KDE website and after installing it fails to open:

kstars cannot be opened because of a problem.

Please Log in or Create an account to join the conversation.

Modded Canon EOS 700D with a WO ZS 71 ED on a SW HEQ5-Pro /
QHY9 CCD and filter wheel with an 8" RC on a SW EQ6-R

Kstars crashes on OSX 4 months 3 weeks ago #25470

md5/sha256 sums check out?

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Kstars crashes on OSX 4 months 3 weeks ago #25472

$> cat kstars-2.9.5.dmg.md5
MD5 (/Users/rlancaste/AstroRoot/kstars-craft/Applications/KDE//kstars_2.9.5.dmg) = 9812a76cd54f81f4e67228a1521c7724
$> md5 kstars-2.9.5.dmg
MD5 (kstars-2.9.5.dmg) = 9812a76cd54f81f4e67228a1521c7724

Please Log in or Create an account to join the conversation.

Modded Canon EOS 700D with a WO ZS 71 ED on a SW HEQ5-Pro /
QHY9 CCD and filter wheel with an 8" RC on a SW EQ6-R

Kstars crashes on OSX 4 months 3 weeks ago #25474

Guess we'll have to wait until Robert checks it out.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Kstars crashes on OSX 4 months 3 weeks ago #25482

Reinstalled 2.9.5 and tried to run it. Primary cause listed in crash file is "DYLD, Library missing". See attached log.
Attachments:

Please Log in or Create an account to join the conversation.

Kstars crashes on OSX 4 months 3 weeks ago #25483

Robert found the issue, please wait a few more hours until he reupload the DMG.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Kstars crashes on OSX 4 months 3 weeks ago #25494

ok, please try again. It should work now. Sorry there have been multiple changes in the last couple of days that have been messing up my build script. First, there were some major craft changes. Then there was an issue with different versions of libraw. Then there was an issue with the qml directory getting changed. All of the changes will be good in the end, but temporarily, they caused some headaches.


Thanks,

Rob

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • 2
Time to create page: 0.174 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica