Welcome, Guest
Username: Password: Remember me
27 Feb 2017
INDI development team is happy to announce the release of INDI Library v1.4.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers. Several improvements and enhancements are included in this release including native support for Cygwin and MacOS platforms in addition to Linux, BSD, and Windows (Client only).
Read More...

TOPIC: Ekos on Mac OS X ?

Ekos on Mac OS X ? 2 months 1 week ago #15216

Actually, one thing that I would like to do is get more xml files into the OS X app. I know the SBIG xml file needs to get in there. I use my SBIG with KStars all the time, hosted using a remote indiserver from my Raspberry Pi. Right now I have to copy and paste the XML file in there. It should be copied in automatically. So yes, if there are any other XML files that need to get in there, please let me know. I will work on getting more XML files into the App.
The following user(s) said Thank You: knro, T-Studio

Please Log in or Create an account to join the conversation.

Ekos on Mac OS X ? 2 months 1 week ago #15217

I'm sorry I lacked the words.
It is a request as follows.

indilib.org/forum/wish-list/2038-ekos-re...-3-party-driver.html

Server uses RaspberryPi, OSX Kstars as remote client.

Please Log in or Create an account to join the conversation.

Ekos on Mac OS X ? 2 months 1 week ago #15218

In UBUNTU, it was necessary to install FCUSB separately from the cloud maker.
(It was not included in sudo apt-get indi-full.)

On OSX, INDI server uses Kstars application with cloud maker, but you can not install FCUSB individually like UBUNTU.

Please Log in or Create an account to join the conversation.

Ekos on Mac OS X ? 2 months 1 week ago #15219

Yes, it's because the cloud makers driver is built into their indi server app. I believe that is a driver we cannot bundle into kstars because it is their own proprietary driver, but as I said before, we can include an xml file in kstars and you could connect to the indiserver on the pi or to the cloudmakers indiserver if you want to run the fcusb on your mac. You can copy the xml file in there yourself, or I should be able to get it in there by next week sometime.

Please Log in or Create an account to join the conversation.

Ekos on Mac OS X ? 2 months 1 week ago #15249

I use Pi as a server and remotely on Mac.
I hope FCUSB can be used if you can select FCUSB on Ekos on Mac so please add it to the list.

How do I add an XML file?

Postscript
Since it had kde-l10n-ja in MacPort, it was installed, but unfortunately it was not localized.

Please Log in or Create an account to join the conversation.

Ekos on Mac OS X ? 2 months 1 week ago #15262

Ok, for right now, the easiest way would be for you to copy and paste this into your favorite text editor and save it as indi_shoestring.xml

<!--?xml version="1.0" encoding="UTF-8"?-->
<driversList>
<devGroup group="Focusers">
<device label="Shoestring Astronomy FCUSB">
<driver name="FCUSB Focuser">indi_fcusb_focuser</driver>
<version>1.1</version>
</device>
</devGroup>
</driversList>

Then once you do that, copy and paste the file into KStars.app/Contents/MacOS/indi
If you don't know how to get into the app, just right click on it and select "show package contents"
The following user(s) said Thank You: T-Studio

Please Log in or Create an account to join the conversation.

Ekos on Mac OS X ? 2 months 1 week ago #15263

Actually, we are discussing right now about possibly getting more xml files in there by default

Please Log in or Create an account to join the conversation.

Ekos on Mac OS X ? 2 months 1 week ago #15338

I was able to display it on the OS X Kstars, Ekos list.
Thank you very much.

Currently, I am challenging OSX Kstars localization.
I installed kde - 10 ln on MacPort, but it was not reflected in Kstars.
Since there was a Kstars language file in the installation file, let's investigate a little more.

Please Log in or Create an account to join the conversation.

Ekos on Mac OS X ? 1 month 4 weeks ago #15825

Several things have happened in the past week.

I corrected a problem with the Gphoto driver build on OS X. By accident, it wasn't included when otool redirected the paths to files in frameworks.
ZWO ASI driver now builds natively in KStars for OS X.
We corrected the problem where several remote drivers that are available for remote use were not listed (like the post by T-Studio).
We directed the user to relaunch kstars if they change their driver directory correcting an observation Sean Houghton made a few weeks ago.

And I just updated the documentation on the OS X KStars page so the instructions are up to date:

github.com/jamiesmith/kstars-on-osx
The following user(s) said Thank You: knro, nmac, Poison, T-Studio

Please Log in or Create an account to join the conversation.

Ekos on Mac OS X ? 1 month 3 weeks ago #16006

rlancaste wrote: Several things have happened in the past week.

I corrected a problem with the Gphoto driver build on OS X. By accident, it wasn't included when otool redirected the paths to files in frameworks.
ZWO ASI driver now builds natively in KStars for OS X.
We corrected the problem where several remote drivers that are available for remote use were not listed (like the post by T-Studio).
We directed the user to relaunch kstars if they change their driver directory correcting an observation Sean Houghton made a few weeks ago.

And I just updated the documentation on the OS X KStars page so the instructions are up to date:

github.com/jamiesmith/kstars-on-osx


So I've downloaded the prebuilt image, and tried building with homebrew, but the ZWO driver still isn't showing up. Any suggestions?

Please Log in or Create an account to join the conversation.

Ekos on Mac OS X ? 3 weeks 5 days ago #16452

I'm testing Ekos on Mac OS X (Kstars 2.7.6). Unfortunately, I cannot connect any of my Canon DSLR's ("Unable to establish: +Canon DSLR Please ensure the device is connected and powered on"). I went through the Q&A, read all the docs I could find but I can't find a solution. Just for your information:
  • The DSLR is NOT mounted by the OS
  • Canon EOS Utilities are NOT installed
  • The DSRL is correctly detected by gphoto2 --auto-detect
  • Camera properties are correctly reported by gphoto2 -a
  • If I run the Ekos VM in VirtualBox the DSLR is detected and it works properly
  • I have the same issue with MacOS Sierra and Yosemite, with a Canon EOS 7D and a 7D Mark II
The above considerations seems to rule out any hardware issue (USB port, USB cable, etc.).
When checking the log I found a suspicious line:
DEBG - INDI Server:  "2017-05-01T19:39:42: Driver indi_canon_ccd: Number of cameras detected: -4."
The full log is attached.
While the problem is solved I can run Ekos VM, but having it run natively would be great. Is there something else I can check to sort this out?
Thanks in advance - Alessio
Attachments:

Please Log in or Create an account to join the conversation.

Ekos on Mac OS X ? 3 weeks 5 days ago #16454

Hi Allessio, I'll look into it and ask Jasem if he knows anything about it. It was working the last time I tried it, but the code may have been changed.

I'll do the same for you poobie, sorry I didn't get back to you sooner.

Thanks,

Rob

Please Log in or Create an account to join the conversation.

Time to create page: 0.206 seconds

Login

3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!

Gallery

Replica

Why INDI

Replica