Welcome, Guest
Username: Password: Remember me
20 Aug 2017
INDI development team is happy to announce the release of INDI Library v1.5.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...

TOPIC: Remote astrometry solver

Re:Remote astrometry solver 3 months 2 days ago #18659

  • phme
  • phme's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 16
  • Thank you received: 0
Hi,
I'm using the remote solver from KStars/Ekos on Windows, connecting to a RPi. Until today, everything went totally fine.
Today, the solver is launched and finds a solution, but the solution never shows in Ekos. The logs say "solver complete" (and I can verify in the logs that the solution is correctly found), but Ekos interface keeps waiting, until I finally cancel the alignment.
Any idea where this could come from, or how I could debug further?
I'm using KStars 2.8.0, build 2017-07-25T13:18:46Z, Indi library 1.5.0, no update since the last time it worked.
Thanks

Please Log in or Create an account to join the conversation.

Re:Remote astrometry solver 3 months 1 day ago #18662

This happens repeatedly or just a one time thing?

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Re:Remote astrometry solver 3 months 1 day ago #18664

  • phme
  • phme's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 16
  • Thank you received: 0
Repeatedly, including after disconnection / re connection, reboot, etc. I also tried to upload and solve an image, same issue.
Since then, I've updated Indi, and when tried uploading and solving an image, and the solution was retrieved by Ekos.
I'll let you know tonight if the issue persists.
Cheers,
P

Please Log in or Create an account to join the conversation.

Re:Remote astrometry solver 3 months 1 day ago #18680

I tried today with StellarMate even with HotSpot and it worked many times without any issues. If it happens again try to check the logs.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Re:Remote astrometry solver 3 months 1 day ago #18696

  • phme
  • phme's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 16
  • Thank you received: 0
It's happening again. I attach a screenshot showing the GUI about 1 minute after the solve completed, as well as the relevant portion of the solver logs.
As you see, all goes well, but Ekos fails to retrieve the solution.
Any idea?
Thanks,
P
Attachments:

Please Log in or Create an account to join the conversation.

Re:Remote astrometry solver 3 months 1 day ago #18697

Ekos log?

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Re:Remote astrometry solver 3 months 1 day ago #18700

  • phme
  • phme's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 16
  • Thank you received: 0
Where do you find it on windows? Can't locate them in appdata.

EDIT: Never mind, I've just enabled them. Will get back to you in 10 minutes.

Please Log in or Create an account to join the conversation.

Last Edit: by phme.

Re:Remote astrometry solver 3 months 1 day ago #18702

  • phme
  • phme's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 16
  • Thank you received: 0
See below. Nothing striking I'm afraid. Note the last line, when I pressed "Stop" after about 1 min without results.

017-08-23T22:29:41.558 - DEBG - Alignment: "Capturing image..."
2017-08-23T22:29:41.604 - DEBG - Astrometry : "Astrometry solver is enabled. "
2017-08-23T22:29:41.607 - DEBG - < Astrometry >: < ASTROMETRY_RESULTS >
2017-08-23T22:29:41.652 - DEBG - Nikon DSLR DSC D5300 : "Starting 9 sec exposure "
2017-08-23T22:29:55.516 - DEBG - Nikon DSLR DSC D5300 : "Exposure done, downloading image... "
2017-08-23T22:30:44.509 - DEBG - Alignment: "Image received."
2017-08-23T22:30:44.519 - DEBG - Astrometry : "Solving image... "
2017-08-23T22:30:44.521 - WARN - Audio notification requested, but sound file from notifyrc file was not found, aborting audio notification
2017-08-23T22:31:07.510 - DEBG - Alignment: "Solver completed in 23 seconds."
2017-08-23T22:31:07.517 - DEBG - Astrometry : "Astrometry solver is disabled. "
2017-08-23T22:31:07.854 - DEBG - Astrometry : "Solver complete. "
2017-08-23T22:31:55.877 - DEBG - Alignment: "Solver aborted after 0 seconds"

Please Log in or Create an account to join the conversation.

Re:Remote astrometry solver 3 months 1 day ago #18703

This might be related to d-bus functionality under Windows, it seems some messages get lost between the modules, with no clear reason. I had issues with the June version of KStars, on which I could not even start the Scheduler. Getting back to Feb version "solved" that part for me. After that I decided I had no time to debug and returned to Linux.
-Eric

Envoyé de mon ASUS_Z00AD en utilisant Tapatalk

Please Log in or Create an account to join the conversation.

Re:Remote astrometry solver 3 months 1 day ago #18704

  • phme
  • phme's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 16
  • Thank you received: 0
Interesting, I'll try that. The weird thing is that it worked perfectly until yesterday.
The only thing I did in-between is install and play with Sequence Generator Pro -- to quickly go back to KStars/Ekos :)
Maybe that's the issue, who knows?
Unfortunately, I can't go full Linux yet, as my guide cam is not supported.

Please Log in or Create an account to join the conversation.

Re:Remote astrometry solver 3 months 1 day ago #18705

  • phme
  • phme's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 16
  • Thank you received: 0
Success! I installed kstars 1.8.1 and uninstalled SG Pro, and all works fine now.
Back to imaging.
Thanks, and clear skies to all.

Please Log in or Create an account to join the conversation.

Re:Remote astrometry solver 3 months 5 hours ago #18742

  • phme
  • phme's Avatar
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 16
  • Thank you received: 0
Actually, it started again tonight, I can't get the solve results.
Is there a way to debug dbus, if this is a likely culprit?

Please Log in or Create an account to join the conversation.

Last Edit: by phme.
Time to create page: 0.118 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica