Welcome, Guest
Username: Password: Remember me
25 Jul 2018
Glad to announce of release of INDI Library v1.7.4 on 2018-07-25. A few drivers were added in this release as we continue to improve & stabilize existing drivers.
Read More...

TOPIC: Raspberry Pi 3 Setup Script

Raspberry Pi 3 Setup Script 7 months 3 weeks ago #22758

  • rlancaste
  • rlancaste's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 1291
  • Karma: 13
  • Thank you received: 346
Thats really awesome, I'm glad to hear it! That was just a random idea I had when you said that you couldn't connect with your iPad, so I wondered, if there is "an app for that," is there a device for that? Then a quick google search got me that link.

And you really did some nice work explaining how to use it. Talk to Jasem, I think you could write a great tutorial!! I will forward him a link to your post.

Please Log in or Create an account to join the conversation.

Raspberry Pi 3 Setup Script 7 months 3 weeks ago #22777

rlancaste wrote: And you really did some nice work explaining how to use it. Talk to Jasem, I think you could write a great tutorial!! I will forward him a link to your post.

We think alike. I was considering writing up a more detailed tutorial.

Please Log in or Create an account to join the conversation.

Raspberry Pi 3 Setup Script 7 months 2 weeks ago #22864

I used the script tonight to install kstars, INDI etc on my RPi3 with Ubuntu MATE. The script works like a charm and the installation proceeded without any problems. There are, however, two problems:

- start up hangs with 4 raspberries in the upper left. After about 1.5 minutes it continues with the message Failed to start Load Kernel Modules
- the icons of KStars in the button bar are not visible.

Any idea what I did wrong?

Please Log in or Create an account to join the conversation.

Modded Canon EOS 700D with a WO ZS 71 ED on a SW HEQ5-Pro /
QHY9 CCD and filter wheel with an 8" RC on a SW EQ6-R

Raspberry Pi 3 Setup Script 7 months 2 weeks ago #22868

  • rlancaste
  • rlancaste's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 1291
  • Karma: 13
  • Thank you received: 346
Do you mean the actual icons in the kstars program at the top of the window?

Please Log in or Create an account to join the conversation.

Raspberry Pi 3 Setup Script 7 months 2 weeks ago #22869

  • rlancaste
  • rlancaste's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 1291
  • Karma: 13
  • Thank you received: 346
For the load kernel modules startup time issue, i have seen that on some systems and not others. I remember reading about this. As i understand I think it is waiting for something to be connected. If it doesnt find that, It should continue staring after about 2 minutes. There was a way to disable that waiting period, but as I said I dont remember right now

Please Log in or Create an account to join the conversation.

Raspberry Pi 3 Setup Script 7 months 2 weeks ago #22872

Concerning the icons: yes, those I mean

Concerning the time out: OK thanks. I'll search online to see if I can find anything to solve this. Obviously, if you remember how to solve it then I'd very much like to know :)

Please Log in or Create an account to join the conversation.

Modded Canon EOS 700D with a WO ZS 71 ED on a SW HEQ5-Pro /
QHY9 CCD and filter wheel with an 8" RC on a SW EQ6-R

Raspberry Pi 3 Setup Script 7 months 2 weeks ago #22873

The slow boot was due to cups modules not being available. I commented them out in

/etc/modules-load.d/cups-filters.conf

and then booting up went much faster.

Please Log in or Create an account to join the conversation.

Modded Canon EOS 700D with a WO ZS 71 ED on a SW HEQ5-Pro /
QHY9 CCD and filter wheel with an 8" RC on a SW EQ6-R

Raspberry Pi 3 Setup Script 7 months 2 weeks ago #22875

Here's a screenshot of KStars:

Attachments:

Please Log in or Create an account to join the conversation.

Modded Canon EOS 700D with a WO ZS 71 ED on a SW HEQ5-Pro /
QHY9 CCD and filter wheel with an 8" RC on a SW EQ6-R

Raspberry Pi 3 Setup Script 7 months 2 weeks ago #22877

  • rlancaste
  • rlancaste's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 1291
  • Karma: 13
  • Thank you received: 346
Ok the icons is due to a recent change in kstars. I had put a set of fallback icons in kstars about 2 years ago so this couldn’t happen, but when we did the application theme, I figured out how to get the icon theme to work on macs. Jasem said that on the non kde Linux systems, installing kstars would install the icons, so we took out the fallback icons. Apparently not. Can you try:

sudo apt-get install breeze-icon-theme

(Not sure if that is the package name)

Please Log in or Create an account to join the conversation.

Raspberry Pi 3 Setup Script 7 months 2 weeks ago #22880

That one's already installed:

~$ sudo dpkg -l \*icon\*
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-============================================-===========================-===========================-=============================================================================================
un account-plugin-icons <none> <none> (no description available)
ii adwaita-icon-theme 3.18.0-2ubuntu3.1 all default icon theme of GNOME (small subset)
un adwaita-icon-theme-full <none> <none> (no description available)
ii breeze-icon-theme 4:5.18.0-0ubuntu1 armhf Default Plasma icon theme.
ii gnome-icon-theme 3.12.0-1ubuntu3 all GNOME Desktop icon theme
<snip>

Please Log in or Create an account to join the conversation.

Modded Canon EOS 700D with a WO ZS 71 ED on a SW HEQ5-Pro /
QHY9 CCD and filter wheel with an 8" RC on a SW EQ6-R

Raspberry Pi 3 Setup Script 7 months 2 weeks ago #22881

By the way, apart from the icons your script works really well. When I open KStars and hover the mouse over the icon bar I can open Ekos by clicking when I see the appropriate tool tip. I tried controlling my EQMod mount and EOS camera and it all works like a charm. Well done indeed and thanks so very much for doing the effort and making this all available to us!

Please Log in or Create an account to join the conversation.

Modded Canon EOS 700D with a WO ZS 71 ED on a SW HEQ5-Pro /
QHY9 CCD and filter wheel with an 8" RC on a SW EQ6-R

Raspberry Pi 3 Setup Script 7 months 2 weeks ago #22882

  • rlancaste
  • rlancaste's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 1291
  • Karma: 13
  • Thank you received: 346
Yeah no problem. We will look into the icons issue. It will probably be a problem for anybody that installs kstars on non kde Linux. It’s pretty important.

Please Log in or Create an account to join the conversation.

Time to create page: 0.268 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica