Welcome, Guest
Username: Password: Remember me
25 Jul 2018
Glad to announce of release of INDI Library v1.7.4 on 2018-07-25. A few drivers were added in this release as we continue to improve & stabilize existing drivers.
Read More...

TOPIC: Raspberry Pi 3 Setup Script

Raspberry Pi 3 Setup Script 7 months 2 weeks ago #22884

Actually I have Ubuntu Mate also installed on my laptop and of course I installed KStars bleeding on it and the icons show up just fine. The plot thickens....

Please Log in or Create an account to join the conversation.

Modded Canon EOS 700D with a WO ZS 71 ED on a SW HEQ5-Pro /
QHY9 CCD and filter wheel with an 8" RC on a SW EQ6-R

Raspberry Pi 3 Setup Script 7 months 2 weeks ago #22886

  • rlancaste
  • rlancaste's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 1291
  • Karma: 13
  • Thank you received: 346
Hmm I wonder if it is a raspberry pi specific issue? It is a modified version of Ubuntu mate they use.

Please Log in or Create an account to join the conversation.

Raspberry Pi 3 Setup Script 7 months 2 weeks ago #22887

  • rlancaste
  • rlancaste's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 1291
  • Karma: 13
  • Thank you received: 346
Wait did you install the kstars bleeding on the laptop more than 1 week ago? If so, it still included the fallback icons at that point

Please Log in or Create an account to join the conversation.

Raspberry Pi 3 Setup Script 7 months 2 weeks ago #22893

Yes I did so that mist be it then.

Please Log in or Create an account to join the conversation.

Modded Canon EOS 700D with a WO ZS 71 ED on a SW HEQ5-Pro /
QHY9 CCD and filter wheel with an 8" RC on a SW EQ6-R

Raspberry Pi 3 Setup Script 7 months 2 weeks ago #22896

I compared the icon themes on my laptop and RPi and found a difference: the oxygen icon theme was not installed on the RPi. Once I installed it the icons showed up just fine in KStars. I'll also put this answer in the other thread .

Please Log in or Create an account to join the conversation.

Modded Canon EOS 700D with a WO ZS 71 ED on a SW HEQ5-Pro /
QHY9 CCD and filter wheel with an 8" RC on a SW EQ6-R

Raspberry Pi 3 Setup Script 7 months 2 weeks ago #22905

  • rlancaste
  • rlancaste's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 1291
  • Karma: 13
  • Thank you received: 346
That is strange. Why would they need the oxygen icon theme for the breeze icon theme to work? I understand why they might need the hicolor theme, since it is the default theme and other themes are based on it. But why oxygen?

Please Log in or Create an account to join the conversation.

Raspberry Pi 3 Setup Script 7 months 2 weeks ago #22907

I did a complete re-install today, decided to update everything including the raspberry kernel etc. No problems whatsoever besides Firefox. I read that this problem is already present for months, so I decided to remore Firefox and install Chromium. Which is actually great as it synced everything I had already setup in Chrome on my regular computer and I was good to go, love it! I also installed both icon themes mentioned above, before running the script and the icons are displaying fine now.

Please Log in or Create an account to join the conversation.

Raspberry Pi 3 Setup Script 7 months 2 weeks ago #22908

  • rlancaste
  • rlancaste's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 1291
  • Karma: 13
  • Thank you received: 346
Good that its working. Perhaps Chromium should be installed in the script. It is better than Firefox in many ways I think.

Looking into why oxygen might be needed with Jasem. . .
The following user(s) said Thank You: supernov

Please Log in or Create an account to join the conversation.

Raspberry Pi 3 Setup Script 7 months 2 weeks ago #22920

  • rlancaste
  • rlancaste's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 1291
  • Karma: 13
  • Thank you received: 346
I have a solution that seems to work without the oxygen icon theme or the fallback icons. Can somebody else try this?

Add a file called ~/.config/kdeglobals

and put in it:
[Icons]
Theme=breeze

If this works I can easily add that to the setup script. I found the answer here:
www.google.com/url?q=https://forum.kde.o...yC2IJbCFjNA2023L86qg

Please Log in or Create an account to join the conversation.

Raspberry Pi 3 Setup Script 7 months 2 weeks ago #22925

Hey Ron.

Tried your work around and I now have icons.

Thanks

John

Please Log in or Create an account to join the conversation.

Raspberry Pi 3 Setup Script 7 months 2 weeks ago #22926

  • rlancaste
  • rlancaste's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 1291
  • Karma: 13
  • Thank you received: 346
Cool! It's not really a workaround, it's probably what we need to do for non kde-linux systems. Apparently, it must need that file to load the theme properly.

Please Log in or Create an account to join the conversation.

Raspberry Pi 3 Setup Script 7 months 2 weeks ago #22928

Tonight I started all over again with my RPi3 and added the file with the contents as specifed. It worked for me as well. Plus the 1.5/2 minute delay I had before is gone now yay!

Please Log in or Create an account to join the conversation.

Modded Canon EOS 700D with a WO ZS 71 ED on a SW HEQ5-Pro /
QHY9 CCD and filter wheel with an 8" RC on a SW EQ6-R
Time to create page: 0.173 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica