Welcome, Guest
Username: Password: Remember me
25 Jul 2018
Glad to announce of release of INDI Library v1.7.4 on 2018-07-25. A few drivers were added in this release as we continue to improve & stabilize existing drivers.
Read More...
  • Page:
  • 1

TOPIC: Installation dependencies on Raspbian

Installation dependencies on Raspbian 10 months 20 hours ago #21165

Hi,

I want to install the dependencies on my Raspberry Pi with Raspbian stretch lite.
sudo apt-get install cdbs libcfitsio3-dev libnova-dev libusb-1.0-0-dev libjpeg-dev libusb-dev libtiff5-dev libftdi-dev fxload libkrb5-dev libcurl4-gnutls-dev libraw-dev libgphoto2-dev libgsl0-dev dkms libboost-regex-dev libgps-dev libdc1394-22-dev

I get following error:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'libgsl-dev' instead of 'libgsl0-dev'
Package libcfitsio3-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libcfitsio-dev

E: Package 'libcfitsio3-dev' has no installation candidate

so i think because of the problem with the dependencies the manuel installation of INDI
$ tar -xzf libindi_1.6.0_rpi.tar.gz
$ cd libindi_1.6.0_rpi
$ sudo dpkg -i *.deb

also didn't work for me and I get this error messages, e.g.
dpkg: error processing package indi-bin (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of indi-eqmod:
 indi-eqmod depends on libgsl0ldbl (>= 1.9); however:
  Package libgsl0ldbl is not installed.

dpkg: error processing package indi-eqmod (--install):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of indi-eqmod-dbg:
 indi-eqmod-dbg depends on indi-eqmod (= 0.3); however:
  Package indi-eqmod is not configured yet.

Any idea?

Please Log in or Create an account to join the conversation.

Installation dependencies on Raspbian 10 months 18 hours ago #21170

Looks like libgsl0dbl was left over from upgrade to Stretch, I removed it so please use tomorrow's Raspbian build.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Installation dependencies on Raspbian 9 months 6 days ago #21651

Can you please clarify which version has this bug fixed? Downloading the current tar file for RPi (from Nov 11, ten days before your posting) still gives me the same error as reported above.

Cheers, Aleks

Please Log in or Create an account to join the conversation.

Installation dependencies on Raspbian 9 months 6 days ago #21652

I just checked my RPi and it was having an error building packages.. so wait for few hours until it finishes building the new package and uploads it.
The following user(s) said Thank You: procras

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Installation dependencies on Raspbian 9 months 5 days ago #21695

Hi Jasem,

Is the download version on
Raspberry Pi Download URL complied for Stretch now?

I note the page still says

Extract and install on Raspbian Jessie.

Please Log in or Create an account to join the conversation.

Installation dependencies on Raspbian 9 months 4 days ago #21705

Hi James,

Thanks for all your work on this project

I'm also still having errors building packages with the current download. Can you inform us when everything is corrected?
Thanks

Please Log in or Create an account to join the conversation.

Installation dependencies on Raspbian 9 months 22 hours ago #21802

It should be working now

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Installation dependencies on Raspbian 8 months 3 weeks ago #21877

Much appreciated.

I still get the same dependency issues though. Here the part from the log where the errors begin:
It is likely that 4.9.59-v7+ belongs to a chroot's host
Building for 3.6-trunk-rpi, 4.9.59+ and 4.9.59-v7+
Building initial module for 3.6-trunk-rpi
Error! Bad return status for module build on kernel: 3.6-trunk-rpi (armv7l)
Consult /var/lib/dkms/fliusb/1.3/build/make.log for more information.
Setting up fliusb-source (1.3) ...
Setting up fxload-libusb (1.0.1) ...
Setting up fxload-libusb-dbgsym (1.0.1) ...
dpkg: dependency problems prevent configuration of indi-bin:
 indi-bin depends on libgsl0ldbl (>= 1.9); however:
  Package libgsl0ldbl is not installed.

After that the errors pile up. I'm running Raspbian 9 (Stretch), Kernel 4.9.59-v7+ (I think).
Might swap to Ubuntu.

Aleks

Please Log in or Create an account to join the conversation.

Installation dependencies on Raspbian 8 months 3 weeks ago #21883

This is not the latest package uploaded for Raspbian. Please download again, I just checked indi-bin and it does not depend on libgsl0dbl in Stretch.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Installation dependencies on Raspbian 8 months 3 weeks ago #22091

You are right, my mistake. Thanks for the support!

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.374 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica