Welcome, Guest
Username: Password: Remember me
20 Aug 2017
INDI development team is happy to announce the release of INDI Library v1.5.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...
  • Page:
  • 1
  • 2

TOPIC: KStars not starting up after indi update!

KStars not starting up after indi update! 8 months 3 weeks ago #14816

  • lubel
  • lubel's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 12
  • Thank you received: 2
Huge problem here! I cannot start-up KStars and / or PHD2 anymore after an update of the indidrivers today!

"kstars: error while loading shared libraries: libindi.so.1: cannot open shared object file: No such file or directory"

What happened? Can anybody help? I will have to demount all my gear and then this clear night is gone....:-(
I am working on Ubuntu 16.04 with everything up to date I assume.
The following user(s) said Thank You: dolguldur

Please Log in or Create an account to join the conversation.

KStars not starting up after indi update! 8 months 3 weeks ago #14817

  • lupinix
  • lupinix's Avatar
  • Away
  • Moderator
  • Moderator
  • Posts: 167
  • Karma: 4
  • Thank you received: 38
I guess kstars needs a rebuild. This comes from a recent change in INDI. Maybe knro can help here.
The following user(s) said Thank You: lubel

Please Log in or Create an account to join the conversation.

KStars not starting up after indi update! 8 months 3 weeks ago #14819

  • lubel
  • lubel's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 12
  • Thank you received: 2
thanks. Can I rebuild the older indi drivers from sources somewhere?

Please Log in or Create an account to join the conversation.

KStars not starting up after indi update! 8 months 3 weeks ago #14828

KStars is being rebuilt now. Should be ready in about 1 hour.
The following user(s) said Thank You: lubel

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

KStars not starting up after indi update! 8 months 3 weeks ago #14838

  • lubel
  • lubel's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 12
  • Thank you received: 2
Thanks. Couldn't wait of course installed Indi from sources. Afterwards it worked. Looking forward to get back to the standard libraries though.

Please Log in or Create an account to join the conversation.

KStars not starting up after indi update! 8 months 3 weeks ago #14839

Looks like PHD2 is broken with the same error.

KStars update works though! :)

Please Log in or Create an account to join the conversation.

KStars not starting up after indi update! 8 months 3 weeks ago #14840

  • lubel
  • lubel's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 12
  • Thank you received: 2
Recognized this too. PHD2 refers to the same indi shared files obviously. After buiding indi from the sources provided here: both worked. :-D

Please Log in or Create an account to join the conversation.

KStars not starting up after indi update! 8 months 3 weeks ago #14846

Oddly enough, my toolbar at the top of Kstars has little boxes where the icons should be. Anyone know how to fix this?
Attachments:

Please Log in or Create an account to join the conversation.

KStars not starting up after indi update! 8 months 3 weeks ago #14851

  • nmac
  • nmac's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 252
  • Karma: 2
  • Thank you received: 49
You should install missing icons with the following command:

sudo apt-get install oxygen-icon-theme

indilib.org/forum/ekos/988-missing-butto...10.html?start=6#8274
The following user(s) said Thank You: rockstarbill

Please Log in or Create an account to join the conversation.

(PT) SC@ROS Observatory
RPi3 / Explore Scientific ES80480 / Canon 550D / ESFF 2" / ASI120MM / Arduino Moonlite DC Clone- HEQ5 Pro
RPi2 / Orion 120ST / Atik 420m / WOIII / SSAG - Arduino Moonlite DC Clone - LXD75
www.flickr.com/photos/139335144@N03/
Last Edit: by nmac.

KStars not starting up after indi update! 8 months 3 weeks ago #14854

That did the trick, thanks!

Please Log in or Create an account to join the conversation.

KStars not starting up after indi update! 8 months 3 weeks ago #14889

  • H__
  • H__'s Avatar
  • Offline
  • Junior Boarder
  • Junior Boarder
  • Posts: 27
  • Thank you received: 7
On trying to fix PHD2 I run into one of these 2 bugs while using INDI 1.4.1 FindINDI.cmake :
- using find_package(INDI 1.4.1 REQUIRED) linking barfs with :
undefined reference to `INDI::BaseClient::BaseClient()'
while the linker argument list has -lindidriver -lindiAlignmentDriver

- using find_package(INDI CLIENT 1.4.1 REQUIRED) cmake barfs with :
find_package called with invalid argument "CLIENT"

-- Hans

20170301_235330+0100 update: fixed further down this thread in #14901

Please Log in or Create an account to join the conversation.

Last Edit: by H__.

KStars not starting up after indi update! 8 months 3 weeks ago #14894

  • patdut
  • patdut's Avatar
  • Away
  • Gold Boarder
  • Gold Boarder
  • Posts: 266
  • Karma: 1
  • Thank you received: 32
Hello all,
As I wanted to explore the way to create a python indi client I fell on the same problem. There is no more libindi.so.1 that exists in previous versions. I git pulled the last version of INDI compiled it, installed it and ... I did get any libindi.so.1.
Did I missed something ?

Please Log in or Create an account to join the conversation.

Last Edit: by patdut.
  • Page:
  • 1
  • 2
Time to create page: 0.290 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica