Welcome, Guest
Username: Password: Remember me
20 Aug 2017
INDI development team is happy to announce the release of INDI Library v1.5.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...
  • Page:
  • 1

TOPIC: Ekos scheduler and 'warm ccd' on shutdown

Ekos scheduler and 'warm ccd' on shutdown 7 months 3 weeks ago #15889

  • dokeeffe
  • dokeeffe's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 276
  • Karma: 1
  • Thank you received: 45
Does anyone have a problem with this feature?
For me, using an ATIK ccd it does not seem to work. All other ccd temperature features in ekos work fine.
Derek

Please Log in or Create an account to join the conversation.

Celestron CPC1100 Atik 383L
HP8300 Elite i5 running Xubuntu, Indi, Kstars & Ekos
Roll off roof observatory
Battling Irish weather
github.com/dokeeffe
twitter.com/BallyhouraStars

Ekos scheduler and 'warm ccd' on shutdown 7 months 3 weeks ago #15911

Does ATIK has CCD_COOLER property?

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Ekos scheduler and 'warm ccd' on shutdown 7 months 3 weeks ago #15942

  • dokeeffe
  • dokeeffe's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 276
  • Karma: 1
  • Thank you received: 45
Yes seems to have, here is the output of indi_getprop. Temperature control works fine for sequences. It sets the temp before staring capture.
dokeeffe@hp-elite:~/ops$ indi_getprop | grep 383
Atik 383L+ CCD.CONNECTION.CONNECT=On
Atik 383L+ CCD.CONNECTION.DISCONNECT=Off
Atik 383L+ CCD.DRIVER_INFO.DRIVER_NAME=Atik 383L+ CCD
Atik 383L+ CCD.DRIVER_INFO.DRIVER_EXEC=indi_atik_ccd
Atik 383L+ CCD.DRIVER_INFO.DRIVER_VERSION=1.17
Atik 383L+ CCD.DRIVER_INFO.DRIVER_INTERFACE=2
Atik 383L+ CCD.CONFIG_PROCESS.CONFIG_LOAD=Off
Atik 383L+ CCD.CONFIG_PROCESS.CONFIG_SAVE=Off
Atik 383L+ CCD.CONFIG_PROCESS.CONFIG_DEFAULT=Off
Atik 383L+ CCD.ACTIVE_DEVICES.ACTIVE_TELESCOPE=Celestron GPS
Atik 383L+ CCD.ACTIVE_DEVICES.ACTIVE_FOCUSER=IP Focuser
Atik 383L+ CCD.ACTIVE_DEVICES.ACTIVE_FILTER=ATIK Wheel
Atik 383L+ CCD.ACTIVE_DEVICES.ACTIVE_SKYQUALITY=SQM
Atik 383L+ CCD.CCD_EXPOSURE.CCD_EXPOSURE_VALUE=1
Atik 383L+ CCD.CCD_ABORT_EXPOSURE.ABORT=Off
Atik 383L+ CCD.CCD_FRAME.X=0
Atik 383L+ CCD.CCD_FRAME.Y=0
Atik 383L+ CCD.CCD_FRAME.WIDTH=3326
Atik 383L+ CCD.CCD_FRAME.HEIGHT=2504
Atik 383L+ CCD.CCD_BINNING.HOR_BIN=2
Atik 383L+ CCD.CCD_BINNING.VER_BIN=2
Atik 383L+ CCD.CCD_TEMPERATURE.CCD_TEMPERATURE_VALUE=12.124542236328125
Atik 383L+ CCD.CCD_INFO.CCD_MAX_X=3326
Atik 383L+ CCD.CCD_INFO.CCD_MAX_Y=2504
Atik 383L+ CCD.CCD_INFO.CCD_PIXEL_SIZE=5.4000000953674316406
Atik 383L+ CCD.CCD_INFO.CCD_PIXEL_SIZE_X=5.4000000953674316406
Atik 383L+ CCD.CCD_INFO.CCD_PIXEL_SIZE_Y=5.4000000953674316406
Atik 383L+ CCD.CCD_INFO.CCD_BITSPERPIXEL=16
Atik 383L+ CCD.CCD_COMPRESSION.CCD_COMPRESS=Off
Atik 383L+ CCD.CCD_COMPRESSION.CCD_RAW=On
Atik 383L+ CCD.CCD_FRAME_TYPE.FRAME_LIGHT=On
Atik 383L+ CCD.CCD_FRAME_TYPE.FRAME_BIAS=Off
Atik 383L+ CCD.CCD_FRAME_TYPE.FRAME_DARK=Off
Atik 383L+ CCD.CCD_FRAME_TYPE.FRAME_FLAT=Off
Atik 383L+ CCD.CCD_RAPID_GUIDE.ENABLE=Off
Atik 383L+ CCD.CCD_RAPID_GUIDE.DISABLE=On
Atik 383L+ CCD.TELESCOPE_TYPE.TELESCOPE_PRIMARY=On
Atik 383L+ CCD.TELESCOPE_TYPE.TELESCOPE_GUIDE=Off
Atik 383L+ CCD.ASTROMETRY_SOLVER.ASTROMETRY_SOLVER_ENABLE=Off
Atik 383L+ CCD.ASTROMETRY_SOLVER.ASTROMETRY_SOLVER_DISABLE=On
Atik 383L+ CCD.WCS_CONTROL.WCS_ENABLE=Off
Atik 383L+ CCD.WCS_CONTROL.WCS_DISABLE=On
Atik 383L+ CCD.UPLOAD_MODE.UPLOAD_CLIENT=On
Atik 383L+ CCD.UPLOAD_MODE.UPLOAD_LOCAL=Off
Atik 383L+ CCD.UPLOAD_MODE.UPLOAD_BOTH=Off
Atik 383L+ CCD.UPLOAD_SETTINGS.UPLOAD_DIR=/home/dokeeffe
Atik 383L+ CCD.UPLOAD_SETTINGS.UPLOAD_PREFIX=IMAGE_XXX
Atik 383L+ CCD.CCD_COOLER.COOLER_OFF=On
Atik 383L+ CCD.CCD_COOLER.COOLER_ON=Off
Atik 383L+ CCD.SHUTTER_CONNECTION.SHUTTER_ON=Off
Atik 383L+ CCD.SHUTTER_CONNECTION.SHUTTER_OFF=On
Atik 383L+ CCD.TIMER_THRESHOLD.TIMER_THRESHOLD=2
Atik 383L+ CCD.ACTIVE_DEVICES.ACTIVE_TELESCOPE=Celestron GPS
Atik 383L+ CCD.ACTIVE_DEVICES.ACTIVE_FOCUSER=IP Focuser
Atik 383L+ CCD.ACTIVE_DEVICES.ACTIVE_FILTER=ATIK Wheel
Atik 383L+ CCD.ACTIVE_DEVICES.ACTIVE_SKYQUALITY=SQM

Please Log in or Create an account to join the conversation.

Celestron CPC1100 Atik 383L
HP8300 Elite i5 running Xubuntu, Indi, Kstars & Ekos
Roll off roof observatory
Battling Irish weather
github.com/dokeeffe
twitter.com/BallyhouraStars
Last Edit: by dokeeffe.

Ekos scheduler and 'warm ccd' on shutdown 7 months 3 weeks ago #15943

If you turn on Ekos logging, you should see it command the warm up. If not let me know and I'll investigate further.
The following user(s) said Thank You: dokeeffe

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Ekos scheduler and 'warm ccd' on shutdown 7 months 3 weeks ago #15944

  • dokeeffe
  • dokeeffe's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 276
  • Karma: 1
  • Thank you received: 45
Here is the kstars log from last night around the time of the shutown (started raining).
I'll try to reproduce and get driver debug logs too. Its not a big deal, I can manually set the temp to 1degree or something before I power off.
2017-04-02T00:29:08.163 - DEBG - IP Focuser :  "Focuser is moving to requested position "
2017-04-02T00:29:08.308 - DEBG - IP Focuser :  "Focuser moved to position 10386 "
2017-04-02T00:29:08.309 - DEBG - Focus:  "Capturing image..."
2017-04-02T00:29:09.427 - DEBG - Scheduler:  "Caution! Weather conditions are in the DANGER zone!"
2017-04-02T00:29:09.445 - DEBG - Scheduler:  "Caution! Weather conditions are in the DANGER zone!"
2017-04-02T00:29:09.446 - DEBG - Scheduler:  "Starting shutdown procedure due to severe weather."
2017-04-02T00:29:09.446 - DEBG - Scheduler: Stop current action...
2017-04-02T00:29:09.447 - DEBG - Scheduler: Checking shutown state...
2017-04-02T00:29:09.447 - DEBG - Scheduler: Starting shutdown process...
2017-04-02T00:29:09.447 - DEBG - Scheduler:  "Warming up CCD..."
2017-04-02T00:29:09.448 - DEBG - WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
2017-04-02T00:29:09.448 - DEBG - WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
2017-04-02T00:29:09.448 - DEBG - WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
2017-04-02T00:29:09.448 - DEBG - WARNING: bool Phonon::FactoryPrivate::createBackend() phonon backend plugin could not be loaded
2017-04-02T00:29:09.449 - WARN - Audio notification requested, but sound file from notifyrc file was not found, aborting audio notification
2017-04-02T00:29:10.428 - DEBG - Scheduler: Checking shutown state...
2017-04-02T00:29:10.428 - DEBG - ISD:Telescope: Parking...

2017-04-02T00:29:10.428 - DEBG - Scheduler:  "Parking mount..."
2017-04-02T00:29:10.444 - DEBG - Celestron AuxRemote Gateway :  "Parking to Az (180:00:00) Alt ( 0:00:00)... "
2017-04-02T00:29:10.456 - DEBG - Celestron AuxRemote Gateway :  "Parking to RA (11:37:16) DEC (-38:06:01)... "
2017-04-02T00:29:10.466 - DEBG - Celestron AuxRemote Gateway :  "{\"raHours\":11.621250 ,\"dec\":-38.100300 , \"type\":\"park\"} POST to /mount/target OK "
2017-04-02T00:29:10.476 - DEBG - Celestron AuxRemote Gateway :  "Park request sent to mount "

Please Log in or Create an account to join the conversation.

Celestron CPC1100 Atik 383L
HP8300 Elite i5 running Xubuntu, Indi, Kstars & Ekos
Roll off roof observatory
Battling Irish weather
github.com/dokeeffe
twitter.com/BallyhouraStars

Ekos scheduler and 'warm ccd' on shutdown 7 months 3 weeks ago #15948

From the log above it looks like it's issuing the command. Need to check ATIK log if it received it. Tested with simulators and it was OK.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Ekos scheduler and 'warm ccd' on shutdown 7 months 2 weeks ago #15971

  • dokeeffe
  • dokeeffe's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 276
  • Karma: 1
  • Thank you received: 45
I did some more investigation and I think its something odd with the ATIK ccd driver. I think the Cooler ON/OFF switch does not work.

I set my CCD to -10, then in the scheduler I used the button to force running the shutdown procedure.
Here is the output of indiserver -vv
2017-04-04T20:57:30: Client 0: read <newSwitchVector device='Atik 383L+ CCD' name='CCD_COOLER'>
2017-04-04T20:57:30: Driver indi_atik_ccd: queuing responsible for <newSwitchVector device='Atik 383L+ CCD' name='CCD_COOLER'>
2017-04-04T20:57:30: Driver indi_atik_ccd: sending <newSwitchVector device="Atik 383L+ CCD" name="CCD
2017-04-04T20:57:30: Driver indi_atik_ccd: read <setSwitchVector device='Atik 383L+ CCD' name='CCD_COOLER'>
2017-04-04T20:57:30: Client 0: queuing <setSwitchVector device='Atik 383L+ CCD' name='CCD_COOLER'>
2017-04-04T20:57:30: Client 0: sending <setSwitchVector device="Atik 383L+ CCD" name="CCD
2017-04-04T20:57:30: Driver indi_atik_ccd: read <setNumberVector device='Atik 383L+ CCD' name='CCD_TEMPERATURE'>
2017-04-04T20:57:30: Client 0: queuing <setNumberVector device='Atik 383L+ CCD' name='CCD_TEMPERATURE'>
2017-04-04T20:57:30: Client 0: sending <setNumberVector device="Atik 383L+ CCD" name="CCD
2017-04-04T20:57:31: Client 0: read EOF
2017-04-04T20:57:31: Client 0: shut down complete - bye!

Then I waited a minute or 2 and re-connected the indi driver for the CCD. Ekos still reporting the temp as -10. See screenshot


What is the scheduler doing. Is it switching off the cooler or setting a temp to a higher temp?
I think the cooler on/off button in the ATIK driver does not work.

Anyway its no big deal, I can call indi_setprop in a shell script to set the temp to +5deg or something like that
Attachments:

Please Log in or Create an account to join the conversation.

Celestron CPC1100 Atik 383L
HP8300 Elite i5 running Xubuntu, Indi, Kstars & Ekos
Roll off roof observatory
Battling Irish weather
github.com/dokeeffe
twitter.com/BallyhouraStars

Ekos scheduler and 'warm ccd' on shutdown 7 months 2 weeks ago #15975

yeah it it just switching cooler off, not explicitly setting a higher temperature.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Ekos scheduler and 'warm ccd' on shutdown 7 months 1 week ago #16209

I checked the driver (with control pane, not Ekos and with Atik One, but it is the same camera type as 383L) and set cooler on/off seems to work. But there are two potential issues:

1. Whenever camera connected, driver reports, that cooler is set off, but it is not necessary true.

2. When temperature is set and cooler is off, it is set on automatically. So if you will turn it off and set temperature to +5C, you will actually turn it on again. I think that this does make a sense.

Peter
The following user(s) said Thank You: dokeeffe

Please Log in or Create an account to join the conversation.

Ekos scheduler and 'warm ccd' on shutdown 7 months 1 week ago #16210

  • dokeeffe
  • dokeeffe's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 276
  • Karma: 1
  • Thank you received: 45
Thanks Peter,
I guess if its possible for ekos to 'un-set' the temperature as well as turning off the cooler then this may work.
For the time being I have a shell script to call indi_setprop to set the temp to 0 and wait 5min before it powers off everything. This script is called by ekos on shutdown and seems to work.
Derek

Please Log in or Create an account to join the conversation.

Celestron CPC1100 Atik 383L
HP8300 Elite i5 running Xubuntu, Indi, Kstars & Ekos
Roll off roof observatory
Battling Irish weather
github.com/dokeeffe
twitter.com/BallyhouraStars
  • Page:
  • 1
Time to create page: 0.146 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica