Welcome, Guest
Username: Password: Remember me
20 Aug 2017
INDI development team is happy to announce the release of INDI Library v1.5.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...
  • Page:
  • 1
  • 2

TOPIC: Installing INDI on Ubuntu 16.10

Installing INDI on Ubuntu 16.10 6 months 2 weeks ago #15893

  • Raem
  • Raem's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 13
  • Thank you received: 0
Hello,

I am trying to install INDI full on my Ubuntu laptop but I encounter a missing dependencies error. I have followed the steps described on the INDI download page (add the PPA, update, and install indi-full). The error messages say that the package "1.2.0-2~ubuntu2" is already installed and it seems to cause problems, and the fix command is not able to solve the problem. Can you help me ?

Thanks

Please Log in or Create an account to join the conversation.

Installing INDI on Ubuntu 16.10 6 months 2 weeks ago #15894

  • oleg
  • oleg's Avatar
  • Away
  • Moderator
  • Moderator
  • Ubuntu Astronomy
  • Posts: 268
  • Karma: 3
  • Thank you received: 76
You can try install latest INDI with drivers according this instruction: see page github.com/indilib/indi

Please Log in or Create an account to join the conversation.

You can try my open project Ubuntu Astronomy

Installing INDI on Ubuntu 16.10 6 months 2 weeks ago #15896

  • Raem
  • Raem's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 13
  • Thank you received: 0
Thank you for your answer. I encounter the same error message when I try to install the pre-requisites. The command "apt-get -f install" indicates that the libindi1 package must be updated but I have the following errors :

Preparation to unpack .../libindi1_1.4.1+r3026~201704011202~ubuntu16.10.1_amd64.deb ...
Unpacking libindi1:amd64 (1.4.1+r3026~201704011202~ubuntu16.10.1) sur (1.2.0-2~ubuntu2) ...
dpkg: error processing the archive /var/cache/apt/archives/libindi1_1.4.1+r3026~201704011202~ubuntu16.10.1_amd64.deb (--unpack) :
trying to replace « /usr/lib/x86_64-linux-gnu/libindidriver.so.1 », belonging to package libindidriver1:amd64 1.2.0-2~ubuntu2
Issues have been encountered during execution:
/var/cache/apt/archives/libindi1_1.4.1+r3026~201704011202~ubuntu16.10.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

(I translated from french, it may be different from a true english display)

I am not very used to packages management yet so I don't see how to fix this.

Please Log in or Create an account to join the conversation.

Installing INDI on Ubuntu 16.10 6 months 2 weeks ago #15904

It looks like you have ald version of libindi present on your system. Remove it first with apt-get remove --purge libindi1

Please Log in or Create an account to join the conversation.

Installing INDI on Ubuntu 16.10 6 months 2 weeks ago #15909

Remove existing INDI first
sudo apt-get remove libindi1 libindidriver1 indi-bin

Then try to install libindi again from the PPA.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Installing INDI on Ubuntu 16.10 6 months 2 weeks ago #15912

  • oleg
  • oleg's Avatar
  • Away
  • Moderator
  • Moderator
  • Ubuntu Astronomy
  • Posts: 268
  • Karma: 3
  • Thank you received: 76
IMHO, this page indilib.org/download/ubuntu.html needs the change.

Please Log in or Create an account to join the conversation.

You can try my open project Ubuntu Astronomy

Installing INDI on Ubuntu 16.10 6 months 2 weeks ago #15915

  • Raem
  • Raem's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 13
  • Thank you received: 0
I have tried to remove INDI packages as suggested but even the removal gives the same missing dependencies error: "[many packages] depend on libindi1 but won't be installed". And if I install INDI again (apt-get install indi-full), the missing dependency appears again with the same message.

Thank you all for your answers.

Please Log in or Create an account to join the conversation.

Installing INDI on Ubuntu 16.10 6 months 2 weeks ago #15925

You need to force removal.. so maybe run
sudo apt-get -f install

and see if that works.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Installing INDI on Ubuntu 16.10 6 months 2 weeks ago #15926

  • oleg
  • oleg's Avatar
  • Away
  • Moderator
  • Moderator
  • Ubuntu Astronomy
  • Posts: 268
  • Karma: 3
  • Thank you received: 76
Raem,
in any case, you can download my open project Ubuntu Astronomy 16.04 (64 bit) and try its in Live DVD regime :)

Please Log in or Create an account to join the conversation.

You can try my open project Ubuntu Astronomy
Last Edit: by oleg.

Installing INDI on Ubuntu 16.10 6 months 2 weeks ago #15935

  • Raem
  • Raem's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 13
  • Thank you received: 0
I send you the messages after typing "sudo apt-get -f install" :

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
libindidriver1 linux-headers-4.8.0-22 linux-headers-4.8.0-22-generic
linux-headers-4.8.0-34 linux-headers-4.8.0-34-generic linux-headers-4.8.0-37
linux-headers-4.8.0-37-generic linux-image-4.8.0-22-generic
linux-image-4.8.0-34-generic linux-image-4.8.0-37-generic
linux-image-extra-4.8.0-22-generic linux-image-extra-4.8.0-34-generic
linux-image-extra-4.8.0-37-generic linux-signed-image-4.8.0-34-generic
linux-signed-image-4.8.0-37-generic ubuntu-core-launcher
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
libindi1
The following packages will be upgraded:
libindi1
1 to upgrade, 0 to newly install, 0 to remove and 5 not to upgrade.
36 not fully installed or removed.
Need to get 0 B/250 kB of archives.
After this operation, 829 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
(Reading database ... 328157 files and directories currently installed.)
Preparing to unpack .../libindi1_1.4.1+r3026~201704011202~ubuntu16.10.1_amd64.deb ...
Unpacking libindi1:amd64 (1.4.1+r3026~201704011202~ubuntu16.10.1) over (1.2.0-2~ubuntu2) ...
dpkg: error processing archive /var/cache/apt/archives/libindi1_1.4.1+r3026~201704011202~ubuntu16.10.1_amd64.deb (--unpack):
trying to overwrite '/usr/lib/x86_64-linux-gnu/libindidriver.so.1', which is also in package libindidriver1:amd64 1.2.0-2~ubuntu2
Errors were encountered while processing:
/var/cache/apt/archives/libindi1_1.4.1+r3026~201704011202~ubuntu16.10.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

If I try to install any other package, I receive a message after building the dependence tree :
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies.
libindi-dev : Depends: libindi1 (= 1.4.1+r3026~201704011202~ubuntu16.10.1) but 1.2.0-2~ubuntu2 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).


Oleg, is it possible to install your solution on the computer or it is only for a Live DVD use ?

Please Log in or Create an account to join the conversation.

Installing INDI on Ubuntu 16.10 6 months 2 weeks ago #15937

  • oleg
  • oleg's Avatar
  • Away
  • Moderator
  • Moderator
  • Ubuntu Astronomy
  • Posts: 268
  • Karma: 3
  • Thank you received: 76

Raem wrote: ...
Oleg, is it possible to install your solution on the computer or it is only for a Live DVD use ?

Yes, you can install it on your computer.

Also, see information on page sourceforge.net/projects/ubuntu-astronomy-16-04/

Please Log in or Create an account to join the conversation.

You can try my open project Ubuntu Astronomy

Installing INDI on Ubuntu 16.10 6 months 2 weeks ago #15941

Try this:
sudo apt-get -o Dpkg::Options::="--force-overwrite" install

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
  • Page:
  • 1
  • 2
Time to create page: 0.581 seconds

Login

3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica