Welcome, Guest
Username: Password: Remember me
25 Jul 2018
Glad to announce of release of INDI Library v1.7.4 on 2018-07-25. A few drivers were added in this release as we continue to improve & stabilize existing drivers.
Read More...

TOPIC: Astroberry Server

Astroberry Server 6 months 4 weeks ago #22551

  • Kaczorek
  • Kaczorek's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 451
  • Karma: 6
  • Thank you received: 164
You can upgrade INDI version by regular sudo apt-get update && sudo apt-get upgrade

Please Log in or Create an account to join the conversation.

Astroberry Server 6 months 2 weeks ago #22847

Hi,

1. Any way to gives the SBC a static IP address so that in the field I can connect via a direct Ethernet cable for troubleshooting if Wifi down?
2. I can't connect to Astroberry server via web browser. Password is astroberry.



Thanks
Attachments:

Please Log in or Create an account to join the conversation.

Last Edit: by tmheroes.

Astroberry Server 6 months 2 weeks ago #22890

I'm having the same issue. I've tried Google Chrome and Explorer and I get the same connection not private issues. I'm certain it's something in my security settings but I don't know what. I started Astroberry from scratch and it loaded fine on the Pi and then I went to my laptop to connect per the instructions for setting up the connection and get that same screen. Dead end at that point.

Please Log in or Create an account to join the conversation.

Astroberry Server 6 months 2 weeks ago #22894

  • Kaczorek
  • Kaczorek's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 451
  • Karma: 6
  • Thank you received: 164
Privacy issue probably comes from strict rules implemented in browsers recently. Astroberry Server uses self signed certificates and the browsers do not like it. I will try to propose a solution soon.

For the network connection - Astroberry Server works as a wifi access point / hot spot so you can connect to it in the field. I leave it to users to configure ethernet port as they want. What you can do is to configure it with a static IP (see Static IP Address Assignment here ) or even setup a dhcp server on ethernet port (see here ). Please note that reconfiguring network interfaces migh render your device unaccessible over network. If you get into trouble use HDMI to connect it to a screen and fix it.

Please Log in or Create an account to join the conversation.

Astroberry Server 6 months 1 week ago #23019

I got past that connection not private screen this evening! I had to open the Keychain program on my Mac and import the certificate from there. It wasn't installing when I simply clicked on your link. I was VNC'ing in before but now I'm getting in directly with the browser.

Next question. When I attempt to connect to my home WiFi by using the wlan setup (either via command line or by using the GUI on the desktop), the dropdown area that should be showing networks I can connect to is grayed out and I can't select a network or type one in. Any idea's on that?
Thanks;
James

Please Log in or Create an account to join the conversation.

Astroberry Server 6 months 1 week ago #23026

Hi James,

I assume you were using the wlanconf command (see section how to configure, attached link), correct?

github.com/rkaczorek/astroberry-server

I remember that I once also had the problem with networks not being accessible or network adapter. Did you try “ipconfig” to check network status? There are many hints to restart wlan0 on the internet (but better not to change any of the scripts - not needed!).

Good luck!

Helge

Please Log in or Create an account to join the conversation.

Astroberry Server 6 months 1 week ago #23041

Helge, thanks and - yes, I tried wlanconf via terminal both with and without GUI as well as trying to do it via the icon on the desktop. I have all of my ip addresses, etc. configured correctly. I know this, because I have my local network very well mapped/configured and have the Astroberry connecting to my laptop and Mac via VNC, SSH over the astroberry wireless server and as well as using Ethernet direct between the Pi3 and my laptop. What's missing is that my router cannot see the wireless router on the Pi3 and when I run wlanconf, the option to select a wireless network is missing or I get an error. I can provide screen shots later if you're interested in looking into it further.
Is it possible that having astroberry server running on through wireless is preventing the Pi from attempting to acces any other wireless network? Perhaps I should shut down the server and try it? I'm afraid to do that right now.

Frankly, this isn't as big an issues as I might be making it seem because I really have no reason to connect my astroberry to my local network unless I'm updating something and I'll use ehternet for that. The astroberry server is working fine and connecting to my field laptop both wirelessly and via an enternet cable connecting directly for wireless ops - so I'm pretty happy with it at the moment. I just represents a mystery I'd like to understand.

Please Log in or Create an account to join the conversation.

Astroberry Server 6 months 1 week ago #23047

Hm...not sure if I can be of any help. To be honest, I am myself still fairly new to all this. Just in case this is useful, I copied below the content of what is written in the wpa_supplicant file, which you can access with the following command: sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

Maybe this is also useful (but I am sure you already found this or similar pages): www.raspberrypi.org/documentation/config...less/wireless-cli.md

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
ssid="my network"
psk="my wpa2"
}
The following user(s) said Thank You: u2pilotjt

Please Log in or Create an account to join the conversation.

Astroberry Server 6 months 1 week ago #23094

Are there any settings in the Astroberry config.txt files associated with over-clocking that have been set? When I had set up my Pi3 with INDI/EKOS a year ago, I overclocked my Pi3 and found some slight gains in the image captures. I see that force_turbo is set to 1. Before I toy with settings, I wanted to check to see if that will be an issue. Normally, the force turbo is commented out and it's at whatever the default is.

Please Log in or Create an account to join the conversation.

Astroberry Server 6 months 1 week ago #23121

  • Kaczorek
  • Kaczorek's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 451
  • Karma: 6
  • Thank you received: 164
The only related setting is the one you have already identified - force_turbo=1. This however is not really about overclocking, instead it fixes cpu clock for secondary serial line. Note that RPi3 comes with 2 serials: one for bluetooth and one for free use (actually you can use both of them while bluetooth is disabled). Secondary serial line speed is cpu dependent so if used force_turbo=1 is a recommended setting. Otherwise the line might get unstable.

Please Log in or Create an account to join the conversation.

Astroberry Server - wlanconfig 6 months 1 week ago #23140

Dear Radek,

I freshly generated a SD card and boot my RasPi with it.
I am now having a question regarding wlanconfig.
I can connect to the astroberry server with my Android tablet and Firefox.
I followed the procedure to install the security certificates.
Now I want to connect it to my WiFi network using wlancofig.
wlanconfig first ask for admin password where I entered astroberry. It then comes up with a dialog with a network and a password field.
I am only allowed to enter something into the password field. The Network field seems to be locked.
Do you have a short description on how should I connect the RasPi to let's say SSID myWiFi with password xyz?

Thanks in advance
Roger

Please Log in or Create an account to join the conversation.

Astroberry Server - wlanconfig 6 months 1 week ago #23160

  • Kaczorek
  • Kaczorek's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 451
  • Karma: 6
  • Thank you received: 164
Hi Roger. It seems that wireless networks are not discovered with wlanconf-gui... In such a case use wlanconf - open your terminal and run:
sudo wlanconf
You will be asked for network name and password and you're done ;-)

PS. If nothing works you can add your network to /etc/wpa_supplicant/wpa_supplicant.conf

Please Log in or Create an account to join the conversation.

Last Edit: by Kaczorek.
Time to create page: 0.193 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica