Welcome, Guest
Username: Password: Remember me
27 Feb 2017
INDI development team is happy to announce the release of INDI Library v1.4.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers. Several improvements and enhancements are included in this release including native support for Cygwin and MacOS platforms in addition to Linux, BSD, and Windows (Client only).
Read More...
  • Page:
  • 1

TOPIC: Kstars OS X missing drivers

Kstars OS X missing drivers 3 months 2 weeks ago #16500

I downloaded KStars today and watched some videos on it. I think I am going to like Ekos if I can ever get it setup correctly.

I have an ASI1600MM-C and if I go into the device manager I can see the ZWO CCD driver but it won't let me start the service. So I downloaded INDI Server from CloudMakers and I have it running and I can select the ZWO driver. I can then add a host under the Client tab in the device manager and get the INDI Control Panel to show my camera and I can connect but when I try to create a profile in Ekos the ZWO CCD doesn't show up if the mode is set to local. When I set the mode to remote the ZWO CCD shows up but the tooltip says "Available as a REMOTE driver. To use locally, install the corresponding driver" I'm sure it is because I just starting trying to use the app but I am stuck.

On a related note the Ekos window seem to always want to be on top and I don't see a way to change that. Also even after I resize it smaller it tends to jump back to a size that takes up most of the screen. It would be nice if it remembered the size and position and stayed there unless I change it.

Thanks,
Eric

Please Log in or Create an account to join the conversation.

Kstars OS X missing drivers 3 months 2 weeks ago #16502

Hi Eric,

The ZWO issue should be fixed in the next DMG build soon. For the Ekos Window, Robert can comment on this aspect. Hopefully we should have another build in a couple of days.
The following user(s) said Thank You: ColoradoSolar

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Kstars OS X missing drivers 3 months 2 weeks ago #16517

  • rlancaste
  • rlancaste's Avatar
  • Away
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 763
  • Karma: 6
  • Thank you received: 96
Yep, its fixed now. See my reply in the OS X forum.

Please Log in or Create an account to join the conversation.

Kstars OS X missing drivers 3 months 1 week ago #16527

  • rlancaste
  • rlancaste's Avatar
  • Away
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 763
  • Karma: 6
  • Thank you received: 96

On a related note the Ekos window seem to always want to be on top and I don't see a way to change that. Also even after I resize it smaller it tends to jump back to a size that takes up most of the screen. It would be nice if it remembered the size and position and stayed there unless I change it.


Eric, there is an option in the Preferences under the Ekos tab called "Independent Window." This will make Ekos a separate window and then it can go behind KStars and minimized and maximized separately.

Please Log in or Create an account to join the conversation.

Kstars OS X missing drivers 3 months 1 week ago #16528

I found the independent window option and it seems to work fine. One strange thing that has happened and I don't know how I did it is that the Ekos window is now a tab in the main kstars window. I don't mind it being that way but I'm not sure how I did it.

Please Log in or Create an account to join the conversation.

Kstars OS X missing drivers 3 months 1 week ago #16533

  • rlancaste
  • rlancaste's Avatar
  • Away
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 763
  • Karma: 6
  • Thank you received: 96

ColoradoSolar wrote: I found the independent window option and it seems to work fine. One strange thing that has happened and I don't know how I did it is that the Ekos window is now a tab in the main kstars window. I don't mind it being that way but I'm not sure how I did it.


The is a dock on the right hand side for the Whats Interesting window. But I don't know how you got Ekos into it?? I once edited the kstars code to put it in there just to see if that would be nice, but I changed it back. If you figure out how, it would be useful info

Please Log in or Create an account to join the conversation.

Kstars OS X missing drivers 3 months 1 week ago #16535

This is not on the right hand side. The Ekos window is in a tab at the top of the screen. Not sure how to upload a screen shot to show you what I'm talking about.

Please Log in or Create an account to join the conversation.

Kstars OS X missing drivers 3 months 1 week ago #16537

  • rlancaste
  • rlancaste's Avatar
  • Away
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 763
  • Karma: 6
  • Thank you received: 96

ColoradoSolar wrote: This is not on the right hand side. The Ekos window is in a tab at the top of the screen. Not sure how to upload a screen shot to show you what I'm talking about.


Does it look like this?
Attachments:

Please Log in or Create an account to join the conversation.

Kstars OS X missing drivers 3 months 1 week ago #16538

Nope. It looks like this. Notice the 2 tabs across the top.
Attachments:

Please Log in or Create an account to join the conversation.

Kstars OS X missing drivers 3 months 1 week ago #16539

BTW. How do you get the image to show up in the message instead of just as an attachment?

Please Log in or Create an account to join the conversation.

Kstars OS X missing drivers 3 months 1 week ago #16540

  • rlancaste
  • rlancaste's Avatar
  • Away
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 763
  • Karma: 6
  • Thank you received: 96

ColoradoSolar wrote: BTW. How do you get the image to show up in the message instead of just as an attachment?


Ok, yeah, I have NO idea how you got the tabs at the top. The thing that I tried was using the newer OS X window side by side maximized feature. But I do't have any idea how you got it like that. To get the image to show up inline you need to click on the "Insert" button after you attach the image.

Please Log in or Create an account to join the conversation.

Kstars OS X missing drivers 3 months 1 week ago #16542

I figured out the tabs. It is an OS X feature. In System Preferences->Dock there is a setting "Prefer tabs when opening documents". I think it makes kstars easier to use.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.262 seconds

Login

3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!

Gallery

Replica

Why INDI

Replica