Welcome, Guest
Username: Password: Remember me
20 Aug 2017
INDI development team is happy to announce the release of INDI Library v1.5.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...
  • Page:
  • 1

TOPIC: KStars crashes during session

KStars crashes during session 4 months 2 weeks ago #17138

  • Kaczorek
  • Kaczorek's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 379
  • Karma: 3
  • Thank you received: 124
I'm constantly getting KStars crash after a few images are captured with Ekos. I cannot debug it due to the following error:
astroberry@astroberry:~$ gdb --args kstars
GNU gdb (Ubuntu 7.11.1-0ubuntu1~16.04) 7.11.1
Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "arm-linux-gnueabihf".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from kstars...Reading symbols from /usr/lib/debug//usr/bin/kstars...done.
done.
(gdb) run
Starting program: /usr/bin/kstars 

Program received signal SIGSEGV, Segmentation fault.
0x76fd9822 in ?? () from /lib/ld-linux-armhf.so.3
(gdb) bt
#0  0x76fd9822 in ?? () from /lib/ld-linux-armhf.so.3
#1  0x76fd983a in ?? () from /lib/ld-linux-armhf.so.3
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

I have reports from my mates of the same issue.
phonon4qt5-backend-gstreamer has been replaced with phonon4qt5-backend-vlc was installed. So I assume that it's not notifications issue.
There's nothing meaningful in the KStars logs.

When running from terminal KStars segfaults with the following:
astroberry@astroberry:~$ kstars
libEGL warning: DRI2: failed to authenticate
Dispatch command error(-2): Error: Property SIMULATORMODE not found in device EQMod Mount.
<delProperty device="EQMod Mount" name="SIMULATORMODE" timestamp="2017-06-03T20:17:24"/>
Dispatch command error(-2): Error: Property SIMULATORWORM not found in device EQMod Mount.
<delProperty device="EQMod Mount" name="SIMULATORWORM" timestamp="2017-06-03T20:17:24"/>
Dispatch command error(-2): Error: Property SIMULATORRATIO not found in device EQMod Mount.
<delProperty device="EQMod Mount" name="SIMULATORRATIO" timestamp="2017-06-03T20:17:24"/>
Dispatch command error(-2): Error: Property SIMULATORMOTOR not found in device EQMod Mount.
<delProperty device="EQMod Mount" name="SIMULATORMOTOR" timestamp="2017-06-03T20:17:24"/>
Dispatch command error(-2): Error: Property SIMULATORHIGHSPEED not found in device EQMod Mount.
<delProperty device="EQMod Mount" name="SIMULATORHIGHSPEED" timestamp="2017-06-03T20:17:24"/>
Dispatch command error(-2): Error: Property SIMULATORMCVERSION not found in device EQMod Mount.
<delProperty device="EQMod Mount" name="SIMULATORMCVERSION" timestamp="2017-06-03T20:17:24"/>
Found one coordinate representation.
Segmentation fault

Any ideas?

UPDATE: I have just found out that setting delay in Ekos capture module (e.g. 10s) between images keeps the session stable. Are we facing a race condition somewhere in the code?

Please Log in or Create an account to join the conversation.

Last Edit: by Kaczorek.

KStars crashes during session 4 months 2 weeks ago #17140

  • maudy
  • maudy's Avatar
  • Away
  • Gold Boarder
  • Gold Boarder
  • Posts: 309
  • Karma: 2
  • Thank you received: 23
Thank you for the 10s find... I will try this next session.

Please Log in or Create an account to join the conversation.

KStars crashes during session 4 months 2 weeks ago #17146

Thanks for report, I will try to test this tonight in my observatory.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

KStars crashes during session 4 months 2 weeks ago #17158

I *think* I fixed the issue, there should be a new build within the next couple of hours.
The following user(s) said Thank You: Kaczorek, xsnrg

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

KStars crashes during session 4 months 1 week ago #17221

  • Kaczorek
  • Kaczorek's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 379
  • Karma: 3
  • Thank you received: 124
I have just tested it and it looks like the issue has been fixed. Thanks a lot Jasem.
Out of curiosity - what was the root cause of the issue?

Please Log in or Create an account to join the conversation.

KStars crashes during session 4 months 1 week ago #17232

It was loading WCS data asynchronously. It is a CPU intensive process so it was offloaded to a separate thread. However, sometimes the FITS file itself is closed before the WCS loading is over and hence you get crash on slow machines. WCS data is now loaded on demand.
The following user(s) said Thank You: Kaczorek

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

KStars crashes during session 4 months 1 week ago #17242

  • Kaczorek
  • Kaczorek's Avatar Topic Author
  • Offline
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 379
  • Karma: 3
  • Thank you received: 124
It was definitely fixed with the imaging session. However, I have just noted that when you select Show Equatorial Gridlines on Setup tab in Ekos the KStars goes down. Is is possible that it's related to loading WCS on demand?

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.145 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica