Welcome, Guest
Username: Password: Remember me
08 Apr 2018
INDI development team is happy to announce the release of INDI Library v1.7.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...
  • Page:
  • 1
  • 2

TOPIC: INDI and kstars running on Asus Tinker Board

INDI and kstars running on Asus Tinker Board 10 months 1 week ago #17937

  • petarm
  • petarm's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 69
  • Thank you received: 9
Hi everyone, I recently purchased an Asus Tinker Board. I'm sure everyone on this forum knows what they are, but here is a link

www.asus.com/au/Motherboards/Tinker-Board/

Essentially it is a raspberry pi 3 on steroids. Its a single board computer with 2GB Dual Channel DDR3, Rockchip Quad-Core RK3288 processor clocked at 1.8GHz and 802.11 b/g/n, Bluetooth V4.0 + EDR, and its exactly the same size as a RPi (it actually fits in the RPi case!!). It even has all the GPIO headers, USB and Ethernet ports and so on in the same place as the pi.

And its fast.

So i downloaded and installed this OS image:

plus.google.com/+ELARSystems/posts/AtFHv2xGNuX

Installed kstars/ekos and hey presto i can run everything from this board like on a proper PC running desktop Ubuntu.

This device should be able to be used as a power efficient observatory control all computer (you just remote to it). To keep buy a real time clock module for it.

I'll keep playing with it and let you know of any issues.
The following user(s) said Thank You: knro

Please Log in or Create an account to join the conversation.

Takahashi FC-100DF, Skywatcher HEQ5 Pro, Canon 1100D, Orion 50mm guide scope with ZWO ASI 120MC, homebuilt bluetooth moonlite focuser, Asus Tinkerboard running Armbian Ubuntu 16.04LTS with kstars ( github.com/Patrick-81/NAFABox )

INDI and kstars running on Asus Tinker Board 10 months 1 week ago #17939

  • Gilles
  • Gilles's Avatar
  • Away
  • Expert Boarder
  • Expert Boarder
  • Posts: 83
  • Karma: 2
  • Thank you received: 16
Hi
Some french forumers have made nice scripts to complete installation on this board, in order to control software remotely with a tablet
www.webastro.net/forum/showthread.php?t=148388
lroge.scenari-community.org/TinkerAstro/co/Tinkerboard.html
It's in french... google translate...
I've tried to use it in rpi3, it's working quite well...
Gilles
The following user(s) said Thank You: petarm

Please Log in or Create an account to join the conversation.

Last Edit: by Gilles.

INDI and kstars running on Asus Tinker Board 10 months 1 week ago #17952

  • petarm
  • petarm's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 69
  • Thank you received: 9
Hi Gilles, sounds good, I'll give it a try.

Please Log in or Create an account to join the conversation.

Takahashi FC-100DF, Skywatcher HEQ5 Pro, Canon 1100D, Orion 50mm guide scope with ZWO ASI 120MC, homebuilt bluetooth moonlite focuser, Asus Tinkerboard running Armbian Ubuntu 16.04LTS with kstars ( github.com/Patrick-81/NAFABox )

INDI and kstars running on Asus Tinker Board 10 months 1 week ago #17960

  • petarm
  • petarm's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 69
  • Thank you received: 9
Hi Giles I have it running on the tinker board. But the Ubuntu desktop is in French. What is the password so I can change the language? Or do I need to ask the French blokes?

Please Log in or Create an account to join the conversation.

Takahashi FC-100DF, Skywatcher HEQ5 Pro, Canon 1100D, Orion 50mm guide scope with ZWO ASI 120MC, homebuilt bluetooth moonlite focuser, Asus Tinkerboard running Armbian Ubuntu 16.04LTS with kstars ( github.com/Patrick-81/NAFABox )

INDI and kstars running on Asus Tinker Board 10 months 1 week ago #17961

  • Gilles
  • Gilles's Avatar
  • Away
  • Expert Boarder
  • Expert Boarder
  • Posts: 83
  • Karma: 2
  • Thank you received: 16
Hi
I think default root password of tinkerboard is 1234
Have you tried that ?
Anyway, feel free to join us on french forum
Or i can try to help you here if you prefer

Please Log in or Create an account to join the conversation.

INDI and kstars running on Asus Tinker Board 10 months 1 week ago #17962

  • patdut
  • patdut's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 285
  • Karma: 1
  • Thank you received: 33
@Petarm
If you do installed the ELARSystem image the password is the one used to sudo commands.
Otherwise, just install the legacy armbian image : www.armbian.com/tinkerboard/
Git clone the scripts. Be aware that the first menu prompts you if you want to continue the install in french.
I suggest you to check the mate desktop install and not to check the french install.
I must admit that I didn't tested the install in english. I will test it tomorrow.
Good luck

Please Log in or Create an account to join the conversation.

Last Edit: by patdut.

INDI and kstars running on Asus Tinker Board 10 months 1 week ago #17963

The password may have changed.
For the tinkerboard NAFA box image burnt on the microSD card, last I checked the admin password was: nafa
For the microSD card, created from Armbian image, root password should be 1234 (qwerty keyboard).

Let us know if you managed to get back to a shakespearean environment.

The english version of the french Tinkerboard site should be available soon, being translated "properly" not googled translated....

Please Log in or Create an account to join the conversation.

Last Edit: by Sebriviere.

INDI and kstars running on Asus Tinker Board 10 months 1 week ago #17975

  • petarm
  • petarm's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 69
  • Thank you received: 9
hi Gilles, patdut and Sebriviere. Thanks for all your suggestions and help.

So i managed to change everything to English. Just looked at the menus on my rpi3 which runs ubuntu mate.

I discovered the the password for the NAFABox flash is nafa. The img flash does not use a qwerty keyboard, so i was typing "nqfq" not "nafa".

I confirgured VNC and could see the NAFABox on my mobile phone and could control the NAFABox desktop (still no luck configuring it on my laptop using remmina, i dont have a tablet).

The only issue i now have with the NAFABox flash is there is no bluetooth. I installed blueman, it opens but all the pull down menus are inactive. I tried bluetoothctl, but it cant find the bluetooth radio on the tinker board. I run a shoestring BT adapter on my HEQ5 and a BT joystick. Funny thing is that the ELARSystem image BT works out of the box.

My initial flash was the ELARSystem image and i managed to manually install kstars.ekos/indi/phd2/ everything and everything works fine (my very first post). But i need to work out how to VNC to control the thing. Still have not managed to do this. I wonder if i can run the hotspot.sh tool from NAFAbox flash on this flash?? to automatically configure the VNC on the ELARSystem flash?? Or the other way i can do it is to create a static IP and wifi direct (as i now do on my rpi3). But the issue with this is i cant connect to the internet via wifi.

So this is where im at. Again thanks for all your help.

Please Log in or Create an account to join the conversation.

Takahashi FC-100DF, Skywatcher HEQ5 Pro, Canon 1100D, Orion 50mm guide scope with ZWO ASI 120MC, homebuilt bluetooth moonlite focuser, Asus Tinkerboard running Armbian Ubuntu 16.04LTS with kstars ( github.com/Patrick-81/NAFABox )

INDI and kstars running on Asus Tinker Board 10 months 1 week ago #17977

  • petarm
  • petarm's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 69
  • Thank you received: 9
Hi everyone, its all working now. The Nafabox config on git works very well.
Thanks for all your help

Please Log in or Create an account to join the conversation.

Takahashi FC-100DF, Skywatcher HEQ5 Pro, Canon 1100D, Orion 50mm guide scope with ZWO ASI 120MC, homebuilt bluetooth moonlite focuser, Asus Tinkerboard running Armbian Ubuntu 16.04LTS with kstars ( github.com/Patrick-81/NAFABox )

INDI and kstars running on Asus Tinker Board 10 months 1 week ago #17982

  • patdut
  • patdut's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 285
  • Karma: 1
  • Thank you received: 33
Did you installed all with the sripts included in NAFABox config ?
And what about bluetooth. Did it worked just "out of the box" after installation ?
The following user(s) said Thank You: petarm

Please Log in or Create an account to join the conversation.

INDI and kstars running on Asus Tinker Board 10 months 1 week ago #17983

Thanks for the feedback Petarm, we do need it to improve and cover various issues that may arise.

Could you confirm as Patrick mentioned that the Nafa image worked fine? Or how you managed to get keyboard / bluetooth resolved?

Please Log in or Create an account to join the conversation.

INDI and kstars running on Asus Tinker Board 10 months 1 week ago #17990

  • kecsap
  • kecsap's Avatar
  • Away
  • Expert Boarder
  • Expert Boarder
  • Posts: 82
  • Karma: 4
  • Thank you received: 34
Is the ethernet port on the USB bus?

What does lsusb command say?

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • 2
Time to create page: 0.737 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica