Welcome, Guest
Username: Password: Remember me
20 Aug 2017
INDI development team is happy to announce the release of INDI Library v1.5.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...
  • Page:
  • 1
  • 2

TOPIC: Help resolving Load & Slew for subs...

Help resolving Load & Slew for subs... 1 week 8 hours ago #19375

  • maudy
  • maudy's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 283
  • Karma: 2
  • Thank you received: 23
The goal was to use a sub from a previous night to continue a session. The track command is checked in the scheduler (image attached). The Position Options check to use Position is set (image attached).

Using a sub, one is attached, it will not solve with the Load & Slew. It times out in 180s on the RPI3. I was using the Telescope simulator to test a dry run; perhaps this is the cause as the FOV is not updated 280/2800 and cameras in the Load & Slew. At least the values do not match in the solver page or its options for the ASI1600mm-c and a C11.

To test why the the image is not solving, options were added on the options page: -u aw -3 303.188 -4 38.4103 -5 5 (typically the option are per the image attached, this was only done to test.) This caused the Load & Slew to fail, the output is attached in the txt file.

Using the exact command from the file on the command line of the RPI3 the image does solve per below.

Looking at the fits header in the sub from previous night, there are no coordinates or rotation in the header. There is also the report of errors in the fits header in the text file:
2017-09-13T16:52:18 FITS header: Cannot find FOCALLEN.
2017-09-13T16:52:18 FITS header: Cannot find OBJCTRA.

I am assuming I have some setting wrong when taking the original subs, and since the RA/DEC are not there the Load & Slew is attempting to blindly solve even though the Use Position is set and the telescope is at the NGC6888 coordinates. The sensor length and pixel sizes are accurate in the header.

Please let me know if you have any ideas?

Thank you

*****
stellarmate@voyager1:/media/stellarmate/PENSIVE$ /usr/bin/solve-field -O --no-plots --resort --no-fits2fits --downsample 4 -d 21-30 -u aw -3 303.188 -4 38.4103 -5 5 --config /etc/astrometry.cfg -W /tmp/solution.wcs /home/stellarmate/Light_Ha_480_secs_2017-09-09T03-34-42_008.fits
Reading input file 1 of 1: "/home/stellarmate/Light_Ha_480_secs_2017-09-09T03-34-42_008.fits"...
Extracting sources...
Downsampling by 4...
simplexy: found 4131 sources.
Reading sort column "FLUX"
Sorting sort column
mmapping input file
Copying table header.
Writing row 0
Done
Solving...
Reading file "/home/stellarmate/Light_Ha_480_secs_2017-09-09T03-34-42_008.axy"...
Only searching for solutions within 5 degrees of RA,Dec (303.188,38.4103)
Field 1 did not solve (index index-4207-03.fits, field objects 21-30).
Field 1 did not solve (index index-4206-03.fits, field objects 21-30).
  log-odds ratio 32.9993 (2.14486e+14), 5 match, 0 conflict, 7 distractors, 27 index.
  RA,Dec = (303.025,38.3531), pixel scale 0.280842 arcsec/pix.
  Hit/miss:   Hit/miss: +-++-+-----+(best)------------------------------------+------------+--------------------------------------
Field 1: solved with index index-4205-03.fits.
Field 1 solved: writing to file /home/stellarmate/Light_Ha_480_secs_2017-09-09T03-34-42_008.solved to indicate this.
Field: /home/stellarmate/Light_Ha_480_secs_2017-09-09T03-34-42_008.fits
Field center: (RA,Dec) = (303.024577, 38.353154) deg.
Field center: (RA H:M:S, Dec D:M:S) = (20:12:05.898, +38:21:11.354).
Field size: 21.7859 x 16.4651 arcminutes
Field rotation angle: up is -62.1484 degrees E of N
Creating new FITS file "/home/stellarmate/Light_Ha_480_secs_2017-09-09T03-34-42_008.new"...

Please Log in or Create an account to join the conversation.

Last Edit: by maudy.

Help resolving Load & Slew for subs... 1 week 8 hours ago #19376

  • maudy
  • maudy's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 283
  • Karma: 2
  • Thank you received: 23
Found one correction I could make. Setting the telescope aperture and focal length using the indi driver, rather than the mount tab, updated the solver.

Please Log in or Create an account to join the conversation.

Help resolving Load & Slew for subs... 1 week 8 hours ago #19377

  • maudy
  • maudy's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 283
  • Karma: 2
  • Thank you received: 23
Found one correction I could make. Setting the telescope aperture and focal length using the indi driver, rather than the mount tab, updated the solver. The FOV is now correct.

Please Log in or Create an account to join the conversation.

Help resolving Load & Slew for subs... 1 week 8 hours ago #19379

  • xsnrg
  • xsnrg's Avatar
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 86
  • Karma: 1
  • Thank you received: 9
I noticed this as well. Even though you can update it in Ekos and it has a pretty save button, it does not seem to do anything. I have to change it in INDI and then it shows up correct in the solver tab. @knro is the Ekos telescope info and Save button used for something else?

Please Log in or Create an account to join the conversation.

Help resolving Load & Slew for subs... 1 week 8 hours ago #19380

  • maudy
  • maudy's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 283
  • Karma: 2
  • Thank you received: 23
Sorry for the double posts - traveling and slow connection. However, I am connecting to my gear, minus mount as no observatory, that is 5 time zones away though :) Attempting to prepare a session using the Telescope Simulator for a session when I return.

Anyhoooo... I also tired the --no-verify on and off. Still times out.

If anyone thinks of anything please let me know.

Please Log in or Create an account to join the conversation.

Help resolving Load & Slew for subs... 1 week 2 hours ago #19384

  • gerryr
  • gerryr's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 197
  • Karma: 3
  • Thank you received: 48
Set your simulators to have the same focal length as the real one, then set the sim camera to have the same number and size of pixels as your real one, then save that configuration so when you load your simulator profile, it emulates your real hardware.

Please Log in or Create an account to join the conversation.

Help resolving Load & Slew for subs... 6 days 23 hours ago #19385

  • maudy
  • maudy's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 283
  • Karma: 2
  • Thank you received: 23
Thank you. I should have been more specific. The cameras, EFW, and focuser are real and it is only the telescope that is simulated. The profile use all real drivers and equipment save the Telescope Simulator.

Aside, the CCD Simulator will not accommodate the sensor size needed to simulate the ASI1600.

Please Log in or Create an account to join the conversation.

Help resolving Load & Slew for subs... 6 days 21 hours ago #19388

The "save" button in Ekos mount was indeed not working due to a simple mistake that was fixed here . Hopefully I can make another release soon.
The following user(s) said Thank You: maudy

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Help resolving Load & Slew for subs... 6 days 7 hours ago #19426

  • maudy
  • maudy's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 283
  • Karma: 2
  • Thank you received: 23
Thank you. Setting in INDI for now does correct the FOV for load and slew. The image still will not solve by loading the fits file...

1. Does the Load & Slew try to load RA/Dec from the fits file? If so how to I tell Ekos to put them there so they are there next time?

2. The time out was changed to 480s and it stopped at 180s. This was done to see if the fits file would solve since it is doing it blindly

3. How to get the Load & Slew to Use (or not Use) the mount coordinates as a guess on where it is?

4. the load and slew will crash if there is more than one option set. Capture and Solve the following works: -d 11-20 -d 21-30. Only -d 11-20 can work. Adding any additional options and it fails.

Is there anything I can change to get the load and slew to work. I added the solve log above.

Please Log in or Create an account to join the conversation.

Last Edit: by maudy.

Help resolving Load & Slew for subs... 5 days 19 hours ago #19440

Good questions.

1. Load & Slew tries to load RA/DE/FocalLength from file, if not found it falls back to current values or blind solve.
2. Will check it out.
3. It falls back to mount coords when reading fails. or suppose to at least.

I'll check the logs and get back to you.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Help resolving Load & Slew for subs... 5 days 19 hours ago #19441

  • maudy
  • maudy's Avatar Topic Author
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 283
  • Karma: 2
  • Thank you received: 23
If there are specific logs needed I can capture tonight. I am wondering if it is Kstars or mount. The above log is the astrometry verbose.

Thank you.

Please Log in or Create an account to join the conversation.

Help resolving Load & Slew for subs... 5 days 19 hours ago #19442

I found some issues... working on it now and will get back to you soon.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
  • Page:
  • 1
  • 2
Time to create page: 0.438 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica