Welcome, Guest
Username: Password: Remember me
08 Apr 2018
INDI development team is happy to announce the release of INDI Library v1.7.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...
  • Page:
  • 1
  • 2

TOPIC: How to make USB GPS receiver work for me

How to make USB GPS receiver work for me 8 months 9 minutes ago #20352

  • xsnrg
  • xsnrg's Avatar
  • Offline
  • Gold Boarder
  • Gold Boarder
  • Posts: 215
  • Karma: 2
  • Thank you received: 38
How does the Stellarmate serial port mapper handle having two devices that have the same USB to serial controller such as the Prolific. In this situation, the IDs end up being the same. This is the case I still have some trouble with because gpsd wants to assign the device automatically itself with udev, and it ends up trying to map to my mount causing eqmod to go offline. It is actually gpsd that does not handle this well I think. It assumes that everything that matches a set of IDs is a gps and builds the device links for it and hangs on to the port.

Please Log in or Create an account to join the conversation.

How to make USB GPS receiver work for me 2 months 1 week ago #24938

Hi Kaczorek and Jasem, I have just updated kstars to the latest version as of yesterday (9 April 2018). I assume GPSD now automatically populates time and date as well as location.

No need to set DEVICES="/dev/YOUR_GPS_SERIAL_DEV" in /etc/default/gpsd file and restart gpsd service before using INDI GPSD device driver??

regards

Please Log in or Create an account to join the conversation.

Takahashi FC-100DF, Skywatcher HEQ5 Pro, Canon 1100D, Orion 50mm guide scope with ZWO ASI 120MC, homebuilt bluetooth moonlite focuser, Asus Tinkerboard running Armbian Ubuntu 16.04LTS with kstars ( github.com/Patrick-81/NAFABox )

How to make USB GPS receiver work for me 2 months 1 week ago #24941

xsnrg wrote: How does the Stellarmate serial port mapper handle having two devices that have the same USB to serial controller such as the Prolific. In this situation, the IDs end up being the same. This is the case I still have some trouble with because gpsd wants to assign the device automatically itself with udev, and it ends up trying to map to my mount causing eqmod to go offline. It is actually gpsd that does not handle this well I think. It assumes that everything that matches a set of IDs is a gps and builds the device links for it and hangs on to the port.


It uses serial ID as well.. if they're same, then you're out of luck. I suppose you can go further and map their physical locations on the USB ports but I didn't take it this far.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

How to make USB GPS receiver work for me 2 months 1 week ago #24950

Im still having issues connecting my ublock 7 USB GPS adapter.

I followed the install on the indi-GPS page. The device connects ok, when i run gpsmon in a terminal it produces the correct time, but when i run it in kstars with the Device Manager or in ekos, it doesnt populate the correct time. Coordinates are fine, just the UTC is incorrect. It is still using the time from when the tinkerboard was last updated using an Internet connection. See images below.

I have made sure that time and location are updated by GPS and mount on the INDI configuration page. See image.

Any suggestions???
Attachments:

Please Log in or Create an account to join the conversation.

Takahashi FC-100DF, Skywatcher HEQ5 Pro, Canon 1100D, Orion 50mm guide scope with ZWO ASI 120MC, homebuilt bluetooth moonlite focuser, Asus Tinkerboard running Armbian Ubuntu 16.04LTS with kstars ( github.com/Patrick-81/NAFABox )

How to make USB GPS receiver work for me 2 months 1 week ago #24951

petarm wrote: Hi Kaczorek and Jasem, I have just updated kstars to the latest version as of yesterday (9 April 2018). I assume GPSD now automatically populates time and date as well as location.

No need to set DEVICES="/dev/YOUR_GPS_SERIAL_DEV" in /etc/default/gpsd file and restart gpsd service before using INDI GPSD device driver??

regards


Sooooo..... If I have a GPS unit from Skywatcher that is compatible with my HEQ5 mount. I should be able to plug it into stellarmate and Kstars will automatically have the GPS time and location?

What about the need to have the local Kstars update devices rather than the other way around? I went through this before and it seems updates from the mount to stellarmate to Kstars is not working, so I question whether updates from GPS to stellamate to local Kstars is working too!

I believe local kstars to stellarmate to devices has become a very typical configuration so can you guys confirm that this is working with GPS at stellarmate?

Please Log in or Create an account to join the conversation.

Last Edit: by gbeaton.

How to make USB GPS receiver work for me 2 months 1 week ago #24975

petarm wrote: No need to set DEVICES="/dev/YOUR_GPS_SERIAL_DEV" in /etc/default/gpsd file and restart gpsd service before using INDI GPSD device driver??


GPSD driver uses gpsd service, which in turn reads gps data from your gps receiver. You need to have gpsd service properly configured to have GPSD driver working. This means that you have to set correct gps serial device in /etc/default/gpsd. Otherwise gpsd service will not work (no valid source of gps data). To keep it simple - if gpsmon or cgps don't give you fix and valid gps time/location, don't expect GPSD driver working.
The following user(s) said Thank You: knro, gbeaton, petarm

Please Log in or Create an account to join the conversation.

How to make USB GPS receiver work for me 2 months 1 week ago #24993

Hi Kaczorek, yep i did all that, gpsmon in a terminal tells me the gps adapter is connect and working and acquiring gps data. But when i then run gpsd in kstars/ekos, it was not populating UTC, it was using the time from the asus tinker board.

So what i did was found a python script that automatically runs on boot up that takes the UTC time from the gps adapter and updates the tinker board's time. Now kstars has the correct time. Not an ideal fix, but it works.

regards

Please Log in or Create an account to join the conversation.

Takahashi FC-100DF, Skywatcher HEQ5 Pro, Canon 1100D, Orion 50mm guide scope with ZWO ASI 120MC, homebuilt bluetooth moonlite focuser, Asus Tinkerboard running Armbian Ubuntu 16.04LTS with kstars ( github.com/Patrick-81/NAFABox )

How to make USB GPS receiver work for me 2 months 1 week ago #25006

petarm wrote: Hi Kaczorek, yep i did all that, gpsmon in a terminal tells me the gps adapter is connect and working and acquiring gps data. But when i then run gpsd in kstars/ekos, it was not populating UTC, it was using the time from the asus tinker board.


It's a feature not a bug ;-)
GPSD driver gets time from the system not from gps directly. The reason is noted in the comments in the source code:
// Update time regardless having gps fix.
// We are using system time assuming the system is synced with the gps
// by gpsd using chronyd or ntpd.

Please Log in or Create an account to join the conversation.

How to make USB GPS receiver work for me 2 months 1 week ago #25013

No worries. I understand now. Thanks for all your help.

Please Log in or Create an account to join the conversation.

Takahashi FC-100DF, Skywatcher HEQ5 Pro, Canon 1100D, Orion 50mm guide scope with ZWO ASI 120MC, homebuilt bluetooth moonlite focuser, Asus Tinkerboard running Armbian Ubuntu 16.04LTS with kstars ( github.com/Patrick-81/NAFABox )

How to make USB GPS receiver work for me 2 months 5 days ago #25156

I'm having some issues with this. It seems that I have to actually go outside in order to get a GPS fix so I can't test this properly. But I'm connecting to the GPS, and it says its trying to get a fix. So in the meantime it seems to be using the StellarMate time/loc (the year is 2016). So I tried to change my preferences in the local Kstars application (running on a Mac) and it wouldn't work. I tried to put back the manual location but it was ignored even though I changed the setting for local Kstars to update all devices etc. I restarted Kstars and that didnt work either. I had to disconnect from stellarmate and connect to the internet, then I started kstars and entered manual location and then it worked.

This whole time/location thing seems to be very convoluted. Maybe I'm not understanding or getting confused but what I read from Kaczorek and what I see in fact and on the video tutorial are not the same.

I have to say though that I was pleasantly surprised that I plugged in the GPS dongle (from skywatcher) and KStars/StellarMate recognized it and connected without any effort on my part. This is how things should be! :-) But in trying to use it, things didn't go so well. My mount connection hung up too even thought I followed the StellarMate tutorial video #4 to rename the ports - /dev/gps and /dev/mount. Anyway, I'm going to go out next time very early and try this again with a real GPS signal.

Please Log in or Create an account to join the conversation.

How to make USB GPS receiver work for me 2 months 5 days ago #25167

I would suggest you wait a bit. Today I reworked the options for the time & location settings. Instead of 2 options now there are 3:
1. Source is KStars
2. Source is Mount
3. Source is GPS

Before, it used to be "Source is Device", but what happens when both your mount and your GPS send different information? It would be a race condition and whoever sends later wins. Now it's more clear cut. Also, another small issue was that when Ekos detected a GPS device, it automatically sets the source to GPS since it assumed since you're connecting with GPS device, you'd probably want to use it. Now I changed the behavior so that it asks you first how you want to proceed. Anything, these changes should be for 2.9.5 due sooner than expected.
The following user(s) said Thank You: Kaczorek, ollie, gbeaton, xsnrg, tmheroes, starman345

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

How to make USB GPS receiver work for me 2 months 3 days ago #25238

knro wrote: I would suggest you wait a bit. Today I reworked the options for the time & location settings. Instead of 2 options now there are 3:
1. Source is KStars
2. Source is Mount
3. Source is GPS

Before, it used to be "Source is Device", but what happens when both your mount and your GPS send different information? It would be a race condition and whoever sends later wins. Now it's more clear cut. Also, another small issue was that when Ekos detected a GPS device, it automatically sets the source to GPS since it assumed since you're connecting with GPS device, you'd probably want to use it. Now I changed the behavior so that it asks you first how you want to proceed. Anything, these changes should be for 2.9.5 due sooner than expected.


Saw it and selected. Done! Thanks Jasem.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • 2
Time to create page: 0.388 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica