Welcome, Guest
Username: Password: Remember me
20 Aug 2017
INDI development team is happy to announce the release of INDI Library v1.5.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...
  • Page:
  • 1
  • 2

TOPIC: Still weird issue with GPS time

Still weird issue with GPS time 3 weeks 2 days ago #20556

knro wrote: So I spent a few hours on this and finally go it working reliably. You'll receive a link to an updated StellarMateOS image by the end of the day. Do not edit any files, just use the StellarMate Serial Port Assistant tool to add the GPS and then restart your StellarMate afterwards and you should be set.


What are we up to in version? I still have the 1.2 image and saw on the SM website that it's up to 1.2.3

Please Log in or Create an account to join the conversation.

Still weird issue with GPS time 3 weeks 2 days ago #20557

Kaczorek wrote:

knro wrote: Ok so I did a little bit more research and turns out using GPS for NTP is useless unless your GPS unit provides precise timing via PPS.

Why would you say this? The only difference is that without PPS you will not get precision higher than 1s, while with PPS your time precision is around 1us. All the rest would work just fine.

@SparkyHT I read your thread on CHRONY... well done!


Thanks. The version of NTP in MATE for RPI is just hosed, it refuses to run at all so I cannot use GPSD with it. Removing timesyncd didn't help either, so I started looking for other solutions and came across CHRONY. I purged all NTP files, installed CHRONY, and then modified my chrony.conf file to read the data stream coming off the USB GPS receiver. If it was a PPS capable receiver, I would've had better accuracy, but it appears to hold time just fine over the course of a night.

Please Log in or Create an account to join the conversation.

Still weird issue with GPS time 3 weeks 2 days ago #20578

  • Kaczorek
  • Kaczorek's Avatar
  • Away
  • Platinum Boarder
  • Platinum Boarder
  • Posts: 393
  • Karma: 4
  • Thank you received: 135
I have just checked how I fixed NTP issue on Astroberry Server... The solution is to run the following:
sudo systemctl stop prefer-timesyncd.service
sudo systemctl disable prefer-timesyncd.service

The above disables preference of timesyncd over NTP.

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • 2
Time to create page: 0.243 seconds

Login

3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica