Welcome, Guest
Username: Password: Remember me
25 Jul 2018
Glad to announce of release of INDI Library v1.7.4 on 2018-07-25. A few drivers were added in this release as we continue to improve & stabilize existing drivers.
Read More...
  • Page:
  • 1

TOPIC: SkySafari doesn't slew to the correct target

SkySafari doesn't slew to the correct target 8 months 4 days ago #22383

  • JCJ
  • JCJ's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 47
  • Karma: 1
  • Thank you received: 17
I use SkySafari 5 Pro as a planetarium for KStars/Ekos.
Everything works as expected as long as the targets are higher than the celestial equator.
When the targets are lower than the celestial equator, SkySafari doesn't slew to that target but consistently higher !
If these same targets have been selected in KStars, there is no problem : the scope slews to the right place iin KStars and in SkySafari.
My horizon altitude in SkySafari = 0°.
Using SkySafari on its own doesn't produce these effects.
Is this a bug of Ekos or SkySafari ? Or are my settings the origin of this problem ?

Screen Shot 1 : Neptune (below the celestial equator) has been set as target in SkySafari : the goto doesn't reach the target
Screen Shot 2 : Same with Sadalsuud (below the celestial equator) on the other side of the meridian
Screen Shot 3 : Sadalsuud has been set as target in KStars : the goto reaches the target
Attachments:

Please Log in or Create an account to join the conversation.

SkySafari doesn't slew to the correct target 8 months 4 days ago #22398

So it's just a matter of display on KStars side? does the mount end up at the target location but the crosshair location is incorrect?

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

SkySafari doesn't slew to the correct target 8 months 4 days ago #22399

So it's just a matter of display on KStars side? does the mount end up at the target location but the crosshair location is incorrect?

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

SkySafari doesn't slew to the correct target 8 months 4 days ago #22403

  • JCJ
  • JCJ's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 47
  • Karma: 1
  • Thank you received: 17
Hi Jasem,
The mount does not reach the target on the sky chart.
I cannot check if the target is reached in the scope because of the cloudy conditions here.
Here is another set of screenshots.
- Screenshot 1 + 2 + 3 : After the scope has finished to move, Vindemiatrix (above the celestial equator) is reached as proven by Screenshot 1 + Screenshot 2 in SkySafari, as well as by Screenshot 3 in KStars.
- Screenshot 4 + 5 : After the scope has finished to move, Porrima (under the celestial equator) is not reached as proven by Screenshot 4 in SkySafari (the scope cannot get under the celestial equator). Screenshot 5 indicates "Stop" instead of "GoTo" meaning that SkySafari knows that the move is not complete. Porrima is not reached also in KStars.
This bug has nothing to do with the Horizon Altitude of SkySafari = 0°. This is clearly related to the position of targets above or under the celestial equator.

Please Log in or Create an account to join the conversation.

SkySafari doesn't slew to the correct target 7 months 2 weeks ago #22829

  • JCJ
  • JCJ's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 47
  • Karma: 1
  • Thank you received: 17
The mount doesn't end up at the correct location and here is an experiment one can do easily because this bug happens also with the Simulators.

Connect the Telescope Simulator + CCD Simulator + SkySafari.

1/ As long as your targets are located above the celestial equator, everything's fine in KStars and SkySafari.
You can choose any target in KStars, slew to it and SkySafari follows.
You can choose any target in SkySafari, slew to it and KStars follows.

2/ Now choose a target below the celestial equator : say M11 , a globular cluster
With KStars, select M11, slew to it and take a Preview with the CCD Simulator. No problem. And you can check that SkySafari is also right on M11.
Now, in the Scope Control panel of SkySafari, click on Go To : normally the scope should not move because the target has not changed .
But the scope moves around half a degree in the direction of the celestial equator.
The crosshair has moved accordingly in KStars. You can confirm by taking a Preview that you are not anymore on M11.

I hope this helps.

Please Log in or Create an account to join the conversation.

SkySafari doesn't slew to the correct target 7 months 2 weeks ago #22831

  • wbirk
  • wbirk's Avatar
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 82
  • Karma: 3
  • Thank you received: 17
hi!
i don't know whether that is the problem, but i ran into something like that when programming my own controller (which also interacts with sky safari). sky safari sends strings as coordinates, like
-00:17:56# for mintakas declination
this is a string, a series of characters. on the program side, you have to convert this to a number for hour, minute and second. converting the first characters "-00" to a number results in the number 0 ... there is no negative zero, so this does make sense. and voila - the coordinates are wrong, it is now 0°17'56''. as this happens only below the celestial equator in your case, something like that might be your problem. however, porrima has a declination of -1° something, so it might not be exactly that problem, but it may be related...
just my guess...
yours
wolfi

Please Log in or Create an account to join the conversation.

SkySafari doesn't slew to the correct target 7 months 2 weeks ago #22834

  • JCJ
  • JCJ's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 47
  • Karma: 1
  • Thank you received: 17
Hi Wolfi,
Your explanation might be part of the answer.
But it would not explain why the bug applies for targets which are just above my horizon (I'm living in France at 45°N) with a DEC around -43°

Please Log in or Create an account to join the conversation.

SkySafari doesn't slew to the correct target 7 months 2 weeks ago #22845

  • wbirk
  • wbirk's Avatar
  • Offline
  • Expert Boarder
  • Expert Boarder
  • Posts: 82
  • Karma: 3
  • Thank you received: 17
hi!
yes, I know, but something like that COULD be a reason ... where does the telescope actually go to (in declination) when you enter a negative declination???
yours
wolfi

Please Log in or Create an account to join the conversation.

SkySafari doesn't slew to the correct target 7 months 2 weeks ago #22846

  • JCJ
  • JCJ's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 47
  • Karma: 1
  • Thank you received: 17
You can try this yourself using the Telescope Simulator : the scope goes always North of the target at a distance between 0.5-2 ° .
The Horizon Altitude in SkySafari has no effect on the bug.

Please Log in or Create an account to join the conversation.

SkySafari doesn't slew to the correct target 7 months 2 weeks ago #22854

I found the issue and it should be fixed if the PPA is built. You can try it from GIT too.
The following user(s) said Thank You: JCJ

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
  • Page:
  • 1
Time to create page: 3.003 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica