Welcome, Guest
Username: Password: Remember me
25 Jul 2018
Glad to announce of release of INDI Library v1.7.4 on 2018-07-25. A few drivers were added in this release as we continue to improve & stabilize existing drivers.
Read More...
  • Page:
  • 1

TOPIC: SOLVED: Flip Flat Problem

SOLVED: Flip Flat Problem 3 months 3 weeks ago #26319

  • mworion
  • mworion's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 44
  • Thank you received: 16
Hi,

I tried to move my equipment to INDI. It worked so far. Bit I run into some problems using an Alnitak Flip Flat.
I have it in config. I could open and close the cap. I get the status.

But when I would like to switch the light on (which could be only done correctly when closed), the it does not light (it's OK, I counterchecked) and I get this error message:

2018-05-31T18:24:58: [ERROR] >S000 error: Write Error: Input/output error.

Anybody could help ?

Thanks in advance,

Michel

Please Log in or Create an account to join the conversation.

Last Edit: by mworion. Reason: Solved

Flip Flat Problem 3 months 3 weeks ago #26321

Is this repeatable? I have it here and light controls just work OK. Are there other drivers using serial port? Sometimes on startup you have multiple devices trying to open and communicate with the same port.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Flip Flat Problem 3 months 3 weeks ago #26322

  • mworion
  • mworion's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 44
  • Thank you received: 16
Yes it is.
The setup is ubuntu mate 16.04. on a raspi3. I have a QSI (USB) and a mount (ethernet) connected. I had a stick station with MBOX driver, but remove this to countercheck, no difference.
I tried to enable logging on flip flat, but it's Re-disabling debug logging immediately.
I have a micro touch focuser as well (wich might also have a USB to serial converter). This works well.
I removed it and tried again. I had a short flashlight on flip flat panel, but there again this message.
At least this points in the direction you mentioned.
What could I do about it ?

Michel

Please Log in or Create an account to join the conversation.

Last Edit: by mworion.

Flip Flat Problem 3 months 3 weeks ago #26326

I assume you're using Ekos? If yes, then the logs should be enabled from the summary screen, there is a button called "Logs" there to enable/disable logs for various device classes.

You could try using cutecom or something similar to send the serial commands directly and see if that works.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Flip Flat Problem 3 months 3 weeks ago #26334

  • mworion
  • mworion's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 44
  • Thank you received: 16
Hi,

I got some log now. I had not EKOS running but only the server itself. I used the web manager. So I started using EKOS to get the logs. I attached them, but I cannot really "read" them to get some insights:
[2018-06-01T14:49:49.830 CEST DEBG ][           org.kde.kstars.indi] - < CCD Simulator >: < CCD2 >
[2018-06-01T14:49:49.843 CEST DEBG ][           org.kde.kstars.indi] - < CCD Simulator >: < TELESCOPE_TIMED_GUIDE_NS >
[2018-06-01T14:49:49.887 CEST DEBG ][           org.kde.kstars.indi] - Microtouch : "[DEBUG] Connecting to /dev/ttyUSB5 "
[2018-06-01T14:49:49.905 CEST DEBG ][           org.kde.kstars.indi] - Microtouch : "[DEBUG] Trying connection to /dev/ttyUSB0 @ 19200 ... "
[2018-06-01T14:49:49.905 CEST DEBG ][           org.kde.kstars.indi] - Microtouch : "[DEBUG] Connecting to /dev/ttyUSB0 "
[2018-06-01T14:49:49.906 CEST DEBG ][           org.kde.kstars.indi] - Microtouch : "[DEBUG] Port FD 3 "
[2018-06-01T14:49:49.908 CEST DEBG ][           org.kde.kstars.indi] - Microtouch : "[DEBUG] Connection successful, attempting handshake... "
[2018-06-01T14:49:49.909 CEST DEBG ][           org.kde.kstars.indi] - Microtouch : "[DEBUG] WriteCmd : 8d  "
[2018-06-01T14:49:49.909 CEST DEBG ][           org.kde.kstars.indi] - Flip Flat : "[DEBUG] Connecting to /dev/ttyUSB5 "
[2018-06-01T14:49:49.944 CEST DEBG ][           org.kde.kstars.indi] - Flip Flat : "[DEBUG] Trying connection to /dev/ttyUSB0 @ 9600 ... "
[2018-06-01T14:49:49.946 CEST DEBG ][           org.kde.kstars.indi] - Flip Flat : "[DEBUG] Connecting to /dev/ttyUSB0 "
[2018-06-01T14:49:49.946 CEST DEBG ][           org.kde.kstars.indi] - Flip Flat : "[DEBUG] Port FD 3 "
[2018-06-01T14:49:49.948 CEST DEBG ][           org.kde.kstars.indi] - Flip Flat : "[DEBUG] Connection successful, attempting handshake... "
[2018-06-01T14:49:49.949 CEST DEBG ][           org.kde.kstars.indi] - Flip Flat : "[DEBUG] CMD (>P000) "
[2018-06-01T14:49:49.949 CEST DEBG ][           org.kde.kstars.indi] - < CCD Simulator >: < TELESCOPE_TIMED_GUIDE_WE >
[2018-06-01T14:49:50.150 CEST DEBG ][           org.kde.kstars.indi] - < CCD Simulator >: < CCD_FRAME_TYPE >
[2018-06-01T14:49:50.156 CEST DEBG ][           org.kde.kstars.indi] - < CCD Simulator >: < CCD_FRAME_RESET >
[2018-06-01T14:49:50.161 CEST DEBG ][           org.kde.kstars.indi] - < CCD Simulator >: < GUIDER_FRAME_TYPE >
[2018-06-01T14:49:50.166 CEST DEBG ][           org.kde.kstars.indi] - < CCD Simulator >: < CCD_RAPID_GUIDE >
[2018-06-01T14:49:50.170 CEST DEBG ][           org.kde.kstars.indi] - < CCD Simulator >: < GUIDER_RAPID_GUIDE >
[2018-06-01T14:49:50.175 CEST DEBG ][           org.kde.kstars.indi] - < CCD Simulator >: < TELESCOPE_TYPE >
[2018-06-01T14:49:50.179 CEST DEBG ][           org.kde.kstars.indi] - < CCD Simulator >: < WCS_CONTROL >
[2018-06-01T14:49:50.190 CEST DEBG ][           org.kde.kstars.indi] - < CCD Simulator >: < UPLOAD_MODE >
[2018-06-01T14:49:50.194 CEST DEBG ][           org.kde.kstars.indi] - < CCD Simulator >: < UPLOAD_SETTINGS >
[2018-06-01T14:49:50.206 CEST DEBG ][           org.kde.kstars.indi] - < CCD Simulator >: < CCD_EXPOSURE_LOOP >
[2018-06-01T14:49:50.211 CEST DEBG ][           org.kde.kstars.indi] - < CCD Simulator >: < CCD_EXPOSURE_LOOP_COUNT >
[2018-06-01T14:49:50.803 CEST DEBG ][           org.kde.kstars.indi] - < CCD Simulator >: < CCD_VIDEO_STREAM >
[2018-06-01T14:49:51.231 CEST DEBG ][           org.kde.kstars.indi] - < CCD Simulator >: < STREAMING_EXPOSURE >
[2018-06-01T14:49:51.249 CEST DEBG ][           org.kde.kstars.indi] - < CCD Simulator >: < FPS >
[2018-06-01T14:49:51.268 CEST DEBG ][           org.kde.kstars.indi] - < CCD Simulator >: < RECORD_STREAM >
[2018-06-01T14:49:51.278 CEST DEBG ][           org.kde.kstars.indi] - < CCD Simulator >: < RECORD_FILE >
[2018-06-01T14:49:51.299 CEST DEBG ][           org.kde.kstars.indi] - < CCD Simulator >: < RECORD_OPTIONS >
[2018-06-01T14:49:51.325 CEST DEBG ][           org.kde.kstars.indi] - < CCD Simulator >: < CCD_STREAM_FRAME >
[2018-06-01T14:49:51.349 CEST DEBG ][           org.kde.kstars.indi] - < CCD Simulator >: < CCD_STREAM_ENCODER >
[2018-06-01T14:49:51.354 CEST DEBG ][           org.kde.kstars.indi] - < CCD Simulator >: < CCD_STREAM_RECORDER >
[2018-06-01T14:49:51.358 CEST DEBG ][           org.kde.kstars.indi] - < CCD Simulator >: < CCD_COOLER >
[2018-06-01T14:49:51.373 CEST DEBG ][           org.kde.kstars.indi] - CCD Simulator : "[DEBUG] Pixel format 0 is supported by SER recorder. "
[2018-06-01T14:49:51.373 CEST DEBG ][           org.kde.kstars.indi] - CCD Simulator : "[DEBUG] Pixel format 0 is supported by RAW encoder. "
[2018-06-01T14:49:51.378 CEST DEBG ][           org.kde.kstars.indi] - < CCD Simulator >: < FILTER_SLOT >
[2018-06-01T14:49:51.387 CEST WARN ][                       default] - QObject::disconnect: Unexpected null parameter
[2018-06-01T14:49:51.629 CEST DEBG ][           org.kde.kstars.indi] - < CCD Simulator >: < FILTER_NAME >
[2018-06-01T14:49:51.716 CEST DEBG ][           org.kde.kstars.indi] - CCD Simulator : "[DEBUG] Toggle Debug Level -- Driver Debug "
[2018-06-01T14:49:51.717 CEST DEBG ][           org.kde.kstars.indi] - CCD Simulator : "[DEBUG] Toggle Logging Level -- Messages "
[2018-06-01T14:49:51.734 CEST DEBG ][           org.kde.kstars.indi] - CCD Simulator : "[DEBUG] Requested CCD Frame is (0,0) (0 x 0) "
[2018-06-01T14:49:51.739 CEST DEBG ][           org.kde.kstars.indi] - CCD Simulator : "Error: Invalid range for Width (WIDTH). Valid range is from 1 to 1280. Requested value is 0 "
[2018-06-01T14:49:51.780 CEST DEBG ][           org.kde.kstars.indi] - CCD Simulator : "[DEBUG] Pixel format 0 is supported by SER recorder. "
[2018-06-01T14:49:51.781 CEST DEBG ][           org.kde.kstars.indi] - CCD Simulator : "[DEBUG] Pixel format 0 is supported by RAW encoder. "
[2018-06-01T14:49:51.788 CEST DEBG ][           org.kde.kstars.indi] - CCD Simulator : "[DEBUG] Configuration successfully loaded. "
[2018-06-01T14:49:51.790 CEST DEBG ][           org.kde.kstars.ekos] - LX200 10micron  is disconnected.
[2018-06-01T14:49:51.814 CEST DEBG ][           org.kde.kstars.indi] - Microtouch : "[DEBUG] Handshake failed. "
[2018-06-01T14:49:51.815 CEST DEBG ][           org.kde.kstars.indi] - Microtouch : "[DEBUG] Trying connection to /dev/ttyUSB1 @ 19200 ... "
[2018-06-01T14:49:51.815 CEST DEBG ][           org.kde.kstars.indi] - Microtouch : "[DEBUG] Connecting to /dev/ttyUSB1 "
[2018-06-01T14:49:51.816 CEST DEBG ][           org.kde.kstars.indi] - Microtouch : "[DEBUG] Port FD 4 "
[2018-06-01T14:49:51.817 CEST DEBG ][           org.kde.kstars.indi] - Microtouch : "[DEBUG] Connection successful, attempting handshake... "
[2018-06-01T14:49:51.818 CEST DEBG ][           org.kde.kstars.indi] - Microtouch : "[DEBUG] WriteCmd : 8d  "
[2018-06-01T14:49:51.842 CEST DEBG ][           org.kde.kstars.indi] - Flip Flat : "[DEBUG] Handshake failed. "
[2018-06-01T14:49:51.843 CEST DEBG ][           org.kde.kstars.indi] - Flip Flat : "[DEBUG] Trying connection to /dev/ttyUSB1 @ 9600 ... "
[2018-06-01T14:49:51.843 CEST DEBG ][           org.kde.kstars.indi] - Flip Flat : "[DEBUG] Connecting to /dev/ttyUSB1 "
[2018-06-01T14:49:51.843 CEST DEBG ][           org.kde.kstars.indi] - Flip Flat : "[DEBUG] Port FD 4 "
[2018-06-01T14:49:51.844 CEST DEBG ][           org.kde.kstars.indi] - Flip Flat : "[DEBUG] Connection successful, attempting handshake... "
[2018-06-01T14:49:51.845 CEST DEBG ][           org.kde.kstars.indi] - Flip Flat : "[DEBUG] CMD (>P000) "
[2018-06-01T14:49:52.004 CEST DEBG ][           org.kde.kstars.indi] - Microtouch : "[DEBUG] Configuration successfully saved for DEVICE_PORT. "
[2018-06-01T14:49:52.005 CEST DEBG ][           org.kde.kstars.indi] - Flip Flat : "[DEBUG] RES (9000) "
[2018-06-01T14:49:52.015 CEST DEBG ][           org.kde.kstars.indi] - Microtouch : "[DEBUG] Configuration successfully saved for DEVICE_BAUD_RATE. "
[2018-06-01T14:49:52.017 CEST DEBG ][           org.kde.kstars.indi] - Microtouch : "[DEBUG] Configuration successfully saved for CONNECTION_MODE. "
[2018-06-01T14:49:52.018 CEST DEBG ][           org.kde.kstars.ekos] - 2  devices connected out of  4
[2018-06-01T14:49:52.607 CEST DEBG ][           org.kde.kstars.indi] - < Microtouch >: < FOCUS_MOTION >
[2018-06-01T14:49:53.455 CEST DEBG ][           org.kde.kstars.indi] - < Microtouch >: < REL_FOCUS_POSITION >
[2018-06-01T14:49:53.467 CEST DEBG ][           org.kde.kstars.indi] - < Microtouch >: < ABS_FOCUS_POSITION >
[2018-06-01T14:49:53.479 CEST DEBG ][           org.kde.kstars.indi] - < Microtouch >: < FOCUS_ABORT_MOTION >
[2018-06-01T14:49:53.486 CEST DEBG ][           org.kde.kstars.indi] - < Microtouch >: < Presets >
[2018-06-01T14:49:53.508 CEST DEBG ][           org.kde.kstars.indi] - < Microtouch >: < Goto >
[2018-06-01T14:49:53.513 CEST DEBG ][           org.kde.kstars.indi] - < Microtouch >: < USEJOYSTICK >
[2018-06-01T14:49:53.521 CEST DEBG ][           org.kde.kstars.indi] - < Microtouch >: < FOCUS_TEMPERATURE >
[2018-06-01T14:49:53.528 CEST DEBG ][           org.kde.kstars.indi] - < Microtouch >: < FOCUS_MAXTRAVEL >
[2018-06-01T14:49:53.545 CEST DEBG ][           org.kde.kstars.indi] - < Microtouch >: < Motor Speed >
[2018-06-01T14:49:53.551 CEST DEBG ][           org.kde.kstars.indi] - < Microtouch >: < Temperature Settings >
[2018-06-01T14:49:53.563 CEST DEBG ][           org.kde.kstars.indi] - < Microtouch >: < Temperature Compensate >
[2018-06-01T14:49:53.571 CEST DEBG ][           org.kde.kstars.indi] - < Microtouch >: < Reset >
[2018-06-01T14:49:53.576 CEST DEBG ][           org.kde.kstars.indi] - < Microtouch >: < Reset to Position >
[2018-06-01T14:49:53.587 CEST DEBG ][           org.kde.kstars.indi] - Microtouch : "[DEBUG] WriteCmd : 8d  "
[2018-06-01T14:49:53.588 CEST DEBG ][           org.kde.kstars.indi] - Flip Flat : "[DEBUG] Configuration successfully saved for DEVICE_PORT. "
[2018-06-01T14:49:53.589 CEST DEBG ][           org.kde.kstars.indi] - Flip Flat : "[DEBUG] Configuration successfully saved for DEVICE_BAUD_RATE. "
[2018-06-01T14:49:53.589 CEST DEBG ][           org.kde.kstars.indi] - Flip Flat : "[DEBUG] Configuration successfully saved for CONNECTION_MODE. "
[2018-06-01T14:49:53.589 CEST DEBG ][           org.kde.kstars.ekos] - 3  devices connected out of  4
[2018-06-01T14:49:54.037 CEST DEBG ][           org.kde.kstars.indi] - < Flip Flat >: < FLAT_LIGHT_CONTROL >
[2018-06-01T14:49:54.162 CEST DEBG ][           org.kde.kstars.indi] - < Flip Flat >: < FLAT_LIGHT_INTENSITY >
[2018-06-01T14:49:54.226 CEST DEBG ][           org.kde.kstars.indi] - < Flip Flat >: < Status >
[2018-06-01T14:49:54.327 CEST DEBG ][           org.kde.kstars.indi] - < Flip Flat >: < Firmware >
[2018-06-01T14:49:54.425 CEST DEBG ][           org.kde.kstars.indi] - Flip Flat : "[DEBUG] CMD (>V000) "
[2018-06-01T14:49:54.426 CEST DEBG ][           org.kde.kstars.indi] - Microtouch : "[DEBUG] WriteCmd : 84  "
[2018-06-01T14:49:55.218 CEST DEBG ][           org.kde.kstars.indi] - Microtouch : "[DEBUG] WriteCmd : 9e  "
[2018-06-01T14:49:57.693 CEST DEBG ][           org.kde.kstars.indi] - Microtouch : "[DEBUG] MotorSpeed: 255. "
[2018-06-01T14:49:57.694 CEST DEBG ][           org.kde.kstars.indi] - Microtouch : "[DEBUG] WriteCmd : 9e  "
[2018-06-01T14:50:00.857 CEST DEBG ][           org.kde.kstars.indi] - Microtouch : "[DEBUG] WriteCmd : 9e  "
[2018-06-01T14:50:03.701 CEST DEBG ][           org.kde.kstars.indi] - Microtouch : "[DEBUG] WriteCmd : 9e  "
[2018-06-01T14:50:06.725 CEST DEBG ][           org.kde.kstars.indi] - INDI Server:  "Child process 6658 died"
[2018-06-01T14:50:06.727 CEST DEBG ][           org.kde.kstars.indi] - INDI Server:  "2018-06-01T12:50:06: Driver indi_microtouch_focus: stderr EOF"
[2018-06-01T14:50:06.727 CEST DEBG ][           org.kde.kstars.indi] - INDI Server:  "2018-06-01T12:50:06: Driver indi_microtouch_focus: restart #1"
[2018-06-01T14:50:06.728 CEST DEBG ][           org.kde.kstars.indi] - INDI Server:  "2018-06-01T12:50:06: Driver indi_microtouch_focus: pid=6664 rfd=6 wfd=20 efd=21"
[2018-06-01T14:50:06.728 CEST DEBG ][           org.kde.kstars.indi] - INDI Server:  ""
[2018-06-01T14:50:06.729 CEST CRIT ][           org.kde.kstars.indi] - INDI driver  "indi_microtouch_focus"  crashed!
[2018-06-01T14:50:07.192 CEST DEBG ][           org.kde.kstars.indi] - < Microtouch >: < SYSTEM_PORTS >
[2018-06-01T14:51:06.832 CEST DEBG ][           org.kde.kstars.ekos] - Disconnecting  Flip Flat
[2018-06-01T14:51:06.835 CEST DEBG ][           org.kde.kstars.ekos] - Disconnecting  Microtouch
[2018-06-01T14:51:06.838 CEST DEBG ][           org.kde.kstars.ekos] - Disconnecting  CCD Simulator
[2018-06-01T14:51:06.840 CEST DEBG ][           org.kde.kstars.ekos] - Disconnecting  LX200 10micron
[2018-06-01T14:51:06.858 CEST DEBG ][           org.kde.kstars.ekos] - Microtouch  is disconnected.

If anybody can give some hint, it would be very helpful.

Michel

Edit: Some more task done:
defined some dev rules to split all devices an defining the right /dev/ttyUSBx. And made some logs.
Still errors only when switching the light:

Setup in EKOS screen:


Output log:
INFO	322.334124 sec	: Session log file /home/mw/.indi/logs/2018-06-01/indi_flipflat/indi_flipflat_19:35:37.log
ERROR	347.698349 sec	: >S000
 error: Write Error: Input/output error.
ERROR	348.699840 sec	: >S000
 error: Write Error: Input/output error.
ERROR	349.701297 sec	: >S000
 error: Write Error: Input/output error.
ERROR	350.702744 sec	: >S000
 error: Write Error: Input/output error.
ERROR	351.704695 sec	: >S000
 error: Write Error: Input/output error.
ERROR	352.706576 sec	: >S000
 error: Write Error: Input/output error.
ERROR	352.954270 sec	: >D000
 error: Write Error: Input/output error.
ERROR	353.707861 sec	: >S000
 error: Write Error: Input/output error.
ERROR	354.423220 sec	: >D000
 error: Write Error: Input/output error.
ERROR	354.708672 sec	: >S000
 error: Write Error: Input/output error.
ERROR	355.709990 sec	: >S000
 error: Write Error: Input/output error.
INFO	356.223494 sec	: Flip Flat is offline.
Attachments:

Please Log in or Create an account to join the conversation.

Last Edit: by mworion.

Flip Flat Problem 3 months 3 weeks ago #26352

Looks like both Microtouch and Flipflat are performing "Auto Search" which could interfer with each other. Disable auto search for all drivers, save configuration, and try again.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Flip Flat Problem 3 months 3 weeks ago #26368

  • mworion
  • mworion's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 44
  • Thank you received: 16
Hi Jasem,

finally I made it. It was not a SW issue. I had problems with power supply on USB when switching light on. If I correct this, it's running.
Thanks for your help !

Michel

PS: How can I use the same parameters I set with EKOS to use the INDI server headless (based on indiweb) ?

Please Log in or Create an account to join the conversation.

Flip Flat Problem 3 months 3 weeks ago #26370

Glad you have it sorted out. What parameters exactly?

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Flip Flat Problem 3 months 3 weeks ago #26372

  • mworion
  • mworion's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 44
  • Thank you received: 16
All I did with setting the right /dev/ttyUSB link, auto search off, etc. The things I configured in EKOS.....

Michel

Please Log in or Create an account to join the conversation.

Flip Flat Problem 3 months 3 weeks ago #26375

Those are stored in INDI configuration file, not related to Ekos.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Flip Flat Problem 3 months 3 weeks ago #26384

  • mworion
  • mworion's Avatar Topic Author
  • Offline
  • Senior Boarder
  • Senior Boarder
  • Posts: 44
  • Thank you received: 16
Ok, understood. I give it a try.

Michel

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.124 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica