Welcome, Guest
Username: Password: Remember me
20 Aug 2017
INDI development team is happy to announce the release of INDI Library v1.5.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers.
Read More...
  • Page:
  • 1
  • 2

TOPIC: Problem with EQMod

Problem with EQMod 2 months 4 weeks ago #17382

Hi,

Since yesterday, EQMod no longer works. Yesterday afternoon, everything was okay, and after the evening update, impossible to connect the mount.
Tests performed with two differents USB cables and two differents mounts (EQG-Sirius and EQ6-R). Same issue, same log (user added to dialout). (Ok EQMod on Windows 7 - Carte du Ciel)

Here is the log :
2017-06-22T12:48:49: Error:  -> tty read failed, check connection: Timeout error 
2017-06-22T12:48:34: Communication with /dev/ttyUSB0 @ 9600 failed. Starting Auto Search... 
2017-06-22T12:48:34: Error:  -> tty read failed, check connection: Timeout error
2017-06-22T13:36:27: Handshake failed. 
2017-06-22T13:36:27: Error:  -> tty read failed, check connection: Timeout error 

2017-06-22T13:36:12: Communication with /dev/ttyUSB0 @ 9600 failed. Starting Auto Search... 
2017-06-22T13:36:12: Handshake failed. 
2017-06-22T13:36:12: Error:  -> tty read failed, check connection: Timeout error 
2017-06-22T13:35:56: Connection successful, attempting handshake... 
2017-06-22T13:35:56: Port FD 15 
2017-06-22T13:35:56: Connecting to /dev/ttyUSB0

Thanks for your help,
Olivier

Please Log in or Create an account to join the conversation.

Last Edit: by Olivier-40.

Problem with EQMod 2 months 4 weeks ago #17394

It _might_ be an issue with the PPA build, please wait until later today for an update.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?

Problem with EQMod 2 months 4 weeks ago #17395

Ok,


To test my Raspberry (I was thinking about a USB problem), I did a restore with a March backup without performing update, and all is ok.

Thanks knro

Please Log in or Create an account to join the conversation.

Problem with EQMod 2 months 3 weeks ago #17407

Hi,

After update, there is the same problem :
2017-06-24T11:12:40: Handshake failed. 
2017-06-24T11:12:40: Error:  -> tty read failed, check connection: Timeout error 
2017-06-24T11:12:25: dispatch_command: ":", 2 bytes written 
2017-06-24T11:12:25: Connection successful, attempting handshake... 
2017-06-24T11:12:25: Port FD 16 
2017-06-24T11:12:25: Connecting to /dev/ttyUSB0 
2017-06-24T11:12:25: Trying connection to /dev/ttyUSB0 @ 9600 ... 
2017-06-24T11:12:25: Communication with /dev/ttyUSB0 @ 9600 failed. Starting Auto Search... 
2017-06-24T11:12:25: Handshake failed. 
2017-06-24T11:12:25: Error:  -> tty read failed, check connection: Timeout error 
2017-06-24T11:12:10: dispatch_command: ":", 2 bytes written 
2017-06-24T11:12:10: Connection successful, attempting handshake... 
2017-06-24T11:12:10: Port FD 15 
2017-06-24T11:12:10: Connecting to /dev/ttyUSB0 
2017-06-24T11:12:10: ProcessSwitchProperties - name(CONNECTION) 
2017-06-24T11:12:10: ProcessSwitchProperties - name(CONNECTION)

EDIT 2017-06-24 22:55 : Unresolved issue with tonight's update.

Please Log in or Create an account to join the conversation.

Last Edit: by Olivier-40.

Problem with EQMod 2 months 3 weeks ago #17425

Hi,

Today, I tested an update of the functional backup of the month of March, and the result makes that I fall back on the same problem.

Olivier

EDIT : During the last update, this error message was displayed
Paramétrage de fliusb-dkms (1.3+r3140~201706251912~ubuntu16.04.1) ...
Loading new fliusb-1.3+r3140~201706251912~ubuntu16.04.1 DKMS files...
dpkg : avertissement : mauvaise syntaxe de la version « *-* »: le numéro de version ne commence pas par un chiffre
It is likely that 4.4.38-v7+ belongs to a chroot's host
Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.

Please Log in or Create an account to join the conversation.

Last Edit: by Olivier-40.

Problem with EQMod 2 months 3 weeks ago #17430

Hi All,

Did an update yesterday and now is the same issue for me :
2017-06-25T22:50:36.800 - DEBG - EQMod Mount :  "Toggle Debug Level -- Serial Port "
2017-06-25T22:50:36.844 - DEBG - EQMod Mount :  "Toggle Debug Level -- Serial Port "
2017-06-25T22:50:41.674 - DEBG - EQMod Mount :  "ProcessSwitchProperties - name(CONNECTION) "
2017-06-25T22:50:41.716 - DEBG - EQMod Mount :  "ProcessSwitchProperties - name(CONNECTION) "
2017-06-25T22:50:41.722 - DEBG - EQMod Mount :  "Connecting to /dev/ttyUSB1 "
2017-06-25T22:50:41.725 - DEBG - EQMod Mount :  "Port FD 20 "
2017-06-25T22:50:41.730 - DEBG - EQMod Mount :  "Connection successful, attempting handshake... "
2017-06-25T22:50:41.733 - DEBG - EQMod Mount :  "dispatch_command: \":\", 2 bytes written "
2017-06-25T22:50:56.678 - DEBG - EQMod Mount :  "Error:  -> tty read failed, check connection: Timeout error "
2017-06-25T22:50:56.723 - DEBG - EQMod Mount :  "Handshake failed. "
2017-06-25T22:50:56.727 - DEBG - EQMod Mount :  "Communication with /dev/ttyUSB1 @ 9600 failed. Starting Auto Search... "
2017-06-25T22:50:56.730 - DEBG - EQMod Mount :  "Trying connection to /dev/ttyUSB0 @ 9600 ... "
2017-06-25T22:50:56.733 - DEBG - EQMod Mount :  "Connecting to /dev/ttyUSB0 "
2017-06-25T22:50:56.737 - DEBG - EQMod Mount :  "Port FD 21 "
2017-06-25T22:50:56.740 - DEBG - EQMod Mount :  "Connection successful, attempting handshake... "
2017-06-25T22:50:56.743 - DEBG - EQMod Mount :  "dispatch_command: \":\", 2 bytes written "
2017-06-25T22:51:11.678 - DEBG - EQMod Mount :  "Error:  -> tty read failed, check connection: Timeout error "
2017-06-25T22:51:11.725 - DEBG - EQMod Mount :  "Handshake failed. "
2017-06-25T22:51:11.725 - DEBG - EQMod Mount :  "Trying connection to /dev/ttyUSB1 @ 9600 ... "
2017-06-25T22:51:11.741 - DEBG - EQMod Mount :  "Connecting to /dev/ttyUSB1 "
2017-06-25T22:51:11.741 - DEBG - EQMod Mount :  "Port FD 22 "
2017-06-25T22:51:11.741 - DEBG - EQMod Mount :  "Connection successful, attempting handshake... "
2017-06-25T22:51:11.741 - DEBG - EQMod Mount :  "dispatch_command: \":\", 2 bytes written "
2017-06-25T22:51:26.681 - DEBG - EQMod Mount :  "Error:  -> tty read failed, check connection: Timeout error "
2017-06-25T22:51:26.727 - DEBG - EQMod Mount :  "Handshake failed. "
2017-06-25T22:51:26.727 - DEBG - Ekos:  EQMod Mount  is disconnected.
2017-06-25T22:51:26.727 - DEBG - Ekos:  "EQMod Mount is disconnected."

I am using a raspberrypi 2 with ubuntu mate 16.04.1. My EQ6 is connected with an FTDI serial to usb converter. below is the lsusb output.
Bus 001 Device 013: ID 0403:0000 Future Technology Devices International, Ltd H4SMK 7 Port Hub / Bricked Counterfeit FT232 Serial (UART) IC

Sebastien

Please Log in or Create an account to join the conversation.

Problem with EQMod 2 months 3 weeks ago #17433

Sorry guys, I think I caused the problem. I just dropped a hotfix to Github and Jasem merged. It will get up in the next PPA update, please test tomorrow.

Please Log in or Create an account to join the conversation.

Last Edit: by kecsap.

Problem with EQMod 2 months 3 weeks ago #17475

Hi,

There is same issue after today's update.

Please Log in or Create an account to join the conversation.

Problem with EQMod 2 months 3 weeks ago #17486

I also have the same issue. I am using the skyview pro 8 goto upgrade. I can confirm that the below version is working fine on Ubuntu:

0.3+r3130~201706160928~ubuntu17.04.1

Please Log in or Create an account to join the conversation.

Problem with EQMod 2 months 3 weeks ago #17487

I've got the same issue as well still. I can confirm that version 0.3+r3130~201706160928~ubuntu17.04.1 on Ubuntu is working fine, though.

Please Log in or Create an account to join the conversation.

Problem with EQMod 2 months 3 weeks ago #17505

The issue has been identified, fixed and merged. Jasem tested on his EQ mount. The PPA should be updated in the coming hours and the new version can be fetched from the PPA tomorrow.
The following user(s) said Thank You: sebiseb

Please Log in or Create an account to join the conversation.

Problem with EQMod 2 months 3 weeks ago #17519

Hi All!

Same...

ver. 0.3+r3146~201706281908~ubuntu16.04.1
Prolific pl2303
2017-06-29T09:00:52: ProcessSwitchProperties - name(SYSTEM_PORTS) 
2017-06-29T09:00:52: ProcessSwitchProperties - name(SYSTEM_PORTS) 
2017-06-29T09:00:48: Handshake failed. 
2017-06-29T09:00:48: Error:  -> tty read failed, check connection: Timeout error 
2017-06-29T09:00:33: dispatch_command: ":", 2 bytes written 
2017-06-29T09:00:33: Connection successful, attempting handshake... 
2017-06-29T09:00:33: Port FD 9 
2017-06-29T09:00:33: Connecting to /dev/ttyUSB0 
2017-06-29T09:00:33: Trying connection to /dev/ttyUSB0 @ 9600 ... 
2017-06-29T09:00:33: Communication with /dev/ttyUSB0 @ 9600 failed. Starting Auto Search... 
2017-06-29T09:00:33: Handshake failed. 
2017-06-29T09:00:33: Error:  -> tty read failed, check connection: Timeout error 
2017-06-29T09:00:18: dispatch_command: ":", 2 bytes written 
2017-06-29T09:00:18: Connection successful, attempting handshake... 
2017-06-29T09:00:18: Port FD 7 
2017-06-29T09:00:18: Connecting to /dev/ttyUSB0 
2017-06-29T09:00:18: ProcessSwitchProperties - name(CONNECTION) 
2017-06-29T09:00:18: ProcessSwitchProperties - name(CONNECTION) 
2017-06-29T09:00:18: ProcessTextProperties - name(SCOPE_CONFIG_NAME) 
2017-06-29T09:00:18: Error: Invalid range for Aperture (mm) (TELESCOPE_APERTURE). Valid range is from 10 to 5000. Requested value is 0 
2017-06-29T09:00:18: ProcessNumberProperties - name(TELESCOPE_INFO) 
2017-06-29T09:00:18: Active Snoop, driver: Dome Simulator, property: DOME_PARK 
2017-06-29T09:00:18: ProcessSwitchProperties - name(DOME_POLICY) 
2017-06-29T09:00:18: ProcessSwitchProperties - name(DOME_POLICY) 
2017-06-29T09:00:18: ProcessTextProperties - name(ACTIVE_DEVICES)
Attachments:

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
  • 2
Time to create page: 0.116 seconds

Login

3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica