Welcome, Guest
Username: Password: Remember me
27 Feb 2017
INDI development team is happy to announce the release of INDI Library v1.4.0. This new exciting release builds on the maturity of INDI Library and comes with many new supported devices and fixes for existing drivers. Several improvements and enhancements are included in this release including native support for Cygwin and MacOS platforms in addition to Linux, BSD, and Windows (Client only).
Read More...
  • Page:
  • 1

TOPIC: Failing to control Celestron NexStar+ HC

Failing to control Celestron NexStar+ HC 3 weeks 8 hours ago #17659

  • avilqu
  • avilqu's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 14
  • Thank you received: 0
Hi all,

I've failed at controlling a Celestron CGE Pro mount through the NexStar HC. INDI logs attached. I'm using a laptop running Xubuntu 16.04 (Kstar/Ekos), and this set of cables .

I made multiple attempts, with different drivers - I have debug logs for eqmod and celestron_nexstar. The way I proceed is: turn on the telescope, align it, connect the cables, start INDI.

EQmod wasn't really able to connect to the mount. NexStar was more promising: it connects, but that's all. Impossible to move the telescope, or modify anything in the settings. I tried to update the time and location on the INDI settings panel, but it fails (it updates time, but loses it about 30s later, and refuses to update location).

I also noticed that everytime I connect NexStar driver, the HC freezes and becomes completely unresponsive. Not sure why. Even after I disconnect INDI, HC refuses to do anything (screen is frozen on whatever it was showing last). Only way is to hard-turn off and on the mount, and redo alignment.

I'm starting to have a decent history of failing to control mounts... Tried with a SynScan-controlled EQ-8, Celestron CGE, and a Losmandy. I remember, a few months ago, having some sucess with the CGE Pro Mount, I think using the nexstar driver. But nothing tonight... Please help! Am I cursed? Or just stupid?

Please Log in or Create an account to join the conversation.

Last Edit: by avilqu.

Failing to control Celestron NexStar+ HC 3 weeks 8 hours ago #17660

Thanks for the logs, there are helpful. Looks like CGE Pro does not support setting date/time command and probably got stuck. I added an exception to this and also added the mount model as it was not recognized before. If you can compile, you can test right away, or wait for tomorrow's PPA update.
The following user(s) said Thank You: pcxz

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Last Edit: by knro.

Failing to control Celestron NexStar+ HC 3 weeks 7 hours ago #17663

  • avilqu
  • avilqu's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 14
  • Thank you received: 0
This has to be the best ever support service. Thanks. I'm not at the observatory anymore so I'll check that out tomorrow.

Please Log in or Create an account to join the conversation.

Failing to control Celestron NexStar+ HC 2 weeks 4 days ago #17723

  • avilqu
  • avilqu's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 14
  • Thank you received: 0
Did work like a charm. Many thanks!

Please Log in or Create an account to join the conversation.

  • Page:
  • 1
Time to create page: 0.376 seconds

Login

3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!

Gallery

Replica

Why INDI

Replica