Welcome, Guest
Username: Password: Remember me
25 Jul 2018
Glad to announce of release of INDI Library v1.7.4 on 2018-07-25. A few drivers were added in this release as we continue to improve & stabilize existing drivers.
Read More...
  • Page:
  • 1

TOPIC: Beginner problems with HEQ5 Pro through indi server EQMod

Beginner problems with HEQ5 Pro through indi server EQMod 1 week 2 days ago #28375

  • Swich
  • Swich's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
Hello,
We have HEQ5 pro. There are problems with slew through the indi server. I'm testing now in Kstar, and I'll work through indi-client using Python scripts for remote control of the telescope.
Now there are difficulties at the very beginning of the work: I'm trying to set up the HEQ5 in the room so that it is placed at least roughly in the right area.
Problems arise because of the fact that it periodically swaps the top and bottom of the telescope tube, and also, sometimes it goes beyond the horizon. I set it manually to a certain position in the direction of the polar star (especially angle from the horizon), I set this position as parking, and synchronize in Kstar with polar star. The alignment mode is set to "N-star". Then I try to slew at some star, but it goes to the other side of the hemisphere or something like that.
I understand that I probably have some incorrect settings for HEQ5. I'm a beginner and do not really understand what different settings are responsible for. For example, what means "reverse DEC" or "enforce counter-weight up" (I leave default). In Ascom, it slews all right, but I need to control it from ubuntu.
Could someone share their settings file for indi server here? Or maybe give a couple of links or some tips for me to find some info that will help me solve this problem.

Please Log in or Create an account to join the conversation.

HEQ5 Pro
Last Edit: by Swich.

Beginner problems with HEQ5 Pro through endi server 1 week 2 days ago #28376

What cable are you using? Are you connected directly to the mount or via the hand controller? Can you post the logs? (check my signature for how to).

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Beginner problems with HEQ5 Pro through endi server 1 week 2 days ago #28381

  • Swich
  • Swich's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
Thank you for fast answer!

I think it's not a cable problem. Connected directly.
Yes, I can post the logs, but I make some nice progress last hour: now I make it work without using sync. So, looks like all problem was in sync protocol.

What I did: I restarted indi server, slew to the polar star, then manually adjust HEQ5 to polar star and change park position to current. No sync at any time, just uses what's settings it has (we have some settings from the previous mount). I named it "manual sync" :D
So now I need to understand how "align" and "sync" tab work. Which is the difference between different settings(Alignment mode, Sync.Mode), and how to make correct sync's and alignment's points?

Looks like there is need to add some info about it in indilib.org/devices/telescopes/eqmod.html
Can I read about it on some other drivers page? Does it work in the same way?

P.S.: it took me about one week to realize how to make it works.

Please Log in or Create an account to join the conversation.

HEQ5 Pro
Last Edit: by Swich.

Beginner problems with HEQ5 Pro through endi server 1 week 2 days ago #28385

  • jpaana
  • jpaana's Avatar
  • Away
  • Expert Boarder
  • Expert Boarder
  • Posts: 84
  • Karma: 1
  • Thank you received: 28
I've noticed some issues with n-star alignment which occasionally does some weird things, using one star seems to work more reliably, though not as accurately, but combined with plate solving has worked well for me.

Please Log in or Create an account to join the conversation.

Beginner problems with HEQ5 Pro through endi server 1 week 2 days ago #28386

A week! That's quite long. All you have to do is to point to the Celestial pole with the weight down. The documentation could use some improvement, but usually users do not need to fiddle with the settings, it should work fine as is.

Please Log in or Create an account to join the conversation.

Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info

Beginner problems with HEQ5 Pro through endi server 1 week 1 day ago #28389

  • Swich
  • Swich's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
What "plate solving" means?

Please Log in or Create an account to join the conversation.

HEQ5 Pro

Beginner problems with HEQ5 Pro through endi server 1 week 1 day ago #28390

  • Swich
  • Swich's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
Yes, that's because we already have some code on Python which worked with the previous mount, so I tried it first. After that I try to combine it with Kstars, using sync and etc... That was tight way, but I'm not just a usual user, so I need to understand all settings.

Please Log in or Create an account to join the conversation.

HEQ5 Pro

Beginner problems with HEQ5 Pro through endi server 1 week 1 day ago #28391

Swich wrote: What "plate solving" means?


Hi. It's part of what the align module does. It takes a snap of the sky and tells you where the telescope is pointing. Exactly.

** until recently, the indi eqmod driver did not behave as the ascom eqmod driver. We got caught out by that. If your scripts need the ascom behaviour, make sure you have the latest indi-eqmod installed.
HTH and clear skies,
Steve

Please Log in or Create an account to join the conversation.

ubuntu 18.04
700d, eq6, t7m
Last Edit: by alacant.

Beginner problems with HEQ5 Pro through indi server EQMod 1 week 1 day ago #28396

Swich wrote: Hello,
We have HEQ5 pro. There are problems with slew through the indi server. I'm testing now in Kstar, and I'll work through indi-client using Python scripts for remote control of the telescope.
Now there are difficulties at the very beginning of the work: I'm trying to set up the HEQ5 in the room so that it is placed at least roughly in the right area.
Problems arise because of the fact that it periodically swaps the top and bottom of the telescope tube, and also, sometimes it goes beyond the horizon. I set it manually to a certain position in the direction of the polar star (especially angle from the horizon), I set this position as parking, and synchronize in Kstar with polar star. The alignment mode is set to "N-star". Then I try to slew at some star, but it goes to the other side of the hemisphere or something like that.
I understand that I probably have some incorrect settings for HEQ5. I'm a beginner and do not really understand what different settings are responsible for. For example, what means "reverse DEC" or "enforce counter-weight up" (I leave default). In Ascom, it slews all right, but I need to control it from ubuntu.
Could someone share their settings file for indi server here? Or maybe give a couple of links or some tips for me to find some info that will help me solve this problem.



I had a very similar issue in the beginning and it drove me nuts but I got this fixed.
The first thing I've done was to disconnect the mount from anything, forget Ekos/Kstars etc... for the time being.
You will just need for this exercise you mount controller connected to the HEQ5, and follow the instruction to the letter from the link in my post Accurately setting the “Home” or “Park” position on a EQ5
Once it's done and dusted, then you can start playing with Ekos/Kstars.
Generally speaking after you've got the home/park position set and mastered from the previous link, the vast majority of the eqMod settings should work fine for the HEQ5 pro.

Please Log in or Create an account to join the conversation.

Kstars Mac osx
Odroid C1 running indiserver (kept up-to-date with apt-get update/upgrade)
HEQ5 pro / Atik titan / Atik 314L+
Last Edit: by Gonzothegreat.

Beginner problems with HEQ5 Pro through indi server EQMod 1 week 1 day ago #28417

  • Swich
  • Swich's Avatar Topic Author
  • Offline
  • Fresh Boarder
  • Fresh Boarder
  • Posts: 5
  • Thank you received: 0
Gonzothegreat,
Thank you for the complete answer, we for sure will use it!

alacant, sound like a magic :)

Please Log in or Create an account to join the conversation.

HEQ5 Pro
Last Edit: by Swich.

Beginner problems with HEQ5 Pro through indi server EQMod 6 days 17 hours ago #28447

Let us know please if you were successful or not.

Please Log in or Create an account to join the conversation.

Kstars Mac osx
Odroid C1 running indiserver (kept up-to-date with apt-get update/upgrade)
HEQ5 pro / Atik titan / Atik 314L+
  • Page:
  • 1
Time to create page: 0.107 seconds

Login



3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!


Gallery

Replica

Why INDI

Replica