Radek Kaczorek thanked fehlfarbe in topic Satellite confusion 4 months ago
pauledd thanked fehlfarbe in topic Satellite confusion 4 months ago
fehlfarbe replied to the topic 'Satellite confusion' in the forum. 4 months ago

I was using SatelliteTracker from www.heavenscape.com/ and EQMOD/EQMODLX under Windows XP.
A similar program for INDI would be nice :)

Read More...

Ales thanked fehlfarbe in topic Satellite confusion 4 months ago
fehlfarbe replied to the topic 'Satellite confusion' in the forum. 4 months ago

Ihoujin wrote: It certainly should be possible to adjust the RA and DEC slewing rates independently.
They describe such a function they call a continuous tracking state for a sattrack app used with EQ-Mod.
http://eq-mod.sourceforge.net/faqs/sattrack.html
Maybe if this is open source it can be ported over?
Edit: It's not open source, it's shareware.
I wonder if they would be willing to collaborate on a Linux port, as it appears to be Windows only.
At least this shows that custom slew rates + pulse guiding commands are possible for satellite tracking.
Their website: heavenscape
Their app in action: EQMODLX: Satellite Tracking


I tried the satellite tracker software some years ago with my EQ-6 mount and EQMOD. I tracked several satellites with good precision. Here you can see a video of Globalstar M030 with 8" f/5 newtonian telescope and EOS 550D: www.youtube.com/watch?v=zCBZb180LS0&list...6E455C80F8B&index=22 and another video of Globalstar M003 that shows periodic flares from the satellite: www.youtube.com/watch?v=GQrV28yBU6M

I also tried the ISS and some other satellites but there was the problem that tracking rates above 1000 arcsec/sec (iirc) weren't possible. If the speed changes at tracking rates above 1000 the motors stop for a short time and then start to re-accelerate. This means the mount "jumps" from position to position and doesn't catch the satellite because the ramp acceleration is too slow.
IIRC this is a "feature" of the Skywatcher motor driver to prevent damages on the stepper motors.

Maybe someone fixed this problem. Last time I tried the software was 2011 or 2012.

Read More...

fehlfarbe thanked Romain Fafet in topic Satellite confusion 4 months ago
fehlfarbe replied to the topic 'FitsViewer memory usage on zoom' in the forum. 4 months ago

Thank you very much! Now I can control my observatory without lags and crashes :)

Read More...

fehlfarbe created a new topic ' FitsViewer memory usage on zoom' in the forum. 4 months ago

Hi,

I'm running KStars, Ekos and Indi on an Odroid XU4 with 2GB RAM and 64GB eMMC with Ubuntu 16.04.
KStars and Ekos handling is very smooth but when I (accidently) zoom more than 100% into an image the memory usage increases very fast and the system starts swapping which slows down the whole system and I have to wait some minutes before I can abort the action. It's happening in Fitsviewer but also in the focuser window.
I assume Fitsviwer resizes the whole image so it takes much more space in memory. Maybe there is a way to calculate the region of interest where I zoomed in and resize this part of the image. Of course, this needs more CPU because moving the region of interest needs to recalculate the resized image region but it can save memory.

Read More...

fehlfarbe replied to the topic 'Canon EOS Focuser' in the forum. 6 months ago

So I did further tests with an EOS 1000D. When starting Indi from Ekos, connect the camera and start the preview mode I can control the focus. But when I click on autofocus/framing/capture in Ekos with e.g. 4s exposure time the camera starts taking a picture but doesn't stop after 4s. I can only turn the camera off an on to stop the capture. The video preview window closes when I start the capture. This happened in 90% of my tests. It worked only two or three times.

This is the log of my Indi control panel

2016-12-10T17:29:33: Error capturing preview. 
2016-12-10T17:29:33: Error capturing preview: Unspecified error 
2016-12-10T17:29:26: Starting 4 sec exposure 
2016-12-10T17:28:50: World Coordinate System is enabled. CCD rotation must be set either manually or by solving the image before proceeding to capture any frames, otherwise the WCS information may be invalid. 
2016-12-10T17:28:49: Error loading user configuration. Unable to read user config file. Error loading file /home/odroid/.indi/Canon DSLR_config.xml: No such file or directory. To save user configuration, click Save under the Configuration property in the Options tab.  
2016-12-10T17:28:49: Please update the camera pixel size in the Image Info section. The camera resolution will be updated after the first exposure is complete. 
2016-12-10T17:28:49: Detected Canon Inc. Model Canon EOS 1000D. 
2016-12-10T17:28:49: Canon DSLR is online. 

I tried to start the indiserver from bash:
indiserver -vv indi_simulator_telescope indi_simulator_gphoto_ccd
And this seems to work. I tried several times now and didn't get any errors. Autofocus works good with a simulated star.

Read More...

fehlfarbe thanked Jasem Mutlaq in topic Canon EOS Focuser 6 months ago
fehlfarbe thanked leclerc in topic Canon EOS Focuser 6 months ago
fehlfarbe replied to the topic 'Canon EOS Focuser' in the forum. 6 months ago

Thanks it works when I activate and deactivate preview mode. Unfortunately it seems to be not very stable with my 1000D. Indi crashed many times with preview mode or capturing didn't stop. I will do more tests the next days.

Read More...

fehlfarbe created a new topic ' Canon EOS Focuser' in the forum. 6 months ago

Hi,

I tried the Canon DSLR focuser today but the lens doesn't move when I click Focus in/out in EKOS-Focuser tab. Is this feature already implemented?
I tried with different cameras (1000D/550D/6D) and different lenses (18-55/28-135mm) and AF/MF setting.

My setup: Odroid XU4, Ubuntu Mate 16.04, kstars-bleeding and indi-full from repo.

Read More...

fehlfarbe replied to the topic 'Take image with python script' in the forum. 9 months ago

When you start the Python script there should be a list of camera propertys (new Property XXX). There should be the property CCD_BINNING or something similar. Just set a new value the same way you start a new exposure:

def newProperty(self, p):
    if p.getName() == "CCD_BINNING":
	    bin = self.device.getNumber("CCD_BINNING")
            bin[0].value = 5
            self.sendNewNumber(bin)


Read More...

fehlfarbe replied to the topic 'Take image with python script' in the forum. 9 months ago

finally :)

You could add a boolean variable to the IndiClient class that gets true/false when the image is ready and check the variable it in the endless loop.

Read More...

fehlfarbe replied to the topic 'Take image with python script' in the forum. 9 months ago

And does the Python script work when you open your camera with EKOS? :)

Read More...

fehlfarbe replied to the topic 'Take image with python script' in the forum. 9 months ago

Does it work when you open your camera with EKOS?

Read More...

SB thanked fehlfarbe in topic Take image with python script 9 months ago
fehlfarbe replied to the topic 'Take image with python script' in the forum. 9 months ago

My bad, I didn't have the INDI SBIG drivers on my notebook. Start the indiserver with:

indiserver indi_sbig_ccd
and then start your Python script. The device name should appear in the output text:
2016-08-22 13:35:24,190 new device DEVICE NAME


Read More...

Login

3rd Party

Choose from the numerous 3rd party INDI drivers to suit your needs!

Got Problem?

Check out the FAQ, the forum, and the bug tracking system to resolve any issues you might have!
You can also subscribe to INDI newsletter and development mailing lists to get the latest updates on INDI!