×

INDI Library v2.0.6 is Released (02 Feb 2024)

Bi-monthly release with minor bug fixes and improvements

AstroArch - yet another raspberry distro for astrophotography for ARM64

  • Posts: 320
  • Thank you received: 45
Hi Stéphane,
Could you offer a little more detail on how to install FC 2.7.14 on AstroArch please? Your suggestion to install debtap from AUR is a bit too cryptic for me. I have installed FC on Raspberry Pi OS bullseye using dpkg but I'm having other issues with KStars on my RPi5 on bullseye.
I'm sure there are other AstroArch users out there who would be equally grateful!
Thanks, Ed (Avocette)
The following user(s) said Thank You: Steve Cohen
2 months 3 weeks ago #97478
The topic has been locked.
  • Posts: 50
  • Thank you received: 22
Hello Ed,

I think the first problem you encounter for those using AstroArch is the logic of ArchLinux. There are two kinds of packages, the official ones installed with pacman and those from users (anyone can upload their package to AUR) which are installed with a wrapper (yay, trizen….). If the AUR package is widely used and recognized by the community, it becomes official.

Now back to our issue, the FireCapture package offered on the official website is in .deb. ArchLinux does not natively support the .deb type. You must therefore either install it manually or install it from a script. Using dpkg is not recommended on ArchLinux. For more information, here is a useful link low-orbit.net/arch-linux-how-to-install-deb-package

Therefore, the idea is to use debtap (script bbs.archlinux.org/viewtopic.php?id=187558) to convert it.

And to install debtap, you need a wrapper. I use trizen which I like, but yay works great too. The list of wrappers and here wiki.archlinux.org/title/AUR_helpers

In one of my previous posts, there is the method to install trizen.

To summarize, we download the FireCapture file in .deb, convert it with debtap then install it with trizen.

Afterward, I installed the version of java which works well on ArchLinux jdk-openjdk (the one in the package does not work with my ArchLinux).

And finally, modify the Firecapture startup script so that it uses the version of java that I installed rather than that of the package.

This is the explanation which I hope can help you with the installation of FireCapture.

ArchLinux requires a little more effort from its users, because its philosophy is different from other distributions. But in return, we have much more freedom and the latest packages (KSTARS, INDI…). Since I replaced Astroberry
with my version of ArchLinux, I solved all my problems with Kstars. It's much smoother, and I was able to use functions that have changed the way I make my acquisitions.

I think Mattia is working very hard ;) to integrate the data I provided in my posts and the logic of ArchLinux

You will be very surprised when you use the next versions of AstroArch.

Long live Mattia. Long live ArchLinux :)

Have fun and good clear skies to you
The following user(s) said Thank You: Avocette
Last edit: 2 months 3 weeks ago by Stéphane Carlin.
2 months 3 weeks ago #97480
The topic has been locked.
  • Posts: 185
  • Thank you received: 7
Thanks for this DETAILED explanation!
The following user(s) said Thank You: Stéphane Carlin
2 months 3 weeks ago #97481
The topic has been locked.
  • Posts: 320
  • Thank you received: 45
@sc - thanks for your detailed explanation! And I concur with your thanks to @mattia for his ongoing efforts in creating AstroArch. I am presently testing 1.7.0 on my new RPi5 and things are looking very good. As Stéphane suggests KStars does seem to be running very smoothly on this Image. As a personal plea, perhaps @mattia might include FireCapture within a future AstroArch image!.
The following user(s) said Thank You: Stéphane Carlin
2 months 3 weeks ago #97483
The topic has been locked.
  • Posts: 185
  • Thank you received: 7
There are 19 pages in this thread. Can someone please repost the method to install trizen?
2 months 3 weeks ago #97526
The topic has been locked.
  • Posts: 320
  • Thank you received: 45
  • Posts: 130
  • Thank you received: 91
Hello everyone!

Hope y'all are good: sorry I have gone for so long, but last months have been pretty busy at work and now during December I am also spending some extra time doing the advent of code, so I thought not so much about AstroArch.

This post is likely the last one for the 2023 and I want to tell you few things!

First of all, I want to THANK all people that are using astroarch, this year the user base grew esponentially, from 3 users there are now at least 2 dozens or more using it, it makes incredibly proud and happy, you drive this project and there is nothing more important than this to me!

This year we have seen the first contributions! This is the philosophy I like, I can't say how grateful I am to have received few contribs, either as requests, missing features or even a full guide to install some things that work better. This are the base of a beautiful and strong community!

So, why am I saying all of this? Cause I don't feel good with myself when I go silent and there is movement on the forum.

Here's the plan for the upcoming week and 2024.

First I want to ship indi 2.0.5 asap, I think it may be ready by tomorrow evening. After that I don't expect much activity for another ~2 months, I tried the building steps given by Stephan and I believe reworking the project that way will be a major improvement for everyone, so that will be my next focus - shipping a reworked 1.8 version that should correct some annoying bugs that have been around since few months (striped theme on dolphin and missing icons to anyone?)
This will absorb an incredible amount of time unfortunately, rebuilding things from scratch and make sure they work is a lot of trials and errors and when you want to achieve 100% reproducibility you find yourself nuking things and redo them even few times per day, and flashing stuff on SD and scripting may be time consuming

I will be on holiday starting next week, so maybe (although unlikely) I may have 1.8 ready by beginning of 2024.

I also hear you, having a mega thread which now reached 19 pages is not the best thing :D I will ask Jasem if we can have a proper forum section next to stellarmate/astroberry in the forum so hopefully things will be cleaner.

I wish you all and your families a peaceful time during the upcoming holidays (and a lot of clear skies of course).
I'll see you all next year!

Mattia


PS: for AUR packages, there is already paru installed and you can install packages from the AUR simply using paru -S package_name
The following user(s) said Thank You: Avocette, Stefan, Matteo, Steve Cohen, Stéphane Carlin, Troy
2 months 3 weeks ago #97530
The topic has been locked.
  • Posts: 185
  • Thank you received: 7
Stephane, you wrote:

"And to install debtap, you need a wrapper. I use trizen which I like" ...

Does deptap need to be installed? Or did you mean to say "to install FireCapture"? It looks to me that debtap is a script, not a package, and that is the way the rest of your message seems to indicate.
2 months 3 weeks ago #97541
The topic has been locked.
  • Posts: 185
  • Thank you received: 7
When I try to run debtap, I get this

<code>»
» sudo debtap FireCapture_v2.7.14.deb 1 ? astronaut@astroarch
Error: You must run at least once "debtap -u" with root privileges (preferably recently), before running this script

» sudo debtap -u FireCapture_v2.7.14.deb 1 ? astronaut@astroarch
==> Synchronizing pkgfile database...
:: Updating 6 repos...
alarm is up to date
aur is up to date
warning: download failed: fl.us.mirror.archlinuxarm.org/aarch64/community/community.files [error 404]
error: failed to update repo: community
astromatto is up to date
download complete: core [ 1353.2 KiB 1168K/s 1 remaining]
download complete: extra [ 33.9 MiB 5.97M/s 0 remaining]
:: download complete in 5.68s < 35.2 MiB 6.20M/s 2 files >
:: waiting for 1 process to finish repacking repos...
Synchronization failed. Exiting...

</code>
It seems that the debtap script has a broken link? Not sure what is going on here. Maybe I'm doing something wrong,
Last edit: 2 months 3 weeks ago by Steve Cohen. Reason: fix typos
2 months 3 weeks ago #97542
The topic has been locked.
  • Posts: 50
  • Thank you received: 22
Hello Steve !

The Debtap package allows you to install the Debtap script. It's easier than installing it manually.

The Debtap GitHub for explanations of the script github.com/helixarch/debtap

Before using Debtap, you must update it, using sudo debtap -u

Afterward, we can use it to install FireCapture:
sudo Debtap FireCapture_v2.7.14.deb

I hope this will help you.
2 months 3 weeks ago #97543
The topic has been locked.
  • Posts: 185
  • Thank you received: 7
My previous attempt simply pulled down debtap from GitHub. That having failed, I tried using the method on the low-orbit.net/arch-linux-how-to-install-deb-package recommended by Stephane:
tar zvxf ~/Downloads/debtap.tar.gz -C ~/arch
cd ~/arch/debtap
makepkg -s
sudo pacman -U debtap-3.1.4-2-any.pkg.tar.xz

This failed because debtap-3.1.4-2-any.pkg.tar.xz did not exist, but debtap-3.1.5-1-any.pkg.tar.xz did so I changed that and it successfully installed debtap. (YES, it does need to be installed.). However, trying to use this to install FireCapture failed again.
» sudo debtap -u                                                                                                     1 ? astronaut@astroarch
==> Synchronizing pkgfile database...
:: Updating 6 repos...
warning: download failed: http://ca.us.mirror.archlinuxarm.org/aarch64/community/community.files [error 404]
error: failed to update repo: community
  alarm is up to date
  aur is up to date
  astromatto is up to date
  download complete: core                 [  1353.2 KiB  1561K/s  1 remaining]
  download complete: extra                [    33.9 MiB  7.00M/s  0 remaining]
:: download complete in 4.85s             <    35.2 MiB  7.26M/s  2 files    >
:: waiting for 1 process to finish repacking repos...
Synchronization failed. Exiting...

So that's two different methods of using debtap both failing because they depend on a resource that no longer exists, it seems. Can someone help?
2 months 3 weeks ago #97544
The topic has been locked.
  • Posts: 185
  • Thank you received: 7
In my previous post, I meant "convert Firecapture", not "install Firecapture"
2 months 3 weeks ago #97545
The topic has been locked.
Time to create page: 0.837 seconds