×

INDI Library v2.0.7 is Released (01 Apr 2024)

Bi-monthly release with minor bug fixes and improvements

Things keep going from bad to worse

  • Posts: 53
  • Thank you received: 22
I have the same camera as you and no problem with the Kstars viewer.

There is probably a configuration error. Have you looked under configuration/fits to see if you have checked automatic Bayer filter?

Maybe the issue comes from the file handling the 533 in the .indi folder? Move it elsewhere so that Kstars creates another one.
The following user(s) said Thank You: Steve Cohen
2 months 1 week ago #98591

Please Log in or Create an account to join the conversation.

  • Posts: 198
  • Thank you received: 8
Your diagnosis was correct. Turning the auto-debayer setting off made the problem go away, while KStars was running. It came back upon quitting and restarting KStars. And the setting was back ON.

Then I tried your suggestion of moving the original config somewhere so a new one would be created. This made the problem go away permanently.

However, I don't understand any of this. A search within the file for "bayer" returns nothing. I suppose it could be hiding under some other setting name in the config file. But I like to understand the problems I find.
2 months 1 week ago #98593

Please Log in or Create an account to join the conversation.

  • Posts: 53
  • Thank you received: 22
Maybe you could compare your two files to see the difference. Then go back to the configuration value that is causing the problem.
2 months 1 week ago #98620

Please Log in or Create an account to join the conversation.

  • Posts: 198
  • Thank you received: 8
I tried that. Even obtained a visual differencing program, and while there are many differences, none of them seem to point obviously to the source of the problem.

One interesting difference that may be but probably isn’t relevant is that the “device name” in the kstars config file ZWOCCDASI533MCPro_config.xml after the config has been saved iis “ZWO CCD ASI533MC Pro” whereas when a NEW config is created by KStars it is called “ZWO ASI533MC Pro” (no CCD in the name).

I still would like someone who might know to tell me where (what file and key) the Auto-debayer setting is persisted under.

Thanks.
2 months 1 week ago #98623

Please Log in or Create an account to join the conversation.

  • Posts: 1220
  • Thank you received: 565
Usually these types of parameters are stored in ~/.config/kstarsrc (at least on Linux).
In this case, I can see that if I uncheck "Auto Debayer" I get an entry in that file:


If I check that parameter, though, then there is no entry in the file.
I am not familiar with the details of the parameter system, so I'm not sure why this is the case,
but a clue is in the file kstars.kcfg where that parameter is listed as:



Can't really explain more.
Hy
The following user(s) said Thank You: Steve Cohen
2 months 1 week ago #98628
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 198
  • Thank you received: 8
Interestinger and interestinger, as they say.

Thanks for the info!

It answers my question, but it raises others.

If I read this correctly, the "AutoDebayer" attribute defaults to true if "isHardwareLimited" is false. What is "isHardwareLimited"?

More fundamentally, if AutoDebayer is the default with my setup, why does it produce such bad results (the all green screen)? I don't really want monochrome images. I'd prefer color images to be produced as a default. What OTHER settings do I need to look at to get a more reasonable image?
2 months 1 week ago #98632

Please Log in or Create an account to join the conversation.

  • Posts: 1220
  • Thank you received: 565
I checked the code, and the "limited resources mode" in the FITS settings
turns out to be a check for using an arm-based cpu (like a raspberry pi).
I agree in advance that that isn't an ideal definition, but that's what it is, and isn't your green problem.

Why are your images green? No clue, but if I had to guess, I'd say it could be that the bayer pattern being used isn't right.
I'm not sure where that would be set, but perhaps check your INDI settings for the camera you're using
or look at the fits header of one of your files. Also, I'd suggest you post a link to one of your green files.

Hy
The following user(s) said Thank You: Steve Cohen
2 months 1 week ago #98634
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 198
  • Thank you received: 8
Thanks again for all the help.
I've found the settings page on the indi control panel where I could set the Bayer filter pattern. The file I've been showing was using the RGGB pattern. I can't really experiment now since we're in bad weather again for a few days.
Here is a link to the fits file I've been showing.
2 months 1 week ago #98658

Please Log in or Create an account to join the conversation.

  • Posts: 1220
  • Thank you received: 565
When I open this file in PixInsight and run the Debayer process on it, it also turns green.
If you could figure out how to get PixInsight to open it properly, that would probably give us a clue about
what might be wrong in Ekos.

I suggest you should figure out if the header is wrong or some such.
Header says:



You might also check out this:
www.cloudynights.com/topic/760150-asi533mc-pro-bayer-pattern/
2 months 1 week ago #98659
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 198
  • Thank you received: 8
Thanks, but my knowledge of FITS file headers is zero. I can't help you there beyond sending the file.

I'm just trying to understand this on a basic level.
To review:
A month and a half ago I captured the green fits file that I shared.

At various times since then, I was able to do captures that did not have the green problem.

The other night I made captures where the green pattern returned. I did not save the fits file on that occasion (bad move on my part).

We did find that I could make the green pattern go away by turning off auto-debayering but then I am restricting myself to using the camera in monochrome mode, I think, unless there is some way to turn it on or off.

I dhad never heard of PixInsight until you mentioned it and I've been having enough trouble with the KStars learning curve so that I don't want to learn a new software in hopes of finding something when I don't even know what I'm looking for.. Even moreso as I see that this program will cost me $329 after the 45-day free trial expires. If, as you say, the green pattern occurred in Pixinsight, does this not indicate that there must be something wrong in the FITS image itself?

Basically I am trying to determine what may be going on here.
1. Something wrong with the camera
2. Something wrong (bug?) with the KStars or the INDI driver for this camera.
3. Some sort of power/votlage inadequacy in my setup (though I consider this doubtful).

I should probably capture some more images and share those. That will have to wait a few days as we are having unusally bad weather - high winds and heavy rain.

I'd be extremely grateful for any other diagnostic steps I could try.
2 months 1 week ago #98662

Please Log in or Create an account to join the conversation.

  • Posts: 198
  • Thank you received: 8
Or, it seems there is a fourth possibility I hadn't considered.
4. Nothing is wrong.

It is possible that I had always in the past left auto-debayering off, then turned it on, and got the green shading that seemed obviously wrong but was actually to be expected? Many interent sources indicate that it is normal. Here is an example.

So should I just handle this in some sort of post-processing? Leave auto-debayering off, and manually do it in some post-processing step? Perhaps I do need to add this PixInsight to my arsenal as Hy suggested, though the price tag led me to sticker shock. What alternative solutions exist? Thanks for all your answers to my noob questions.
2 months 1 week ago #98670

Please Log in or Create an account to join the conversation.

  • Posts: 53
  • Thank you received: 22
I just noticed several things in your ASIconfig.xml.txt file

A first point which has nothing to do with the green image problem, but which could improve your images. Your offset is 0, Zwo recommends an offset of 70 for the 533

The second point that may be the cause of the green image is that the values ​​of WB_Red and WB_Blue in your file are not the same as in mine.

I just looked in the Indi dashboard. We find these values ​​under the controls tab of camera 533. I have for WB_R=52 and WB_B=95

These values ​​are recommended by Zwo (see bottom of this page www.indilib.org/ccds/zwo-optics-asi-cameras.html)



The following user(s) said Thank You: Steve Cohen
2 months 1 week ago #98671
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: Mattia
Time to create page: 0.344 seconds