×

INDI Library v1.9.3 Released (11 Nov 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

Problems. Connecting to Ioptron CEM70 C

  • Posts: 43
  • Thank you received: 0
I recently got a new mount. The Ioptron CEM 70 C. This is the USB2 version with a USB connection to the mount. I have a. RPI4 with 4 G memory with Astroberry loaded. The Astroberry was loaded around Jan of this year 2021. My previous mount was an EQ6 running EQMod. This mount connected instantly and first time to Ekos so I am surprised I am having all this trouble. My configuration is the Astroberry serves as an Indi server which connects to Kstars running on my PC. I choose the Iopron V 3 driver in the kstars Ekos configuration and CEM 70 in the Indi server. My RPI and PC are connected via ethernet on a local network. All my equipment cameras, focuser filter wheel connect to Ekos on the PC so I know am am doing something right. In the Ekos connection panel under telescope mount it lists my port as ttyUSB0. Thatdoes not work. When I scan the mount connection it recommends trying ttyACM0 but that does not work. Thats on the PC side so I am surprised The Windows interface is worried about what is happening on the RPI Raspbian side. I don’twant to just keep trying random changes Idon’t really inderstand.  Thanks Lou Zyla
2 months 1 week ago #75656

Please Log in or Create an account to join the conversation.

  • Posts: 43
  • Thank you received: 0
I did an additional quick test. I had all the USB connections as before but used the local copy of Kstars/Ekos on RPI4.I ofcourse chose the setup option that equipment was directly connected to local machine. On the Windows PC Kstars/Ekos I chose equipment connected to remote device (RPI4). This time the mount connected just fine. This tells me that the driver works just fine. I have invested a lot of setup time and downloads to configure the Windows version of Kstars/Ekos so I am not ready to switch versions of Kstars.
Lou Zyla
2 months 1 week ago #75658

Please Log in or Create an account to join the conversation.

  • Posts: 212
  • Thank you received: 14
Just a question, if you have all the setup connected to the RPI with Astroberry, why you use KStars on Windows to manage it??? For me is more usefully to use Windows or other device to connect to Astroberry via VNC or other way.
RPI 4 could be used as standalone device that manage all the stuffs.
Does not make mush sense to use Windows as client to manage all, when RPI can do this work
The following user(s) said Thank You: AstroNerd
2 months 1 week ago #75659

Please Log in or Create an account to join the conversation.

  • Posts: 43
  • Thank you received: 0
I guess thats the way I have always done it. Its all setup in terms of downloaded files for use on Windows. I still need a viewer so that would be my Windows computer so using Kstars on the RPI wouldn’t  relieve me of that. . In general I am more comfortable in the Windows environment. I also thought perhaps erroneously that using Kstars/Ekos on my Windows PC would take some of the load off my RPI4. Lou
2 months 1 week ago #75664

Please Log in or Create an account to join the conversation.

  • Posts: 43
  • Thank you received: 0
Well I am ready to give up on RPI, Kstars, Ekos, Stellarmate and Astroberry. Second time I have had connection issues. First time was with my Altair 183M. Nothing solved that problem except time. Eventually a release solved that problem. Now I can’t connect to my new Ioptron CEM70 mount. If I just use the RPI 4 Astroberry and Stellarmate connect just fine. I use my Windows machine to VNC into the RPI. However if I try to use Kstars/Ekos on my Windows PC and use the Indi server onthe RPI no connection. Not specific to Kstars/Ekos because Astrophotography Tools (APT) won’t connect either when configured to use Indi drivers. All my equipment  connects except for the a ioptron mount. if i use Apt or SGP and use Ascom on the PC everything works great. So somewhere the communication between the server on the RPI and the Windows machine breaks down. Lou
2 months 3 days ago #75945

Please Log in or Create an account to join the conversation.

  • Posts: 43
  • Thank you received: 0
Well I solved my own problem, at least in Kstars/Ekos. In the indi Control Panel under mount got to the connection tab. Select a connection speed of 115,200 and press set. The connection should then work for IoptronCEM 70. This is in Kstars/Ekos on my Windows PC. I am not sure where such a setting would be for APT.
Lou
4 days 10 hours ago #77960

Please Log in or Create an account to join the conversation.

  • Posts: 127
  • Thank you received: 24
I use a CEM70 with stellarmate on RPi4

Using driver 'ioptron v3'
In the indi tab you can set the connection baudrate. For me it worked right from the beginning, can check later today my settings.

The USB B connector in the mount gave me trouble a few times so i now soldered a usb wire into the mount (the usb port is a srperate, smaller pcb). I now have no connection issues since then.

I run all my imagimg from the Rpi and use vnc to remote operate.
Cheers! Bart
Latest Stellarmate on Rpi 4B, 294mm-pro, EFW-8, CEM70
4 days 6 hours ago #77966

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 0.766 seconds