×

INDI Library v1.9.5 Released (08 Mar 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Application windows too large for screen

  • Posts: 7
  • Thank you received: 0
Hi everyone, 
to make my telescope setup less power-consuming in the field, I recently switched to Astroberry. My plan is to use it with the 7 inch Pi Touch display. However, I am running into a problem with some of the programs such as oacapture. As you can see in the attached screenshot, its window size seems to be too large to efficiently work with it. I tried changing this using wmctrl and by editing the framebuffer_width and _height values in config.txt but nothing seems to work, I just can't force these tools to fit into the window because at least oacapture refuses to get smaller at a certain point. I think it has something to do with the font size as the oacapture window yields so much text but even if I decrease the font size to "barely readable", it still does not fit.
Has anybody else encountered this problem and found a solution (or could think of one)?

Thanks a lot in advance! 

 
7 months 2 weeks ago #76260
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 190
  • Thank you received: 37
I use the following primarily because ccdciel has the same issues, cannot see all the screen.

framebuffer_width=1280
framebuffer_height=768

I do admit to having to use a handheld magnifier to enlarge some of the text in Skychart but 95%+ of all screen info is legible to be.
Last edit: 7 months 2 weeks ago by Gene N.
7 months 2 weeks ago #76265

Please Log in or Create an account to join the conversation.

  • Posts: 190
  • Thank you received: 37
Sorry if you have already tried these larger numbers, please ignore if so.
7 months 2 weeks ago #76266

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0
Hi Gene, thanks for your reply. I played around with these values and the appearance settings a bit and I found a sweet spot where most applications windows are 100 % visible but everything is still readable so I don't have to use the magnifier that you mentioned. For oacapture it's not really working, unfortunately, so I guess for now I'll just have to find a work flow without using oacapture. However, if someone has another idea how to fix this (e.g. reducing the font size of only the oacapture window), I'm very happy to hear it.
7 months 2 weeks ago #76278

Please Log in or Create an account to join the conversation.

  • Posts: 190
  • Thank you received: 37
Hi John,

Does Settings->General->"Use separate window for controls"
Help any?

There are also these env variables used by QT
doc.qt.io/qt-5/highdpi.html

But me playing on Ubuntu, none of them made any differences on a high-dpi ubuntu laptop by changing the screen resolution to various values.
7 months 2 weeks ago #76308

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0
Unfortunately, I am unable to find this option. Is this in Astroberry? Or Ubuntu?
7 months 2 weeks ago #76316

Please Log in or Create an account to join the conversation.

  • Posts: 190
  • Thank you received: 37
Hi John,

The manual shows the option, now if removed for ARM Debian ???
www.openastroproject.org/documentation/o...e-1-5-0-user-manual/

Search for 'General' in the doc, the lowest radar button available in the page, right above the 'Display FPS' slider.

The text below the Settings description shows:
"Finally another option that may help on small displays, to split the controls off into a separate window that can be hidden behind the main preview window or minimised to get it out of the way."
The following user(s) said Thank You: John McCain
7 months 1 week ago #76330

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0
Ah, you mean in the oaCapture settings. Sorry, I thought you were speaking about the Linux settings. I'm very busy this week but I'll check it out asap.
7 months 1 week ago #76409

Please Log in or Create an account to join the conversation.

  • Posts: 7
  • Thank you received: 0
Hi,
it's been a while but I finally found some time to try your approach and it relaxes the problem a lot, thank you very much! :)
5 months 6 days ago #78560

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 1.182 seconds