×

INDI Library v1.9.5 Released (08 Mar 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

16 bit historgram or how to transfer files from Raspberry to PC Windows

  • Posts: 413
  • Thank you received: 153
There is option for controlling the histogram at Settings menu -> Configure KStars -> FITS -> non linear histogram
Remote observatory running Ubuntu 21.10 x64 with ScopeDome 2M, Skywatcher EQ8, TS 8" RC, Atik 383L+, ASI178MC, ASI120MM-S, SX Lodestar X2, SX USB wheel with OAG, ZWO EAF, Gemini SnapCap, USB_DewPoint, KomaHub
The following user(s) said Thank You: Lars
4 months 2 weeks ago #78849

Please Log in or Create an account to join the conversation.

  • Posts: 104
  • Thank you received: 5
Hi Jarno,
I tested different settings in the KStars FITS menu. I got different results. What I can see, the X-axis is still nonlinear and expressed as a 8-bit 0 to 255 levels. Above I have the raw CR2 file as a CFA format. Both X and Y are linear. I think I can use the KStars FITS histograph for a rough selection and the relation between the colors are no problems, the last check I do in Windows with some more advanced tool. It's a progress.

 

/Lars
TS130 APO & 3" field flattener / Pentax 645 ED 300mm f/4 /Sigma APO 150 mm f/2.8
EQ6 mount / HEQ5 / Star Adventurer
Canon EOS 6D
Lot of patience

Homepage:
www.astrofriend.eu/
4 months 2 weeks ago #78880
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 4
Maybe you already know, but if you need to establish exposure time to reach target ADU, you can use the "Calibrate" button that enables when you choose "Flat" for image type in capture tab.Then Ekos will automatically find correct exposure before taking your flat sequence.

Hope this helps.



 
The following user(s) said Thank You: Lars
4 months 2 weeks ago #78881
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 104
  • Thank you received: 5
@Jarno

Much better now when I changed the paameters yo told me about. But there is something wrong, the histogram doesn't update with new photos, I have to close down the histogram and FITS viewer and take a new photo to see the update.

@Matteo

Interesting, I will test that function later on

/Lars
TS130 APO & 3" field flattener / Pentax 645 ED 300mm f/4 /Sigma APO 150 mm f/2.8
EQ6 mount / HEQ5 / Star Adventurer
Canon EOS 6D
Lot of patience

Homepage:
www.astrofriend.eu/
4 months 2 weeks ago #78929

Please Log in or Create an account to join the conversation.

  • Posts: 228
  • Thank you received: 22
Lars post=78811 userid=3671
-  but the Astroberry version of VNC could not transfer files.

/Lars

Just for the record, the VNC server in Astroberry does transfer files. Click on the black VNC button in the Taskbar, and select the file transfer option from the menu list. I used this for a long period, but these days I prefer using the Samba server option by creating a network drive in Windows File Explorer which gives me simpler and consistently faster transfer connections.
Currently running KStars/Ekos/Indi on two Raspberry Pi 4Bs 4GByte under Raspberry Pi OS thanks to Astroberry
Two mounts, two Fracs, a Newt and a Mak and a couple of OSC cameras.
4 months 1 week ago #79193

Please Log in or Create an account to join the conversation.

  • Posts: 104
  • Thank you received: 5
Strange, when I ggoled on this subject one year ago I got the impression that it was very difficult. Now I ahve at least two solutions, WinSCP works very well, but I will test Astroberry VNC later.

Thanks for all information !

/Lars
TS130 APO & 3" field flattener / Pentax 645 ED 300mm f/4 /Sigma APO 150 mm f/2.8
EQ6 mount / HEQ5 / Star Adventurer
Canon EOS 6D
Lot of patience

Homepage:
www.astrofriend.eu/
4 months 6 days ago #79255

Please Log in or Create an account to join the conversation.

  • Posts: 674
  • Thank you received: 66
I noticed that something has changed with the histogram view several months ago.
I started to largely ignore the histogram and just mouse over the fits image viewer to see what the intensities are.
That's with 16bit astro camera.

Last couple of days I've been playing with a DSLR (Nikon D5500) as an imaging camera for the first time in more that a year.
Both histogram and fits viewer are totally inconsistent and wrong now (was OK a year ago I believe).
Especially when the format is set to Native (NEF in my case).
When the format is set to FITS things get better but still are a bit strange.
Max S.

RPI 4 B (4Gb) with SMate
Askar FRA400, TPO RC6, Nikon D5500 full spectrum (with IDAS clip-in filter).
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
4 months 6 days ago #79258

Please Log in or Create an account to join the conversation.

  • Posts: 104
  • Thank you received: 5
I'm not sure if I understand, do you mean you get a histogram with Fits data, 1-65550 ? My histogram is always 0-255, Canon 6D raw, CR2 files.

How to setup Fits/Histogram to that ?

See screendump:

 

/Lars
TS130 APO & 3" field flattener / Pentax 645 ED 300mm f/4 /Sigma APO 150 mm f/2.8
EQ6 mount / HEQ5 / Star Adventurer
Canon EOS 6D
Lot of patience

Homepage:
www.astrofriend.eu/
4 months 5 days ago #79267
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 674
  • Thank you received: 66
Sorry, I was confused and didn't understand what's going on...
Yes, for both FITS and NATIVE the histogram is not linear and 0-255.
With NATIVE both histogram and fits viewer are wrong
With FITS, histogram is wrong but the fits viewer shows correct intensities (14bit in my case. 0-16384).
Max S.

RPI 4 B (4Gb) with SMate
Askar FRA400, TPO RC6, Nikon D5500 full spectrum (with IDAS clip-in filter).
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
4 months 5 days ago #79282

Please Log in or Create an account to join the conversation.

  • Posts: 104
  • Thank you received: 5
Okay, then I understand better.

I save my Canon files as Native, but temporarly they must be in fits format. So what I see in the Fitsviewer is converted native files because Fitsviewer can only display fits files, or ?

/Lars
TS130 APO & 3" field flattener / Pentax 645 ED 300mm f/4 /Sigma APO 150 mm f/2.8
EQ6 mount / HEQ5 / Star Adventurer
Canon EOS 6D
Lot of patience

Homepage:
www.astrofriend.eu/
4 months 4 days ago #79300

Please Log in or Create an account to join the conversation.

  • Posts: 172
  • Thank you received: 20
With the caveat that I'm using StellarMate, not Astroberry, I certainly never see a 256-bit histogram. In the camera tab on the INDI Control Panel, is there an option for 8-bit vs. 16-bit images? For a long time my Pi kept defaulting to 8-bit and my images suffered terribly because of that! Dunno how the CR2 and FITS work together but the FITS off my ASI183, a 14-bit camera, are always 16-bit.
4 months 4 days ago #79305

Please Log in or Create an account to join the conversation.

  • Posts: 674
  • Thank you received: 66
With a dedicated astro-camera there's no problem with histogram/fits viewer.
With a DSLR there is a problem.
When it is set to NATIVE (at least in my case with D5500 and NEF format), the histogram is 8-bit and stretched all the way and is the same for say 1 sec and 10 sec exposure. Fits viewer also shows wrong intensities I believe.
When it is set to FITS things do get better. Fits viewer shows right intensities but the histogram sometimes is wrong. Sometimes it is OK.
Max S.

RPI 4 B (4Gb) with SMate
Askar FRA400, TPO RC6, Nikon D5500 full spectrum (with IDAS clip-in filter).
ASI2600MC Pro
ZWO ASI120MM Mini on ZWO 30F4
ZWO ASI224MC-S on Orion 50 mm f/3.2
ZWO EAF x 2
SW AZ-GTi
SW HEQ5
RST-135
4 months 4 days ago #79308

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 0.745 seconds