×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

KStars/EKOS crashing when imaging; Astroberry, RPi 4-4GB

  • Posts: 19
  • Thank you received: 1
I started an SGL thread about this topic and due to less daylight, etc, haven't progressed with it. Thinking it might be Astroberry related, posted the following content on Astroberry Github , and suggestion was to post here.

In short, running RPi4 4GB with astroberry installed on 128GB micro SD. I use a combination of Anydesk and VNC to access the RPi which is mounted on my mount, controlling guiding, tracking and DSLR.

Several imaging sessions have been interrupted by kstars closing shortly after closing my connection to the RPi. In effort to debug, I'd saved out the log files but didn't get round to really getting into them. Read a couple of places about memory leaks and wrote shell script to output ALL memory parameters out to text file whilst running anything else on the RPi.

As the nights are short (and weather of late not the best!), I have even used the simulator to duplicate the crashing, with log files being saved as verbose, etc.
I have enabled the FITS Limited Resouces Mode and disabled FITS viewer as had read about this possibly causing issues.

My most recent is the most detail I've had on the issue - started the imaging at ~12:30 and closed connections ~18:00. Log file ends about 30min later with:
[2022-05-16T18:28:14.871 BST DEBG ][           org.kde.kstars.indi] - Telescope Simulator : "[SCOPE] Current RA:  3:05:52 Current DEC: 90:00:00 "
[2022-05-16T18:28:14.892 BST INFO ][   org.kde.kstars.ekos.capture] - "Capturing 2.500-second Luminance image..."
At this point, the simulator has 'captured' 7652x 2.5sec exposures, just using the default settings in EKOS:

My shell script outputs memory info just before starting:
2022-05-16 12:23:54; Temp=39.4ºC. RAM 'Used': 399MB (10.5%); RAM 'Free': 2.4GB (64.7%); RAM 'Available': 3.1GB (84.4%); RAM used in Shared & Buffer: 26.0%. Swap used: 0.0%. µSD @/dev/root uses 20,178,276kB.
2022-05-16 12:23:55; Temp=39.9ºC. RAM 'Used': 399MB (10.5%); RAM 'Free': 2.4GB (64.7%); RAM 'Available': 3.1GB (84.6%); RAM used in Shared & Buffer: 26.0%. Swap used: 0.0%. µSD @/dev/root uses 20,178,276kB.
Here's memory stats just before and after crash time:
2022-05-16 18:28:02; Temp=42.3ºC. RAM 'Used': 1.2GB (31.3%); RAM 'Free': 114MB ( 3.0%); RAM 'Available': 2.4GB (63.8%); RAM used in Shared & Buffer: 66.4%. Swap used:100.0%. µSD @/dev/root uses 39,596,736kB.
2022-05-16 18:28:03; Temp=43.3ºC. RAM 'Used': 1.2GB (31.4%); RAM 'Free': 112MB ( 3.0%); RAM 'Available': 2.4GB (64.0%); RAM used in Shared & Buffer: 66.5%. Swap used:100.0%. µSD @/dev/root uses 39,596,748kB.
2022-05-16 18:28:05; Temp=41.3ºC. RAM 'Used': 1.2GB (31.4%); RAM 'Free': 112MB ( 3.0%); RAM 'Available': 2.4GB (63.9%); RAM used in Shared & Buffer: 66.5%. Swap used:100.0%. µSD @/dev/root uses 39,596,484kB.
2022-05-16 18:28:06; Temp=42.8ºC. RAM 'Used': 1.2GB (31.4%); RAM 'Free': 109MB ( 2.9%); RAM 'Available': 2.4GB (64.0%); RAM used in Shared & Buffer: 66.6%. Swap used:100.0%. µSD @/dev/root uses 39,599,312kB.
2022-05-16 18:28:08; Temp=41.8ºC. RAM 'Used': 1.2GB (31.4%); RAM 'Free': 110MB ( 2.9%); RAM 'Available': 2.4GB (64.0%); RAM used in Shared & Buffer: 66.6%. Swap used:100.0%. µSD @/dev/root uses 39,599,312kB.
2022-05-16 18:28:09; Temp=43.3ºC. RAM 'Used': 1.2GB (31.4%); RAM 'Free': 106MB ( 2.8%); RAM 'Available': 2.4GB (64.0%); RAM used in Shared & Buffer: 66.6%. Swap used:100.0%. µSD @/dev/root uses 39,601,876kB.
2022-05-16 18:28:10; Temp=41.8ºC. RAM 'Used': 1.2GB (31.4%); RAM 'Free': 106MB ( 2.8%); RAM 'Available': 2.4GB (64.0%); RAM used in Shared & Buffer: 66.6%. Swap used:100.0%. µSD @/dev/root uses 39,601,884kB.
2022-05-16 18:28:12; Temp=43.3ºC. RAM 'Used': 1.2GB (31.4%); RAM 'Free': 105MB ( 2.8%); RAM 'Available': 2.4GB (63.9%); RAM used in Shared & Buffer: 66.7%. Swap used:100.0%. µSD @/dev/root uses 39,604,444kB.
2022-05-16 18:28:13; Temp=43.3ºC. RAM 'Used': 1.2GB (31.4%); RAM 'Free': 104MB ( 2.8%); RAM 'Available': 2.4GB (64.0%); RAM used in Shared & Buffer: 66.7%. Swap used:100.0%. µSD @/dev/root uses 39,604,448kB.
2022-05-16 18:28:15; Temp=42.8ºC. RAM 'Used': 1.0GB (24.4%); RAM 'Free': 489MB (17.1%); RAM 'Available': 3.1GB (83.1%); RAM used in Shared & Buffer: 66.8%. Swap used:98.8%. µSD @/dev/root uses 39,607,008kB.
2022-05-16 18:28:16; Temp=42.3ºC. RAM 'Used': 459MB (12.1%); RAM 'Free': 847MB (22.4%); RAM 'Available': 3.1GB (83.8%); RAM used in Shared & Buffer: 65.7%. Swap used:98.8%. µSD @/dev/root uses 39,607,008kB.
2022-05-16 18:28:18; Temp=42.8ºC. RAM 'Used': 460MB (12.2%); RAM 'Free': 846MB (22.4%); RAM 'Available': 3.1GB (83.8%); RAM used in Shared & Buffer: 65.7%. Swap used:98.8%. µSD @/dev/root uses 39,607,008kB.
2022-05-16 18:28:19; Temp=42.3ºC. RAM 'Used': 461MB (12.2%); RAM 'Free': 847MB (22.4%); RAM 'Available': 3.1GB (83.8%); RAM used in Shared & Buffer: 65.7%. Swap used:98.8%. µSD @/dev/root uses 39,607,012kB.
2022-05-16 18:28:20; Temp=42.3ºC. RAM 'Used': 459MB (12.1%); RAM 'Free': 848MB (22.4%); RAM 'Available': 3.1GB (83.8%); RAM used in Shared & Buffer: 65.7%. Swap used:98.8%. µSD @/dev/root uses 39,607,012kB.
2022-05-16 18:28:22; Temp=41.8ºC. RAM 'Used': 459MB (12.1%); RAM 'Free': 848MB (22.4%); RAM 'Available': 3.1GB (83.7%); RAM used in Shared & Buffer: 65.7%. Swap used:98.8%. µSD @/dev/root uses 39,607,024kB.
2022-05-16 18:28:23; Temp=42.3ºC. RAM 'Used': 459MB (12.1%); RAM 'Free': 848MB (22.4%); RAM 'Available': 3.1GB (83.8%); RAM used in Shared & Buffer: 65.7%. Swap used:98.8%. µSD @/dev/root uses 39,607,024kB.
2022-05-16 18:28:25; Temp=41.8ºC. RAM 'Used': 458MB (12.1%); RAM 'Free': 848MB (22.4%); RAM 'Available': 3.1GB (83.8%); RAM used in Shared & Buffer: 65.7%. Swap used:98.8%. µSD @/dev/root uses 39,607,024kB.
As seen, there's virtually no memory available at the time of crash, and 100% swap used. The above results have been generated using "free" in a script outputting to txt every second. I can share if needed, but attach the log file and full output of this script in hopes that it may lead to a solution?
I'm running it again without additional things going on (had been running Conky on the RPi, but disabled it for now).

File Attachment:

File Name: log_12-24-22.txt
File Size:6,945 KB

File Attachment:

File Name: SystemLog.txt
File Size:11,214 KB

I do have to setup mount and so on to test with it as Radek has suggested on github, but wondered if I can start the ball rolling anyway by posting and running simulators again without anything else going on.
4 months 1 week ago #82937
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 1
Just found the log from the last crash when imaging so adding that - last result is a camera capture:

File Attachment:

File Name: log_20-32-...5-18.txt
File Size:226 KB
[2022-03-26T00:33:03.487 GMT INFO ][   org.kde.kstars.ekos.capture] - "Capturing 60.000-second  image..."
[2022-03-26T00:33:03.500 GMT INFO ][           org.kde.kstars.indi] - Canon DSLR EOS 550D :  "[INFO] Starting 60 seconds exposure. "

with RAM report looking like the crash appears at the end of the exposure:
2022-03-26 00:34:01, Temp=25.3ºC. RAM available: 2.4GB; RAM used: 1.1GB.
2022-03-26 00:34:02, Temp=25.8ºC. RAM available: 2.5GB; RAM used: 1.1GB.
2022-03-26 00:34:03, Temp=26.2ºC. RAM available: 2.5GB; RAM used: 1.0GB.
2022-03-26 00:34:04, Temp=25.3ºC. RAM available: 2.5GB; RAM used: 1.0GB.
2022-03-26 00:34:05, Temp=25.8ºC. RAM available: 3.1GB; RAM used: 417MB.
2022-03-26 00:34:06, Temp=26.2ºC. RAM available: 3.1GB; RAM used: 442MB.
2022-03-26 00:34:07, Temp=25.3ºC. RAM available: 3.1GB; RAM used: 429MB.
Hope this helps?
Last edit: 4 months 1 week ago by Pete Simpson. Reason: Formatting and upload initially failed
4 months 1 week ago #82938
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 76
  • Thank you received: 5
Hi Pete,

just tried the same thing on my astroberry and find a similar thing. 400 “images” and over a gig of memory is used up.

What I’ve noticed is that it’s the buffer/cache entry that appears to be increasing as free goes down. Not sure if that’s a problem or not as the system my as well use free memory as cache.

Regards

Nigel
4 months 1 week ago #82947

Please Log in or Create an account to join the conversation.

  • Posts: 186
  • Thank you received: 41
if you use basic free shell command then "free" really means totally unused memory. what you should look at is available as OS can easily free most of memory occupied by cache.
What I don't get is why swap is going up. I don't think this is memory issue but something else.

Try run "gdb kstars" then press enter "run" command and wait until kstars crash. Then use "bt" command to get backtrace and post it here.
4 months 1 week ago #82948

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 1
Thanks Nigel & Nou,
Seems like Nigel is getting similar thing - Nou, can I direct you to the updated script in the 1st post - I output all types of memory in this, or is "free" just a bad idea as output?
I'm running another session at present, where disabling Conky seems to be working "better" - it completed 10000 successful simulation images, and I've upped it to run 100k, just to see how things fare over duration.
Looking at the memory figures though, it's still using lots of Swap, which in my limited googling and understanding, seems like an issue:
*************************************************************************
**      New record of system info started at 2022-05-18, 15:10:22      **
**   Total RAM available is 3.7GB and total SWAP available is  99MB.   **
*************************************************************************
2022-05-18 15:10:26 Temp=39.4ºC. RAM 'Used': 314MB ( 8.3%); RAM 'Free': 3.0GB (82.5%); RAM 'Available': 3.2GB (86.9%); RAM used in Shared & Buffer: 10.5%. Swap used: 0.0%. µSD @/dev/root uses 39,559,852kB.
2022-05-18 15:10:28 Temp=38.4ºC. RAM 'Used': 314MB ( 8.3%); RAM 'Free': 3.1GB (82.7%); RAM 'Available': 3.2GB (87.2%); RAM used in Shared & Buffer: 10.1%. Swap used: 0.0%. µSD @/dev/root uses 39,559,852kB.
2022-05-18 15:10:30 Temp=38.4ºC. RAM 'Used': 313MB ( 8.3%); RAM 'Free': 3.1GB (82.7%); RAM 'Available': 3.2GB (87.2%); RAM used in Shared & Buffer: 10.1%. Swap used: 0.0%. µSD @/dev/root uses 39,559,852kB.
2022-05-18 15:10:32 Temp=39.4ºC. RAM 'Used': 313MB ( 8.3%); RAM 'Free': 3.1GB (82.8%); RAM 'Available': 3.2GB (87.2%); RAM used in Shared & Buffer: 10.1%. Swap used: 0.0%. µSD @/dev/root uses 39,559,852kB.
2022-05-18 15:10:34 Temp=38.4ºC. RAM 'Used': 314MB ( 8.3%); RAM 'Free': 3.1GB (82.8%); RAM 'Available': 3.2GB (87.2%); RAM used in Shared & Buffer: 10.1%. Swap used: 0.0%. µSD @/dev/root uses 39,559,852kB.
 
<Skip a few thousand output lines!>
 
2022-05-19 13:07:24 Temp=38.9ºC. RAM 'Used': 1.5GB (41.7%); RAM 'Free':  78MB ( 2.1%); RAM 'Available': 2.0GB (52.9%); RAM used in Shared & Buffer: 57.9%. Swap used:100.0%. µSD @/dev/root uses 76,427,688kB.
2022-05-19 13:07:25 Temp=38.4ºC. RAM 'Used': 1.5GB (41.7%); RAM 'Free':  76MB ( 2.2%); RAM 'Available': 2.0GB (53.1%); RAM used in Shared & Buffer: 58.0%. Swap used:100.0%. µSD @/dev/root uses 76,430,256kB.
2022-05-19 13:07:27 Temp=37.4ºC. RAM 'Used': 1.5GB (41.5%); RAM 'Free':  78MB ( 2.1%); RAM 'Available': 2.0GB (53.0%); RAM used in Shared & Buffer: 58.2%. Swap used:100.0%. µSD @/dev/root uses 76,430,260kB.
2022-05-19 13:07:29 Temp=38.4ºC. RAM 'Used': 1.5GB (41.6%); RAM 'Free':  81MB ( 2.1%); RAM 'Available': 2.0GB (52.8%); RAM used in Shared & Buffer: 57.9%. Swap used:100.0%. µSD @/dev/root uses 76,432,824kB.
I've tried to keep the syntax of 'FREE" :


A next update to the output might be to include '-w' to split buffer & shared. Obviously I switch to % too - would it be more helpful to keep all same unit (i.e. output in MB or % overall?)
Last edit: 4 months 1 week ago by Pete Simpson.
4 months 1 week ago #82950
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 186
  • Thank you received: 41
What is important is available not free. Linux just keeps any read/writen file in memory cache until it is knocked out by program allocating some memory or by other read/write operation.
You can clear this memory cache by running "echo 3 | sudo tee /proc/sys/vm/drop_cache"
4 months 1 week ago #82952

Please Log in or Create an account to join the conversation.

  • Posts: 76
  • Thank you received: 5
Hi Nou

that’s what I was getting at. The top command wasn’t showing any actual change in the memory used by kstars etc. Unfortunately I didn’t have chance to let it run to see if kstars/ekos crashed once all the memory & swap had been used up.
4 months 1 week ago #82954

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 1
Hi guys,
In effort to clear some terminology up, I've been using the 'free -h' command in the terminal (via shell script to extract ALL the memory sections that the command returns. This is then reported in the output file with the same 'fields' as the terminal window shows:
I'm hoping to update the script to output more user friendly units, probably everything as percentage of original. More on that later.
@Nou - your comment about using the basic "free" command suggests that there may be a more useful/better way of doing this? I'm not a computer guru so make things up from scratch and lots of searching to get what I need - I attach the script I am using to show what I mean here - a programmer would be sick at the variables I'm sure, but it seemed to be showing what I wanted to see (I've copied the code from shell script to text file as need this format to upload and didn't want to paste the hundred lines in here as the topic would just get foolish). Thoughts and comments welcome!

File Attachment:

File Name: SampleShell.txt
File Size:4 KB

Anyway, after further testing...
Simulator ran on 18/5, doing 10k 'images', completed successfully as noted above, although system memory "free" still decreasing throughout, including swap being used.
Final lines of log file from KStars:
[2022-05-18T23:59:49.778 BST DEBG ][           org.kde.kstars.indi] - CCD Simulator : "[DEBUG] BLOB transfer took 0.136006 seconds "
[2022-05-18T23:59:49.778 BST DEBG ][           org.kde.kstars.indi] - CCD Simulator : "[DEBUG] Upload complete "
[2022-05-18T23:59:49.811 BST INFO ][   org.kde.kstars.ekos.capture] - "Received image 10000 out of 10000."
[2022-05-18T23:59:50.294 BST DEBG ][     org.kde.kstars.ekos.guide] - Reset non guiding dithering position
[2022-05-18T23:59:50.302 BST DEBG ][   org.kde.kstars.ekos.capture] - setMeridianFlipStage:  "MF_READY"
[2022-05-18T23:59:50.302 BST DEBG ][   org.kde.kstars.ekos.capture] - All capture jobs complete.
[2022-05-18T23:59:50.325 BST DEBG ][   org.kde.kstars.ekos.capture] - setMeridianFlipStage:  "MF_READY"
[2022-05-18T23:59:50.381 BST DEBG ][                       default] - WARNING: Phonon::createPath: Cannot connect  Phonon::MediaObject ( no objectName ) to  Phonon::AudioOutput ( no objectName ).
[2022-05-18T23:59:50.391 BST DEBG ][           org.kde.kstars.indi] - Telescope Simulator : "[SCOPE] mountToApparentRaDec 90.000000, 90.000000 to ha 90.000000, ra 131.562230, 90.000000 "
[2022-05-18T23:59:50.391 BST DEBG ][           org.kde.kstars.indi] - Telescope Simulator : "[SCOPE] Current RA:  8:46:15 Current DEC: 90:00:00 "

Memory stats at this point:
2022-05-18 23:59:42 Temp=39.4ºC. RAM 'Used': 1.2GB (31.9%); RAM 'Free':  90MB ( 2.4%); RAM 'Available': 2.3GB (63.3%); RAM used in Shared & Buffer: 65.8%. Swap used:61.0%. µSD @/dev/root uses 65,207,256kB.
2022-05-18 23:59:44 Temp=38.4ºC. RAM 'Used': 1.2GB (31.9%); RAM 'Free': 115MB ( 3.0%); RAM 'Available': 2.3GB (63.5%); RAM used in Shared & Buffer: 65.8%. Swap used:61.0%. µSD @/dev/root uses 65,207,260kB.
2022-05-18 23:59:46 Temp=38.9ºC. RAM 'Used': 1.2GB (32.1%); RAM 'Free': 108MB ( 3.0%); RAM 'Available': 2.3GB (63.5%); RAM used in Shared & Buffer: 65.9%. Swap used:61.0%. µSD @/dev/root uses 65,209,820kB.
2022-05-18 23:59:47 Temp=39.4ºC. RAM 'Used': 1.2GB (31.9%); RAM 'Free': 112MB ( 3.0%); RAM 'Available': 2.3GB (63.5%); RAM used in Shared & Buffer: 65.9%. Swap used:61.0%. µSD @/dev/root uses 65,209,824kB.
2022-05-18 23:59:49 Temp=38.4ºC. RAM 'Used': 1.2GB (32.0%); RAM 'Free': 110MB ( 2.9%); RAM 'Available': 2.3GB (63.5%); RAM used in Shared & Buffer: 65.9%. Swap used:61.0%. µSD @/dev/root uses 65,212,388kB.
2022-05-18 23:59:51 Temp=38.4ºC. RAM 'Used': 1.2GB (31.9%); RAM 'Free': 105MB ( 2.8%); RAM 'Available': 2.3GB (63.5%); RAM used in Shared & Buffer: 66.1%. Swap used:61.0%. µSD @/dev/root uses 65,212,388kB.
2022-05-18 23:59:52 Temp=38.4ºC. RAM 'Used': 1.2GB (31.9%); RAM 'Free': 106MB ( 2.8%); RAM 'Available': 2.3GB (63.5%); RAM used in Shared & Buffer: 66.1%. Swap used:61.0%. µSD @/dev/root uses 65,212,392kB.
2022-05-18 23:59:54 Temp=38.4ºC. RAM 'Used': 1.2GB (31.9%); RAM 'Free': 105MB ( 2.8%); RAM 'Available': 2.3GB (63.5%); RAM used in Shared & Buffer: 66.1%. Swap used:61.0%. µSD @/dev/root uses 65,212,392kB.
2022-05-18 23:59:56 Temp=37.9ºC. RAM 'Used': 1.2GB (31.9%); RAM 'Free': 106MB ( 2.8%); RAM 'Available': 2.3GB (63.5%); RAM used in Shared & Buffer: 66.1%. Swap used:61.0%. µSD @/dev/root uses 65,212,396kB.
Still shows significant use on the FREE ram, and the Swap also.
So with this dataset completing, I started a further one, 9 hours later once I saw the results
[2022-05-19T09:01:00.692 BST DEBG ][           org.kde.kstars.indi] - Telescope Simulator : "[SCOPE] Current RA: 17:48:55 Current DEC: 90:00:00 "
[2022-05-19T09:01:00.876 BST DEBG ][           org.kde.kstars.indi] - Telescope Simulator : "[SCOPE] mountToApparentRaDec 90.000000, 90.000000 to ha 90.000000, ra -92.771706, 90.000000 "
[2022-05-19T09:01:00.877 BST DEBG ][           org.kde.kstars.indi] - Telescope Simulator : "[SCOPE] Current RA: 17:48:55 Current DEC: 90:00:00 "
[2022-05-19T09:01:01.041 BST DEBG ][           org.kde.kstars.indi] - CCD Simulator : "[DEBUG] Uploading file. Ext: bin, Size: 2621440, sendImage? Yes, saveImage? No "
[2022-05-19T09:01:01.135 BST DEBG ][           org.kde.kstars.indi] - CCD Simulator : "[DEBUG] BLOB transfer took 0.0755511 seconds "
[2022-05-19T09:01:01.136 BST DEBG ][           org.kde.kstars.indi] - CCD Simulator : "[DEBUG] Upload complete "
[2022-05-19T09:01:01.165 BST INFO ][   org.kde.kstars.ekos.capture] - "Received image 1 out of 100000."
[2022-05-19T09:01:02.250 BST DEBG ][           org.kde.kstars.indi] - Telescope Simulator : "[SCOPE] mountToApparentRaDec 90.000000, 90.000000 to ha 90.000000, ra -92.770659, 90.000000 "
[2022-05-19T09:01:02.250 BST DEBG ][           org.kde.kstars.indi] - Telescope Simulator : "[SCOPE] Current RA: 17:48:55 Current DEC: 90:00:00 "
[2022-05-19T09:01:02.281 BST INFO ][   org.kde.kstars.ekos.capture] - "Capturing 2.500-second Luminance image..."
[2022-05-19T09:01:02.860 BST DEBG ][           org.kde.kstars.indi] - Telescope Simulator : "[SCOPE] mountToApparentRaDec 90.000000, 90.000000 to ha 90.000000, ra -92.769612, 90.000000 "
Memory situation hasn't improved much over the period of not capturing images:
2022-05-19 09:00:55 Temp=37.0ºC. RAM 'Used': 1.2GB (33.1%); RAM 'Free': 116MB ( 3.1%); RAM 'Available': 2.3GB (61.1%); RAM used in Shared & Buffer: 65.5%. Swap used:61.3%. µSD @/dev/root uses 65,259,284kB.
2022-05-19 09:00:57 Temp=37.4ºC. RAM 'Used': 1.2GB (33.1%); RAM 'Free': 116MB ( 3.1%); RAM 'Available': 2.3GB (61.2%); RAM used in Shared & Buffer: 65.5%. Swap used:61.3%. µSD @/dev/root uses 65,259,284kB.
2022-05-19 09:00:59 Temp=38.4ºC. RAM 'Used': 1.2GB (33.1%); RAM 'Free': 115MB ( 3.0%); RAM 'Available': 2.3GB (61.1%); RAM used in Shared & Buffer: 65.5%. Swap used:61.3%. µSD @/dev/root uses 65,259,288kB.
2022-05-19 09:01:01 Temp=37.4ºC. RAM 'Used': 1.2GB (33.1%); RAM 'Free': 110MB ( 2.9%); RAM 'Available': 2.3GB (61.1%); RAM used in Shared & Buffer: 65.6%. Swap used:61.3%. µSD @/dev/root uses 65,261,852kB.
2022-05-19 09:01:03 Temp=37.4ºC. RAM 'Used': 1.2GB (33.1%); RAM 'Free': 112MB ( 3.0%); RAM 'Available': 2.3GB (61.1%); RAM used in Shared & Buffer: 65.6%. Swap used:61.3%. µSD @/dev/root uses 65,261,856kB.
2022-05-19 09:01:05 Temp=38.4ºC. RAM 'Used': 1.2GB (33.0%); RAM 'Free': 113MB ( 3.0%); RAM 'Available': 2.3GB (61.2%); RAM used in Shared & Buffer: 65.6%. Swap used:61.3%. µSD @/dev/root uses 65,264,416kB.
2022-05-19 09:01:06 Temp=37.9ºC. RAM 'Used': 1.2GB (33.0%); RAM 'Free': 113MB ( 3.0%); RAM 'Available': 2.3GB (61.2%); RAM used in Shared & Buffer: 65.7%. Swap used:61.3%. µSD @/dev/root uses 65,264,420kB.

A different message though at the end of the log file - things appear to freeze 6 hours later, and then ~14 hours of nothing before error reported:
[2022-05-19T15:37:25.542 BST DEBG ][           org.kde.kstars.indi] - CCD Simulator : "[DEBUG] Upload complete "
[2022-05-19T15:37:25.649 BST INFO ][   org.kde.kstars.ekos.capture] - "Received image 6867 out of 100000."
[2022-05-19T15:37:26.475 BST DEBG ][           org.kde.kstars.indi] - Telescope Simulator : "[SCOPE] mountToApparentRaDec 90.000000, 90.000000 to ha 90.000000, ra 6.602958, 90.000000 "
[2022-05-19T15:37:26.476 BST DEBG ][           org.kde.kstars.indi] - Telescope Simulator : "[SCOPE] Current RA:  0:26:25 Current DEC: 90:00:00 "
[2022-05-19T15:37:26.477 BST DEBG ][           org.kde.kstars.indi] - Telescope Simulator : "[SCOPE] mountToApparentRaDec 90.000000, 90.000000 to ha 90.000000, ra 6.604005, 90.000000 "
[2022-05-19T15:37:26.477 BST DEBG ][           org.kde.kstars.indi] - Telescope Simulator : "[SCOPE] Current RA:  0:26:25 Current DEC: 90:00:00 "
[2022-05-19T15:37:26.478 BST DEBG ][           org.kde.kstars.indi] - Telescope Simulator : "[SCOPE] mountToApparentRaDec 90.000000, 90.000000 to ha 90.000000, ra 6.605052, 90.000000 "
[2022-05-19T15:37:26.478 BST DEBG ][           org.kde.kstars.indi] - Telescope Simulator : "[SCOPE] Current RA:  0:26:25 Current DEC: 90:00:00 "
[2022-05-19T15:37:26.479 BST DEBG ][           org.kde.kstars.indi] - Telescope Simulator : "[SCOPE] mountToApparentRaDec 90.000000, 90.000000 to ha 90.000000, ra 6.606098, 90.000000 "
[2022-05-19T15:37:26.480 BST DEBG ][           org.kde.kstars.indi] - Telescope Simulator : "[SCOPE] Current RA:  0:26:25 Current DEC: 90:00:00 "
[2022-05-20T05:47:44.246 BST DEBG ][           org.kde.kstars.indi] - Telescope Simulator : "[SCOPE] mountToApparentRaDec 90.000000, 90.000000 to ha 90.000000, ra -140.237616, 90.000000 "
[2022-05-20T05:47:44.248 BST DEBG ][           org.kde.kstars.indi] - Telescope Simulator : "[SCOPE] Current RA: 14:39:03 Current DEC: 90:00:00 "
[2022-05-20T05:47:44.496 BST DEBG ][           org.kde.kstars.indi] - Telescope Simulator : "[SCOPE] mountToApparentRaDec 90.000000, 90.000000 to ha 90.000000, ra -140.236569, 90.000000 "
[2022-05-20T05:47:44.496 BST DEBG ][           org.kde.kstars.indi] - Telescope Simulator : "[SCOPE] Current RA: 14:39:03 Current DEC: 90:00:00 "
[2022-05-20T05:47:44.745 BST DEBG ][           org.kde.kstars.indi] - Telescope Simulator : "[SCOPE] mountToApparentRaDec 90.000000, 90.000000 to ha 90.000000, ra -140.235521, 90.000000 "
[2022-05-20T05:47:44.748 BST DEBG ][           org.kde.kstars.indi] - Telescope Simulator : "[SCOPE] Current RA: 14:39:03 Current DEC: 90:00:00 "
[2022-05-20T05:47:44.922 BST WARN ][                       default] - QObject::killTimer: Timers cannot be stopped from another thread
[2022-05-20T05:47:44.924 BST WARN ][                       default] - QObject::~QObject: Timers cannot be stopped from another thread

Memory at time of writing still isn't improving on the RPi:
2022-05-20 09:49:31 Temp=37.0ºC. RAM 'Used': 304MB ( 8.0%); RAM 'Free': 3.0GB (82.4%); RAM 'Available': 3.3GB (88.2%); RAM used in Shared & Buffer:  9.9%. Swap used:95.3%. µSD @/dev/root uses 82,909,640kB.

and the same generated straight from the terminal now:


I'll restart the RPi, and do again with using the "gdb kstars"

Another thought is to include in my memory script - is there a clean memory command that would help free any "unused" or "leaking memory" up? Whilst this may help, it's probably not the "best"(!) solution to this issue.
Thoughts and comments again please!
4 months 1 week ago #82970
Attachments:

Please Log in or Create an account to join the conversation.

  • Posts: 186
  • Thank you received: 41
No free command is fine. I just wanted to make sure that your log is from that free command and something else.

But that Phonon::createPath: Cannot connect remind me that there was issue with sound notification. After a while kstars process run out of available file descriptors and crashed. I am not sure if it was fixed but go and disable all sound nofitication in Kstars Settings->Notification settings.There is play triangle next to them.
4 months 1 week ago #82971

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 1
"But that Phonon::createPath: Cannot connect remind me that there was issue ..."
Dang! My original post in SGL comments on this where I say
"I'm assuming that's not one to chase down (just yet)?"

So I'm changing things over in KStars to output any notifications that originally had sounds attached to text file (for my reference), and will re-run as before and we'll see what happens. Script also being changed to output ONLY percentages rather than a mix. This will make things easier to see on the whole.
Hopefully the sound issue is the cause, fingers (and lots of cables on a mount!) crossed!
BTW, thanks @Nou :D
Last edit: 4 months 1 week ago by Pete Simpson.
4 months 1 week ago #82972

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 1
For those interested, new scripting output is a bit cleaner:
*************************************************************************
**      New record of system info started at 2022-05-20, 13:12:51      **
**   Total RAM available is 3.7GB and total SWAP available is  99MB.   **
**   Total space on micro SD card (located @/dev/root) is 116.935GB    **
*************************************************************************
2022-05-20 13:12:56 Temp=38.9ºC. RAM 'Used': 12.9%; RAM 'Free': 73.9%; RAM in Shared:  1.9%; RAM in Buffer:  1.7%; RAM in Cache: 11.5%; RAM 'Available': 81.7%. Swap used:   0.0%. µSD has 30.188% free space.
2022-05-20 13:12:57 Temp=37.0ºC. RAM 'Used': 12.9%; RAM 'Free': 73.9%; RAM in Shared:  1.9%; RAM in Buffer:  1.7%; RAM in Cache: 11.5%; RAM 'Available': 81.7%. Swap used:   0.0%. µSD has 30.188% free space.
2022-05-20 13:12:59 Temp=37.9ºC. RAM 'Used': 12.9%; RAM 'Free': 73.9%; RAM in Shared:  1.9%; RAM in Buffer:  1.7%; RAM in Cache: 11.5%; RAM 'Available': 81.8%. Swap used:   0.0%. µSD has 30.188% free space.
I'll upload the script if anyone else wants to test.
Let's see how 'muting' notifications works...
So to clean things up, I've rebooted RPi, started my script, then just running KStars - EKOS - connect - setup 100k x 2.5sec exposures, start imaging session. Nothing else is opened at startup to ensure a fair test (anydesk connection only)
Last edit: 4 months 1 week ago by Pete Simpson.
4 months 1 week ago #82973

Please Log in or Create an account to join the conversation.

  • Posts: 19
  • Thank you received: 1
Oh dear, not worked I'm afraid @Nou
*************************************************************************
**      New record of system info started at 2022-05-20, 13:22:30      **
**   Total RAM available is 3.7GB and total SWAP available is  99MB.   **
**   Total space on micro SD card (located @/dev/root) is 116.935GB    **
*************************************************************************
2022-05-20 13:22:34 Temp=38.9ºC. RAM 'Used':  8.3%; RAM 'Free': 82.5%; RAM in Shared:  1.4%; RAM in Buffer:  1.1%; RAM in Cache:  8.1%; RAM 'Available': 86.9%. Swap used:   0.0%. µSD has 51.071% free space.
2022-05-20 13:22:36 Temp=37.4ºC. RAM 'Used':  8.5%; RAM 'Free': 81.7%; RAM in Shared:  1.4%; RAM in Buffer:  1.1%; RAM in Cache:  8.6%; RAM 'Available': 86.5%. Swap used:   0.0%. µSD has 51.071% free space.
2022-05-20 13:22:38 Temp=38.4ºC. RAM 'Used':  8.8%; RAM 'Free': 81.2%; RAM in Shared:  1.4%; RAM in Buffer:  1.1%; RAM in Cache:  8.9%; RAM 'Available': 86.5%. Swap used:   0.0%. µSD has 51.071% free space.
2022-05-20 13:22:39 Temp=37.4ºC. RAM 'Used':  8.5%; RAM 'Free': 81.3%; RAM in Shared:  1.4%; RAM in Buffer:  1.1%; RAM in Cache:  9.2%; RAM 'Available': 86.8%. Swap used:   0.0%. µSD has 51.071% free space.
 
<+ 1 hour of lines cropped out>
 
2022-05-20 14:48:47 Temp=37.9ºC. RAM 'Used': 12.5%; RAM 'Free':  2.6%; RAM in Shared:  1.1%; RAM in Buffer:  1.6%; RAM in Cache: 83.4%; RAM 'Available': 82.5%. Swap used:   4.8%. µSD has 47.266% free space.
2022-05-20 14:48:48 Temp=37.9ºC. RAM 'Used': 12.6%; RAM 'Free':  2.5%; RAM in Shared:  1.1%; RAM in Buffer:  1.6%; RAM in Cache: 83.5%; RAM 'Available': 82.4%. Swap used:   4.8%. µSD has 47.264% free space.
2022-05-20 14:48:50 Temp=37.4ºC. RAM 'Used': 12.5%; RAM 'Free':  2.5%; RAM in Shared:  1.1%; RAM in Buffer:  1.6%; RAM in Cache: 83.5%; RAM 'Available': 82.4%. Swap used:   4.8%. µSD has 47.264% free space.
2022-05-20 14:48:51 Temp=37.0ºC. RAM 'Used': 12.5%; RAM 'Free':  2.3%; RAM in Shared:  1.1%; RAM in Buffer:  1.6%; RAM in Cache: 83.5%; RAM 'Available': 82.4%. Swap used:   4.8%. µSD has 47.262% free space.
2022-05-20 14:48:53 Temp=37.4ºC. RAM 'Used': 12.5%; RAM 'Free':  2.4%; RAM in Shared:  1.1%; RAM in Buffer:  1.6%; RAM in Cache: 83.5%; RAM 'Available': 82.4%. Swap used:   4.8%. µSD has 47.262% free space.

Swap getting used too. Interestingly, the micro SD card has 30% free before the restart, and then has 50% - I've not deleted any of the simulation *.bin files. I've done a cleanup so the next report should look a little cleaner (shorter lines, so no wrapping when displaying here, or that may just be my settings)
Nigel reported seeing the buffer/cache increasing as free decreases - this also agrees.
So some way to clean out the cache on the fly" might help get around the issue (although it would obviously be better solving it). Anyone want to throw in $0.02?!
Last edit: 4 months 1 week ago by Pete Simpson.
4 months 1 week ago #82975

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 1.605 seconds