×

INDI Library v1.9.8 Released (29 Sep 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Device(s) not seen when running Ekos locally and INDI server remotely

  • Posts: 20
  • Thank you received: 0
When I set up my RPi to run both ekos and indi, it works pretty well ... most of the time (I'll get to that).
When I try to run Ekos on my laptop and connect to indi on the astroberry RPi, it always fails to recognize at least one device.
Often, it will be one of the two cameras, either the main ccd or the guide camera.
Sometimes, Ekos will report that it simply couldn't find one of the devices. Other times, there is an error message to the effect that a USB port was either not found, or in use by another device.

So I suspect this has more to do with USB and less with indi. I'm running a Pegasus Powerbox to supply power to the mount and all the devices, including the Pi. I currently have the cameras and the mount USB connections going to the powerbox.

After shutting down the remote Ekos session, if I try to restart the local Ekos on the RPi, it gets very confused and cannot find two or more devices. I have been resorting to shutting down the Pi, and powering down the entire system, to somehow "clear" the error state.

How can I debug this? Does INDI keep some cache of the usb ports it used the last time a session started? Or is this more an issue at the OS level? I've also noticed that the devices are very finicky about establishing usb connections depending on when you physically connect them. What's the best sequence? Connect everything while power is off, then power up the hub, and then the Pi?

Thanks
Last edit: 3 months 1 week ago by Wes Mitchell.
3 months 1 week ago #85662

Please Log in or Create an account to join the conversation.

  • Posts: 1014
  • Thank you received: 302
It sounds like a hardware problem. For debugging purposes, try to call
indi_getprop -h <RPi-Address>

This should list all devices visible on your astroberry.

A second approach would be starting the indiserver on the astroberry manually with the "-v" option (or -vv or -vvv for being more verbose).

HTH
Wolfgang
TSA-120 + FSQ-85 + ONTC 10"F4 Newton (+ epsilon-160 on Japan trip) | Avalon Linear + M-zero | ASI 1600mm pro + 6200mm pro | KStars/INDI on Raspberry Pi 4/Intel NUC
3 months 1 week ago #85670

Please Log in or Create an account to join the conversation.

  • Posts: 20
  • Thank you received: 0
Interesting .... if I start with astroberry, no kstars, start indi_server through the web manager, I get:
astroberry@astroberry:~ $ ps -ef | grep indi
astrobe+ 1079 1 0 10:21 ? 00:00:01 /usr/bin/python3 /var/www/indiwebmanager/main.py -v -l /var/log/astroberry/indiwebmanager.log
astrobe+ 4744 1 0 10:41 ? 00:00:00 indiserver -p 7624 -m 100 -v -f /tmp/indiFIFO
astrobe+ 4746 4744 0 10:41 ? 00:00:00 indi_skysafari
astrobe+ 4748 4744 0 10:41 ? 00:00:00 indi_pegasus_upb
astrobe+ 4750 4744 0 10:41 ? 00:00:00 indi_asi_single_ccd
astrobe+ 4752 4744 0 10:41 ? 00:00:00 indi_asi_single_ccd
astrobe+ 4754 4744 0 10:41 ? 00:00:00 indi_ioptronv3_telescope
astrobe+ 7442 2121 0 10:54 pts/1 00:00:00 grep --color=auto indi
astroberry@astroberry:~ $ indi_getprop | grep ASI120
ZWO ASI183MC Pro.CAMERAS_LIST.ZWO ASI120MM-S=Off
ZWO ASI183MC Pro.CAMERAS_LIST.ZWO ASI120MM-S=Off

Note two asi_single_ccd processes running, but the ASI120MM-S isn't showing up. The properties for the ASI183 showed up TWICE:
ZWO ASI183MC Pro.CONNECTION.CONNECT=Off
ZWO ASI183MC Pro.CONNECTION.DISCONNECT=On
ZWO ASI183MC Pro.DRIVER_INFO.DRIVER_NAME=ZWO Camera
ZWO ASI183MC Pro.DRIVER_INFO.DRIVER_EXEC=indi_asi_single_ccd
ZWO ASI183MC Pro.DRIVER_INFO.DRIVER_VERSION=2.0
ZWO ASI183MC Pro.DRIVER_INFO.DRIVER_INTERFACE=2
ZWO ASI183MC Pro.POLLING_PERIOD.PERIOD_MS=1000
ZWO ASI183MC Pro.DEBUG.ENABLE=Off
ZWO ASI183MC Pro.DEBUG.DISABLE=On
ZWO ASI183MC Pro.SIMULATION.ENABLE=Off
ZWO ASI183MC Pro.SIMULATION.DISABLE=On
ZWO ASI183MC Pro.CONFIG_PROCESS.CONFIG_LOAD=Off
ZWO ASI183MC Pro.CONFIG_PROCESS.CONFIG_SAVE=Off
ZWO ASI183MC Pro.CONFIG_PROCESS.CONFIG_DEFAULT=Off
ZWO ASI183MC Pro.CONFIG_PROCESS.CONFIG_PURGE=Off
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_TELESCOPE=iOptron GEM28
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_ROTATOR=Rotator Simulator
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_FOCUSER=Focuser Simulator
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_FILTER=
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_SKYQUALITY=SQM
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_TELESCOPE=iOptron GEM28
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_ROTATOR=Rotator Simulator
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_FOCUSER=Focuser Simulator
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_FILTER=
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_SKYQUALITY=SQM
ZWO ASI183MC Pro.CAMERAS_LIST.ZWO ASI183MC Pro=On
ZWO ASI183MC Pro.CAMERAS_LIST.ZWO ASI120MM-S=Off
ZWO ASI183MC Pro.CONNECTION.CONNECT=Off
ZWO ASI183MC Pro.CONNECTION.DISCONNECT=On
ZWO ASI183MC Pro.DRIVER_INFO.DRIVER_NAME=ZWO Camera
ZWO ASI183MC Pro.DRIVER_INFO.DRIVER_EXEC=indi_asi_single_ccd
ZWO ASI183MC Pro.DRIVER_INFO.DRIVER_VERSION=2.0
ZWO ASI183MC Pro.DRIVER_INFO.DRIVER_INTERFACE=2
ZWO ASI183MC Pro.POLLING_PERIOD.PERIOD_MS=1000
ZWO ASI183MC Pro.DEBUG.ENABLE=Off
ZWO ASI183MC Pro.DEBUG.DISABLE=On
ZWO ASI183MC Pro.SIMULATION.ENABLE=Off
ZWO ASI183MC Pro.SIMULATION.DISABLE=On
ZWO ASI183MC Pro.CONFIG_PROCESS.CONFIG_LOAD=Off
ZWO ASI183MC Pro.CONFIG_PROCESS.CONFIG_SAVE=Off
ZWO ASI183MC Pro.CONFIG_PROCESS.CONFIG_DEFAULT=Off
ZWO ASI183MC Pro.CONFIG_PROCESS.CONFIG_PURGE=Off
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_TELESCOPE=iOptron GEM28
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_ROTATOR=Rotator Simulator
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_FOCUSER=Focuser Simulator
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_FILTER=
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_SKYQUALITY=SQM
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_TELESCOPE=iOptron GEM28
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_ROTATOR=Rotator Simulator
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_FOCUSER=Focuser Simulator
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_FILTER=
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_SKYQUALITY=SQM
ZWO ASI183MC Pro.CAMERAS_LIST.ZWO ASI183MC Pro=On
ZWO ASI183MC Pro.CAMERAS_LIST.ZWO ASI120MM-S=Off

Does this mean that both indi_asi_single_ccd processes are both talking to the ASI183?

After I start kstars on the astroberry, and start Ekos with the local equipment profile, the duplicate profile elements disappear, and the profile elements for the ASI120 are, I assume, correct:

ZWO ASI183MC Pro.CONNECTION.CONNECT=Off
ZWO ASI183MC Pro.CONNECTION.DISCONNECT=On
ZWO ASI183MC Pro.DRIVER_INFO.DRIVER_NAME=ZWO Camera
ZWO ASI183MC Pro.DRIVER_INFO.DRIVER_EXEC=indi_asi_single_ccd
ZWO ASI183MC Pro.DRIVER_INFO.DRIVER_VERSION=2.0
ZWO ASI183MC Pro.DRIVER_INFO.DRIVER_INTERFACE=2
ZWO ASI183MC Pro.POLLING_PERIOD.PERIOD_MS=1000
ZWO ASI183MC Pro.DEBUG.ENABLE=Off
ZWO ASI183MC Pro.DEBUG.DISABLE=On
ZWO ASI183MC Pro.SIMULATION.ENABLE=Off
ZWO ASI183MC Pro.SIMULATION.DISABLE=On
ZWO ASI183MC Pro.CONFIG_PROCESS.CONFIG_LOAD=Off
ZWO ASI183MC Pro.CONFIG_PROCESS.CONFIG_SAVE=Off
ZWO ASI183MC Pro.CONFIG_PROCESS.CONFIG_DEFAULT=Off
ZWO ASI183MC Pro.CONFIG_PROCESS.CONFIG_PURGE=Off
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_TELESCOPE=iOptron GEM28
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_ROTATOR=Rotator Simulator
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_FOCUSER=Focuser Simulator
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_FILTER=
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_SKYQUALITY=SQM
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_TELESCOPE=iOptron GEM28
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_ROTATOR=Rotator Simulator
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_FOCUSER=Focuser Simulator
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_FILTER=
ZWO ASI183MC Pro.ACTIVE_DEVICES.ACTIVE_SKYQUALITY=SQM
ZWO ASI183MC Pro.CAMERAS_LIST.ZWO ASI183MC Pro=On
ZWO ASI183MC Pro.CAMERAS_LIST.ZWO ASI120MM-S=Off
ZWO ASI120MM-S.CONNECTION.CONNECT=Off
ZWO ASI120MM-S.CONNECTION.DISCONNECT=On
ZWO ASI120MM-S.DRIVER_INFO.DRIVER_NAME=ZWO Camera
ZWO ASI120MM-S.DRIVER_INFO.DRIVER_EXEC=indi_asi_single_ccd
ZWO ASI120MM-S.DRIVER_INFO.DRIVER_VERSION=2.0
ZWO ASI120MM-S.DRIVER_INFO.DRIVER_INTERFACE=6
ZWO ASI120MM-S.POLLING_PERIOD.PERIOD_MS=1000
ZWO ASI120MM-S.DEBUG.ENABLE=Off
ZWO ASI120MM-S.DEBUG.DISABLE=On
ZWO ASI120MM-S.SIMULATION.ENABLE=Off
ZWO ASI120MM-S.SIMULATION.DISABLE=On
ZWO ASI120MM-S.CONFIG_PROCESS.CONFIG_LOAD=Off
ZWO ASI120MM-S.CONFIG_PROCESS.CONFIG_SAVE=Off
ZWO ASI120MM-S.CONFIG_PROCESS.CONFIG_DEFAULT=Off
ZWO ASI120MM-S.CONFIG_PROCESS.CONFIG_PURGE=Off
ZWO ASI120MM-S.ACTIVE_DEVICES.ACTIVE_TELESCOPE=iOptron GEM28
ZWO ASI120MM-S.ACTIVE_DEVICES.ACTIVE_ROTATOR=Rotator Simulator
ZWO ASI120MM-S.ACTIVE_DEVICES.ACTIVE_FOCUSER=Focuser Simulator
ZWO ASI120MM-S.ACTIVE_DEVICES.ACTIVE_FILTER=CCD Simulator
ZWO ASI120MM-S.ACTIVE_DEVICES.ACTIVE_SKYQUALITY=SQM
ZWO ASI120MM-S.ACTIVE_DEVICES.ACTIVE_TELESCOPE=iOptron GEM28
ZWO ASI120MM-S.ACTIVE_DEVICES.ACTIVE_ROTATOR=Rotator Simulator
ZWO ASI120MM-S.ACTIVE_DEVICES.ACTIVE_FOCUSER=Focuser Simulator
ZWO ASI120MM-S.ACTIVE_DEVICES.ACTIVE_FILTER=CCD Simulator
ZWO ASI120MM-S.ACTIVE_DEVICES.ACTIVE_SKYQUALITY=SQM
ZWO ASI120MM-S.CAMERAS_LIST.ZWO ASI183MC Pro=Off
ZWO ASI120MM-S.CAMERAS_LIST.ZWO ASI120MM-S=On

I still see several duplicated properties though. Seems like this is a potential problem. How do I clean this up? How do I get the asi_single_ccd processes talking to the correct devices?

Thanks
Wes
3 months 1 week ago #85691

Please Log in or Create an account to join the conversation.

  • Posts: 1014
  • Thank you received: 302
Hi Wes,
is there a reason that you are using indi_asi_single_ccd? I'm always using indi_asi_ccd even if I have two ASI cameras attached.
Wolfgang
TSA-120 + FSQ-85 + ONTC 10"F4 Newton (+ epsilon-160 on Japan trip) | Avalon Linear + M-zero | ASI 1600mm pro + 6200mm pro | KStars/INDI on Raspberry Pi 4/Intel NUC
3 months 1 week ago #85694

Please Log in or Create an account to join the conversation.

  • Posts: 20
  • Thank you received: 0
Hi Wolfgang,

That was what was designated by default when I set up the kstars profile on the astroberry. Should I change it to use the other driver?

Wes
3 months 1 week ago #85706

Please Log in or Create an account to join the conversation.

  • Posts: 20
  • Thank you received: 0
Hi,

A quick note: I set up a profile just using Zwo CCD for the main camera, and leaving the guide camera blank. The guide connects to the main via USB, both are Zwo.
So far, it's working very well, either locally from the RPi, or remotely from kstars on my Mac.
3 months 5 days ago #85813

Please Log in or Create an account to join the conversation.

  • Posts: 2
  • Thank you received: 0
Hi Wes,

From a completely newbie:

I'm having the same nightmare trying to recognize at the sametime both ASI1600MM and ASI462MC for guiding, connected both to same powered USB 3.0 HUB. If connected individually, ASI1600 is recognized by Ekos connecting through indiserver (only one ZWO COM driver with same default executable file indi_asi_single_ccd); while asi462MC sometimes connect some others don't.

I am even so desperate as to pull some github code for new driver asi_ccd (from here: github.com/indilib/indi-3rdparty/tree/master/indi-asi) and try to compile it. Thinking outloud, this branch's description would definetively help me by associating driver with serial number for the specific camera so they do not get entangled.

RPI's OS nicely detects both cameras as 'lsusb -v' comand lists, so my amateur's though is that the problem could be in indiserver and drivers selected for ZWOs cams (or even in the fifo pipeline defined) I also tried running a different indiserver (only for guiding cam) with different ports/pipeline etc and id did not work.

Anyway, Could you please tell me if you could guide normally (guider cam connected through main camera) and all options of main and guider cam works independently?

Many thanks and clear skies!
3 months 4 days ago #85841

Please Log in or Create an account to join the conversation.

  • Posts: 918
  • Thank you received: 430
I would use the basic asi_ccd driver (found under ZWO -> ZWO CCD) driver for both cameras (as opposed to the asi_single_ccd driver). I believe it will just work out-of-the-box, labeling each camera by its model name, e.g. something like ZWO CCD ASI 1600 MM, and ZWO CCD ASI 462 MC, or something like that. I've done that many times with the ASI1600MM and the ASI 294MC.

BTW, It can get more complicated if you have the same camera model for both imaging and guiding--one will be labeled 1 and the other 2, I think, and I don't think it's deterministic which gets a 1 and which 2. I switched to both imaging and guiding with ASI1600s. Since they are not interchangable (one is connected to the filter-wheel and one not), this can be a problem. Because of that, in the recent pre-release software, I added the ability in the asi_ccd driver to nickname ZWO cameras, and the nicknames are tied to their serial numbers, just as you suggest. (Not all ZWO cameras reveal their serial numbers over the ASI API, but many do, so it only works for those cameras).

FWIW, my experience with all of the above is only with local ekos and local INDI, but the device naming really only happens on the INDI server, so I'm not sure why local/remote would matter.
Hy
AP1100 & Orion Atlas Pro, WO/ZS105 w/Moonlight V2 focus, GSO RC10 w/RSF focus
ZWO ASI1600, Astronomik Filters, ST80, QHY 5L-IIm.
KStars/Ekos/Indi on NUC10 & RPi4 w/SSD -- Ubuntu
Projects: Greedy Scheduler, Terrain, Polar Align, Analyze, Linear Focuser, SEP MultiStar & GPG Guide, FITS autostretch.
3 months 4 days ago #85861

Please Log in or Create an account to join the conversation.

  • Posts: 20
  • Thank you received: 0
Using the configuration in my last reply, I am able to independently control both ASI cameras now, no problems connecting. I've taken various test shots, played with gain, etc. I haven't had any clear nights to try guiding yet, but I'm hopeful that since the 120MM-S can be told to capture photos, then that should be enough.

Hardware: ASI183MC main camera, ASI120MM guide camera.
USB3 port on main wired to USB3 port on Pegasus powerbox
USB3 port on guide wired to USB2 port (!) on main, per ZWO recommendation
Pegasus communicates with astroberry via USB3-USB3 connection.

For the ekos profile, I have only
CCD: ZWO CCD
no entry for guide camera.

Indi seems to want to pick up the guide camera from the main, also somewhere in ZWO or ekos documentation? Not sure.
This profile causes the main camera to use the indi_asi_ccd process, and I think the guide uses it also. I think I was getting some kind of conflicts, maybe at usb bus level, when I had a profile with zwo camera 1 and zwo camera 2, as each one was associated with the indi_asi_single_ccd process..... But all this is speculation, based upon trying a lot of different combinations.

HTH
Wes
Last edit: 3 months 4 days ago by Wes Mitchell. Reason: clarify usb connections
3 months 4 days ago #85862

Please Log in or Create an account to join the conversation.

  • Posts: 2
  • Thank you received: 0
Hi!

For the sake of closing my reported issues with ASI1600 & AS462MC as guider...

Yesterday I was able to nicely have indiserver recognize both cams at the same time connected to a feeded HUB and HUB to RPi4's indiserver.

I IMG-toasted a new SD card and started configuring everything from scracth. I'll move to SDD shortly and see what happens (speed x 8 !!) I also used "aliasses" for cameras.

At least now I have an working SD with Astroberry 2.0.4 and a lowenergy-consuming-PC W10 with Kstars/Ekos 3.6.0 connecting to RPi4.

Cheers & clear skies!

Jason
3 months 1 day ago #85941

Please Log in or Create an account to join the conversation.

Moderators: Radek Kaczorek
Time to create page: 1.293 seconds