×
INDI Library v1.8.1 Released (09 Sep 2019)

Monthly maintenance release INDI v1.8.1

Astroberry Server

1 year 4 months ago
theboz
Fresh Boarder
Fresh Boarder
Posts: 1
More
Astroberry Server #25641
Hello to everyone.
Many thanks to Kaczorek for the great job!!!

I have the same problem of mccarthy.bsm: Raspberry Pi 3B+, Ubuntu Mate 16.04 and get the multi-color screen.

Do you know if there is a workaround or even when Ubuntu Mate will support Raspberry Pi 3B+?

Thanks very much!!
The topic has been locked.
1 year 4 months ago 1 year 4 months ago by uzelessknowledge.
uzelessknowledge
Junior Boarder
Junior Boarder
Posts: 34
More
Astroberry Server #26025
Hello all. I'm wanting to set up an RPi so I can sit inside and remotely image. I have a Pi3 running Stretch. Using Indi I can control my EQMod mount and either DSLR or ASI224MC. I came across this as it seems like a good option too. I've flashed the SD and was up and running in no time. I have some questions though.
1. How can I change the language. The date is not in English. I've changed all the usual settings I know how and can't get it to change.
Edit: After a shutdown and fresh start it changed. Weird it wasn't changing after a roboot.
2. If using this in the field how will the system know the correct time and how will Kstars know since it's not connected to the internet?
3. I can't connect from my iPhone. After entering the password it just says failed to connect. I can connect to the hotspot of astroberry, but can’t log in.
4. How do you update since not connected to the internet?

Thanks
The topic has been locked.
1 year 4 months ago
phomer60
Gold Boarder
Gold Boarder
Posts: 166
More
Astroberry Server #26038
uzelessknowledge,
2 and 4) You can connect to a wireless hotspot, like your iPhone, and it will update automatically.
or 2) manually set the time in Unix using the following command
sudo date -s “dd mmm yyyy HH:MM:SS”
You should be able to VNC to the Raspberry Pi but you will need to install a VNC program on your phone.
Paul
The topic has been locked.
1 year 4 months ago
uzelessknowledge
Junior Boarder
Junior Boarder
Posts: 34
More
Astroberry Server #26039

phomer60 wrote: uzelessknowledge,
2 and 4) You can connect to a wireless hotspot, like your iPhone, and it will update automatically.

Paul

Thank you Paul. I must be doing something wrong. I tried to connect it to my home WiFi and I can’t. When I open the network GUI I have no networks available and only have a place to enter a password. When I try via command line it fails. I have Stretch that I configured, same PI different SD card, and I can connect to the WiFi fine.
Does it have something to do with the auto configured VAP? Can there be a VAP and it connect to WiFi at the same time?







Travis
The topic has been locked.
1 year 4 months ago
HelgeMK
Gold Boarder
Gold Boarder
Posts: 303
Karma: 1
More
Astroberry Server #26044
Hi Travis,

See instructions on github.com/rkaczorek/astroberry-server

There is a dedicated command, which is wlanconf.

Personally I use the Ethernet cable only, from my experience, the wlan set up interferes with the hotspot.

Best, Helge
The topic has been locked.
1 year 4 months ago
uzelessknowledge
Junior Boarder
Junior Boarder
Posts: 34
More
Astroberry Server #26047

HelgeMK wrote: Hi Travis,

See instructions on github.com/rkaczorek/astroberry-server

There is a dedicated command, which is wlanconf.

Personally I use the Ethernet cable only, from my experience, the wlan set up interferes with the hotspot.

Best, Helge


Hey Helge. I was and that is what I tried in the one screen shot. Unless I’m doing it wrong.
I wondered if it would interfere. Bummer.

I tried an Edimax usb WiFi adapter, but still couldn’t get it to work.



Travis
The topic has been locked.
1 year 4 months ago
HelgeMK
Gold Boarder
Gold Boarder
Posts: 303
Karma: 1
More
Astroberry Server #26050
Sorry, I was too fast with my response, ignored the second screenshot. The WiFi stick should not be necessary. Did you make any changes to the wlan config files? Sometimes creating a fresh image can help. With the mentioned command I never had any issues to connect.
The topic has been locked.
1 year 4 months ago
phomer60
Gold Boarder
Gold Boarder
Posts: 166
More
Astroberry Server #26051
Travis,
It is not clear to me which Raspberry Pi you have. Only the Raspberry Pi 3 models and the Zero W model have built in WiFi.
Also what distribution are you using, Raspbian supports the most recent 3+ but others may not.
If it has wifi then it is most likely not compatible with the hardware.
You should be able to connect to the network router with an Ethernet cable, which would be a good starting point to confirm that networking is functional.
Paul
The topic has been locked.
1 year 4 months ago
uzelessknowledge
Junior Boarder
Junior Boarder
Posts: 34
More
Astroberry Server #26053

phomer60 wrote: Travis,
It is not clear to me which Raspberry Pi you have. Only the Raspberry Pi 3 models and the Zero W model have built in WiFi.
Also what distribution are you using, Raspbian supports the most recent 3+ but others may not.
If it has wifi then it is most likely not compatible with the hardware.
You should be able to connect to the network router with an Ethernet cable, which would be a good starting point to confirm that networking is functional.
Paul

I have a Pi3 model B as printed on the board. It does have WiFi on board. I know the WiFi is working because the hotspot is created and I can connect to the hotspot from my computer.
I’m using the image provided by Astroberry that is Ubuntu Mate.
I’ll try the suggestion of using an Ethernet cable.

HelgeMK wrote: Sorry, I was too fast with my response, ignored the second screenshot. The WiFi stick should not be necessary. Did you make any changes to the wlan config files? Sometimes creating a fresh image can help. With the mentioned command I never had any issues to connect.

I did not change any files. Thought about the fresh image and tried that as well. I know the WiFi is working because the hotspot is created and I can connect to the hotspot from my computer.





Travis
The topic has been locked.
1 year 4 months ago
uzelessknowledge
Junior Boarder
Junior Boarder
Posts: 34
More
Astroberry Server #26066
Here is my pi.




Travis
The topic has been locked.
1 year 4 months ago
uzelessknowledge
Junior Boarder
Junior Boarder
Posts: 34
More
Astroberry Server #26067
Update: I started with a brand new SD card and a fresh download of the image. First thing I tried was to update and it failed. Couldn’t access temp.
I connected Ethernet and was able to connect to my network. Ran update and upgrade with success.
Ran wlanconf and it failed.
Ran wlanconf-GUI and had no options.
Ran wlanconf and it succeeded! Don’t understand why but it did. I’m now connected wireless to my network and can still connect wirelessly to astroberry.

Now to connect the mount and camera and see if it still works.



Travis
The topic has been locked.
1 year 3 months ago
Bonito
Fresh Boarder
Fresh Boarder
Posts: 1
More
Astroberry Server #26318
Hi Kaczorek,
what do u thinking about update astroberry to indi library 1.7.0 ?

Adn if possible how make itTanks
Pasquito
The topic has been locked.
Moderators: Kaczorek
Time to create page: 1.336 seconds