×

INDI Library v1.8.0 is Released (27 Jul 2019)

INDI Library v1.8.0 is mostly a maintenance release to fix a few bugs in several drivers.

Astroberry Server

  • Posts: 2
  • Thank you received: 1

Replied by rafacastill0 on topic Astroberry Server

Hi! I've just started to test Astroberry in Raspberi pi 3 b+.
It's great! I have test ok almost my whole configuration: sbig + eqmod mount.
But I've a problem with qhy5 detection.

sudo qhy_ccd_test reports no qhyccd connected.

astroberry@astroberry:~$ uname -a
Linux astroberry.local 4.14.78-v7+ #1156 SMP Tue Oct 23 14:34:39 BST 2018 armv7l armv7l armv7l GNU/Linux
astroberry@astroberry:~$ sudo qhy_ccd_test
[sudo] password for astroberry:
QHY Test CCD using SingleFrameMode, Version: 1.00
QHYCCD | qhyccd.cpp | InitQHYCCDResource | START
QHYCCD | qhyccd.cpp | InitQHYCCDResource | END
SDK resources initialized.
ScanQHYCCD
QHYCCD | QHYCCD.CPP SCANQHYCCD | start
ScanQHYCCD numdev=0
QHYCCD | QHYCCD.CPP ScanQHYCCD | finished. Return nid=0
No QHYCCD camera found, please check USB or power.

Any idea? Could I force ccd connection?

Regards, and Thanks in advance.
Rafa.
Last edit: 8 months 1 day ago by rafacastill0.
8 months 1 day ago #32650
The topic has been locked.
  • Posts: 2
  • Thank you received: 1

Replied by rafacastill0 on topic Astroberry Server

Hi, finally it's fixed!
There was a problem with /lib/udev/rules.d.
I've added a line with the lsusb command result.
This topics opened my eyes: indilib.org/forum/ccds-dslrs/217-qhy5-indi-driver.html
Regards,
Rafa.
The following user(s) said Thank You: Kaczorek
7 months 4 weeks ago #32719
The topic has been locked.
  • Posts: 2
  • Thank you received: 0

Replied by Ludo on topic Astroberry Server

Hi,
I’m a new user of astroberry.
I have been ‘designed’ a box with big Li-Fe battery 12V and all-in-one connectors to provide energy to all devices (apn, raspberry Pi 3, motors). With a little telescope 150x750, this set-up is very light and simple to move.
Thanks for Astroberry !
But i have some troubles. I don’t find solution on this website :
1) when i connect 1 time on my personnal Network (wifi), the vpa did not start even if my personnal box is switch off. I do not find simple solution to ´suppress’ or forget this wifi connection and the vpa do not start. Have you got a solution or i have to modify several files (vap_conveniant (?), wlan_config...) ?
I want to connect on my wifi to be able to update software...
2) I find the way to change language and time format but if i modify the date and time, it restart at 2016/02/11 each time i reboot. Nether the graphical interface nor the command Sudo timedatectl... operate.
Have you got a solution ?
Thank you for Astroberry
7 months 2 weeks ago #33086
The topic has been locked.
  • Posts: 632
  • Karma: 6
  • Thank you received: 244

Replied by Kaczorek on topic Astroberry Server

Ludo wrote: 1) when i connect 1 time on my personnal Network (wifi), the vpa did not start even if my personnal box is switch off. I do not find simple solution to ´suppress’ or forget this wifi connection and the vpa do not start. Have you got a solution or i have to modify several files (vap_conveniant (?), wlan_config...) ? I want to connect on my wifi to be able to update software...


To forget all existing wifi connections you can just remove the wpa_supplicant.conf file:
sudo rm -rf /etc/wpa_supplicant/wpa_supplicant.conf

or edit it if you want to remove specific network:
sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

Regarding Virtual Access Point (VAP) - there has been a problem with a script recognizing RPi version in the initial release. It is already fixed in the latest system image, so you can either redownload the image and reflash the SD card or replace the script with the latest one:
wget https://github.com/rkaczorek/astroberry-server/blob/master/scripts/astroberry_vap
sudo mv astroberry_vap /usr/local/bin/astroberry_vap

If you don't see VAP it might also mean that your PC does not support wireless AC mode (default for RPi 3B+)
In such a case see the last question and answer in FAQ

Ludo wrote: 2) I find the way to change language and time format but if i modify the date and time, it restart at 2016/02/11 each time i reboot. Nether the graphical interface nor the command Sudo timedatectl... operate.


You can change all the regional settings in a regular way by entering system settings and choosing your locale.
RPi does not have a real time clock (RTC) so it get the current time from the Internet. If after a few minutes from starting the system the time and date is not updated automatically, you are probably not connected to the Internet. In such a case you can set the time manually with timedatectl. Just make sure you disable NTP before by running: sudo timedatectl set-ntp 0

Happy New Year!
--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM
The following user(s) said Thank You: Ludo
Last edit: 7 months 1 week ago by Kaczorek.
7 months 2 weeks ago #33116
The topic has been locked.
  • Posts: 26
  • Thank you received: 2

Replied by astronometria on topic Astroberry Server

I had problem with creating acess point too ( I dont know if I had old version) .
I fix the problem by creating access point in command line with the nmcli command. I followed how to do on google
7 months 2 weeks ago #33121
The topic has been locked.
  • Posts: 2
  • Thank you received: 0

Replied by Ludo on topic Astroberry Server

Thank you for your reply. I’ll check if i have the last version of this file.
Happy new year !
Bonne année !
7 months 2 weeks ago #33133
The topic has been locked.
  • Posts: 5
  • Thank you received: 0

Replied by Ganymed on topic Astroberry Server

Hi,

I am planning to use Astroberry and have a few questions.:)
I want to control my mount using an EQDIR cable or an EQDIR Bluetooth adapter. Both are bypassing the hand control of the mount which is a Skywatcher NEQ6 Pro.
I am currently using either an EQDIR cable or an EQDIR Bluetooth connection and EQMOD on a Windows 10 notebook to perform this.
It is more important that the EQDIR cable works as Astroberry will be attached to mount anyway. The control is planned with an Android tablet.

I am also using a Bluetooth Gamepad to control the mount moves manually (i.e. for star alignment). Will this work as well?
7 months 1 week ago #33426
The topic has been locked.
  • Posts: 36
  • Thank you received: 1

Replied by Avocette on topic Astroberry Server

My Linux is pretty woolly but I shall pursue your suggestions and see what I learn....
7 months 1 week ago #33467
The topic has been locked.
  • Posts: 632
  • Karma: 6
  • Thank you received: 244

Replied by Kaczorek on topic Astroberry Server

Ganymed wrote: Hi,

I am planning to use Astroberry and have a few questions.:)
I want to control my mount using an EQDIR cable or an EQDIR Bluetooth adapter. Both are bypassing the hand control of the mount which is a Skywatcher NEQ6 Pro.
I am currently using either an EQDIR cable or an EQDIR Bluetooth connection and EQMOD on a Windows 10 notebook to perform this.
It is more important that the EQDIR cable works as Astroberry will be attached to mount anyway. The control is planned with an Android tablet.

I am also using a Bluetooth Gamepad to control the mount moves manually (i.e. for star alignment). Will this work as well?


Hi, EQDIR cable works perfectly with INDI EQMod driver.
Bluetooth works well with the latest Astroberry Server and Raspberry Pi 3B. It does not work with Raspberry Pi 3B+ with a built-in bluetooth (firmware issue?) but should work with a bluetooth USB dongle. I hope that it will be fixed with Ubuntu 18.04 soon.
The same applies to Gamepad - just load Joystick driver and enable it with your mount/focuser driver.
--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM
7 months 1 week ago #33502
The topic has been locked.
  • Posts: 5
  • Thank you received: 0

Replied by Ganymed on topic Astroberry Server

I have setup astroberry and I am not seeing Ekos being part of the programs.

I connected an ASI178 camera. PHD2 can connect to it and shows an image
Other programs like CCDCiel do not allow to setup the camera. There is not selection in the camera drop down.

Seems I am having some strange behavior.
7 months 6 days ago #33579
The topic has been locked.
  • Posts: 36
  • Thank you received: 1

Replied by Avocette on topic Astroberry Server

Ekos is included with/part of KStars.
7 months 6 days ago #33581
The topic has been locked.

Replied by knro on topic Astroberry Server

There is now a sub-forum dedicated to Astroberry, so locking this topic.
Jasem Mutlaq
Support INDI & Ekos; Get StellarMate Astrophotography Gadget.
How to Submit Logs when you have problems?
Add your observatory info
7 months 2 days ago #33722
The topic has been locked.
Moderators: Kaczorek
Time to create page: 1.187 seconds