×

INDI Library v1.8.0 is Released (27 Jul 2019)

INDI Library v1.8.0 is mostly a maintenance release to fix a few bugs in several drivers.

Astroberry Server

  • Posts: 632
  • Karma: 6
  • Thank you received: 244

Replied by Kaczorek on topic Astroberry Server

Psamathe

Display resolution is fixed in to 1920x1080 (full HD) so KStars and Ekos can fit to a screen. If you need to change it or you prefer to use hdmi connected display instead of remote display over VNC just select your resolution in /boot/config.txt - see the very last line: hdmi_mode=16. You don't need to do it if you use remote display because you can do local scaling, which will autofit display to your screen size (see Scaling option in left side popup menu in your browser).

I need to take a look at these problems with listing available wireless networks. Anyway as already discussed a few posts before:

Kaczorek wrote: If there's no networks on the list and you are sure that the list shouldn't be empty you can configure your home network connection from terminal by running "sudo wlanconf"

--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM
2 years 1 month ago #17624
The topic has been locked.
  • Posts: 303
  • Karma: 1
  • Thank you received: 30

Replied by HelgeMK on topic Astroberry Server

Dear Radek,

Whilst in principle I am getting better using astroberry server and Ekos every day, I am increasingly having issues with the noVNC connection, either the screen turns black or I am getting an error message, see attachment. I could not yet find out, what the reason is (also tested detaching PiFace, checked powering and so on). Now I wanted to try disconnecting WLAN/wifi, maybe it interferes? But how can I do it? The command wlanconf is designed for establishing the connection, how can I remove?

Many thanks in advance,

Helge
2 years 1 month ago #17681
Attachments:
The topic has been locked.
  • Posts: 632
  • Karma: 6
  • Thank you received: 244

Replied by Kaczorek on topic Astroberry Server

You get this type of error if (for some reason) GPS panel or INDI webmanager is not ready while opening the main page. You can just refresh the main page and it will disappear. I will take a closer look at this in the next release.
There's no tool for removing added wireless networks. However you can remove them manually by editing /etc/wpa_supplicant/wpa_supplicant.conf (or removing the file if you want to forget all wireless networks).
And the last but not least - I noted that sometimes you get a black screen when accessing your desktop over noVNC. I'm not sure why it happends and I suspect it's related to Xauthority. When it happens restart your RPi (over ssh). Restart always fixes this issue... at least until it happens again. The good news is that is does not happen during consecutive connections during same session, so you can safely restart before kstars and ekos are started.
--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM
The following user(s) said Thank You: HelgeMK
Last edit: 2 years 1 month ago by Kaczorek.
2 years 1 month ago #17689
The topic has been locked.
  • Posts: 303
  • Karma: 1
  • Thank you received: 30

Replied by HelgeMK on topic Astroberry Server

I have removed wlan settings as suggested (thanks a lot!), unfortunately, I did not help. I need to refresh the main page over and over again, or switch the RPi off and on until I am getting connected so I can start KStar/Ekos. The connection keeps dropping off. Strange, it was not like that as the beginning. System became hardly usable - luckily it is raining...

Should I reflash the es card?

You mentioned I should try "restart" via ssh, - I receive a reply that I need to specify what to restart. Can you tell me what exactly I need to type in PuTTy-terminal (which job)?
2 years 1 month ago #17694
The topic has been locked.
  • Posts: 632
  • Karma: 6
  • Thank you received: 244

Replied by Kaczorek on topic Astroberry Server

There are some strange things happening with your system. I would strongly recommend reflashing.
What I mean by "restart your RPi (over ssh)" is to start terminal and or connect to the RPi over ssh and run "sudo reboot" - this will safely reboot your device.
Beware that switching RPi off and on by just disconnecting power plug is not safe. It will for sure corrupt your filesystem. It's just like disconnecting power plug of your PC. What you need to do is to safe shutdown (ex. sudo poweroff) or safe reboot (ex. sudo reboot). You should never unplug power before safe shutdown.
--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM
The following user(s) said Thank You: HelgeMK
2 years 1 month ago #17708
The topic has been locked.
  • Posts: 303
  • Karma: 1
  • Thank you received: 30

Replied by HelgeMK on topic Astroberry Server

Dear Radek,

With rebooting I usually manage to get the system running again, after a few attempts. I reflashed the sd card, but issue is persisting. Could it be that it has to do with the certificate? (I saved the certificate on my laptop, and confirmed exception, following a security alert). Not sure what else I can do.

Btw: focuser runs smoothly, see picture.

Best, Helge

Best, Helge
2 years 1 month ago #17753
Attachments:
The topic has been locked.
  • Posts: 632
  • Karma: 6
  • Thank you received: 244

Replied by Kaczorek on topic Astroberry Server

Hi Helge
What issue stays unresolved? Can you confirm you follow guidelines in readme file ?
--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM
2 years 1 month ago #17756
The topic has been locked.
  • Posts: 303
  • Karma: 1
  • Thank you received: 30

Replied by HelgeMK on topic Astroberry Server

Hm...I find it difficult to admit, but since I have run an update of the operating system, as suggested in the guideline (sudo apt-get update), now seems fine!
2 years 1 month ago #17776
The topic has been locked.
  • Posts: 353
  • Karma: 2
  • Thank you received: 25

Replied by maudy on topic Astroberry Server

Is there a way for force RPI3 to update time right away?

Something has changed and it seems to take 5 minutes or so for the NTP server to grab the correct time.
2 years 1 month ago #17863
The topic has been locked.
  • Posts: 632
  • Karma: 6
  • Thank you received: 244

Replied by Kaczorek on topic Astroberry Server

Do you mean updating time from the Internet or from GPS?
--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM
2 years 1 month ago #17865
The topic has been locked.
  • Posts: 353
  • Karma: 2
  • Thank you received: 25

Replied by maudy on topic Astroberry Server

Internet please.

Ideally the time is updated from Internet or I can do manually.

Manually would be done from a remote site. Or done with Kstars syncing computer to device time.
2 years 1 month ago #17867
The topic has been locked.
  • Posts: 632
  • Karma: 6
  • Thank you received: 244

Replied by Kaczorek on topic Astroberry Server

As already described in this thread the system time is synchronized with NTP. It works in two modes: (1) if you have Internet connection NTP gets time from public NTP servers, (2) if you don't have INternet connection NTP gets time from GPSD server (assuming you have a gps connected to your raspberry). If you don't have INternet connection and gps connected to your raspberry the only option is to set the time manually.
Now, where the time setting delay may come from? NTP does not set the time in one jump. Instead it sets the system time in a few jumps, chasing the actual time. I believe this is for consistency of many processes running on a system. To get it quicker you need to install ntpdate and run it once at system boot. It will set the time and leave little distance for NTP to chase the exact time.
Anyway I would advice to use GPS module with RTC (real time clock) or just RTC module so your raspberry keeps the date and time between reboots.
--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM
2 years 1 month ago #17873
The topic has been locked.
Moderators: Kaczorek
Time to create page: 0.757 seconds