×

INDI Library v1.8.0 is Released (27 Jul 2019)

INDI Library v1.8.0 is mostly a maintenance release to fix a few bugs in several drivers.

Focuser start up position question

  • Posts: 18
  • Thank you received: 2

Focuser start up position question was created by eplumer

My question is about configuring how the focuser starts up. Much of my issues might be my lack of understanding of how to configure Indi/Ekos.

So Far:
I now have piface_focuser controlling my DIY focuser on my Orion ED80T-CF refractor. Yay! I left the motor's step delay at 1ms since anything faster is stalling the little 24BYJ48 I am using. I also bumped up the maximum steps allowed to 100,000 ticks. This gives me a total dynamic range of 20mm of tube displacement, a slew which takes about 2min to complete. Unfortunately, the focusing point for my equipment is about 55mm of tube extension.

Problem:
On startup, I disengage my focuser-stepper and manually rack the focuser to the approximate in-focus position.
When I then restart indi-server through Ekos, I would like the piface focuser to startup assuming that its absolute position is 50,000 ticks (half way within my focusing dynamic range). This would allow me to electronically adjust the focus both up and down from the initial starting point. This is especially desirable when restarting indi-server after a crash (something like this always happens in the field to me). The tube would already be at the right position and I want to effectively sync the driver to approximately the same point.

Currently, If I set the position to 50,000 and save the indi configuration, then on startup, piface immediately begins to move the focuser by 50,000 ticks, something that cannot be interrupted. Instead, I want it to not step the motor but tell the client it is already at absolute position 50,000.

Is this possible through either settings in Indi control panel or by some tweaking to the initProperties method of the piface driver?

Also, can anyone point me to documentation on what the "Parking Enable|Disable" and "Position Reset" buttons are supposed to do in the Indi control panel as they seem like they might be relevant.
6 months 6 days ago #34879

Please Log in or Create an account to join the conversation.

  • Posts: 632
  • Karma: 6
  • Thank you received: 244

Replied by Kaczorek on topic Focuser start up position question

Since there's no encoder on a stepper motor a focuser has no idea where it starts just after connection. That's why the initial position is 0 unless you save the last position. In such the case if you enable Parking, a focuser will travel to 0 when you disconnect and travel to the saved position when you connect. If you disable parking no travel is done at connect/disconnect.
Position Reset lets you go below 0, keeping the absolute position at 0. This is useful when you need to travel inward but you are already at 0 (no negative values are allowed). As the matter of fact this is how you can use the logic in your case i.e. disable Parking mode, don't save the position (or save at 0), when you reconnect you will be at 0, if you need to travel outward do as usual, if you need to travel inward use Position Reset. If you get inward enough with Position reset and then travel outward, you should gain some space to travel both directions as usual.
This is how it's designed ;-)
--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM
6 months 5 days ago #34907

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 2

Replied by eplumer on topic Focuser start up position question

This sounds very promising, thank you! The explanation of what exactly Park does helps alot. I am still unclear about what the Position Reset does. Can you explain that a bit more? It sounds like it might reset the absolute ticks to 0 without moving the stepper?

I have not found docs for either of these two features.
Last edit: 6 months 5 days ago by eplumer.
6 months 5 days ago #34915

Please Log in or Create an account to join the conversation.

  • Posts: 632
  • Karma: 6
  • Thank you received: 244

Replied by Kaczorek on topic Focuser start up position question

When at 0 (zero) position you can only travel outward. Position Reset lets you travel inward, keeping absolute position at 0. Just go to 0 and click reset you will see what I mean.
--
Radek Kaczorek
Astroberry Server | NEQ6 | Atik 460EX | Atik EFW2 | ASI 120MM
6 months 5 days ago #34916

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 2

Replied by eplumer on topic Focuser start up position question

I will give it a try tonight
6 months 5 days ago #34918

Please Log in or Create an account to join the conversation.

  • Posts: 18
  • Thank you received: 2

Replied by eplumer on topic Focuser start up position question

OK, I see that if I am at position zero and press Position Reset that the focuser moves inward by some amount while leaving the position at zero.

What is the amount it moves by? Watching the telescope, it looks like the same amount as 1000 ticks but this amount is not affected by either the "Main Control > Relative Steps" parameter in indi control panel, nor the "Steps" parameter in the Ekos focusing tab. Is this a hard coded value or is it specified somewhere I am missing?
6 months 5 days ago #34923

Please Log in or Create an account to join the conversation.

Moderators: Kaczorek
Time to create page: 0.190 seconds