×

INDI Library v1.7.8 Released (11 May 2019)

Mid year release of INDI Library v1.7.8 comes with a few drivers and improvements to to existing drivers.

Atlas EQ-G

  • Posts: 23
  • Thank you received: 0

Atlas EQ-G was created by freddylq

Hi guys. I'm trying to connect my Atlas EQ-G mount and seem to be having trouble connecting. I keep getting: [ERROR] Serial read error. Timeout error. I'm sure it's something dumb that I'm not doing correctly. I'm using an Aten UC232A USB to Serial adapter. That is connected to the RS-232 port on my hand controller. Can someone walk me through the proper settings on EKOS. I did set up a Mount Test profile in the Indi manager using the Synscan driver and started the server. I get the same error when I tried Skychart. It just occured to me, do I need to install drivers for the UC232A? If so how do I do that?
Last edit: 2 months 6 days ago by freddylq.
2 months 6 days ago #36643

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 4

Replied by Spartacus on topic Atlas EQ-G

In my set up I don't use the hand controller. Just connect the RS232 end of your adaptor to the mount and the USB end to your Raspberry Pi or whatever you are running KStars/EKOS on. Don't use the synscan driver use EQMod. Select EQMod mount in your profile when you create it along with the rest of your gear. Save it then start EKOS and it should connect. Make sure that you are set auto search for your connection. It should be automatic.
Once you are connected you can open up the various tabs in INDI and adjust as you wish but usually the defaults work fine.
2 months 6 days ago #36649

Please Log in or Create an account to join the conversation.

  • Posts: 23
  • Thank you received: 0

Replied by freddylq on topic Atlas EQ-G

But don't I need an EQDir adapter to connect it that way?
2 months 6 days ago #36650

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 4

Replied by Spartacus on topic Atlas EQ-G

Hi
Yes the simplest way is to use the EQDir USB2EQ6 serial to USB connector.
However I have just replicated your setup and connected OK. So here is what I did
Connect the hand box to the mount in the usual way.
Connect the serial to RJ connector from the handbox to your Aten serial to USB connector
Connect the USB of your Aten to the RPi or whatever computer you are using.
Turn on the computer and the mount
Go through the initialisation as per normal on your handbox (co-ords, time etc) Do not do any alignment.
Go into utilities and select PC Direct mode
Start up Kstars then EKOS
Create a profile suing EQMod driver in the area for your mount
Select your camera and guider and telescope parameters
Save the profile
Go to EKOS box and select the profile that you have created
Start INDI
This should now connect to your mount (make sure you selected auto search in the connection tab in the mount section in INDI
Now you are away. If for some reason it does not connect it may be that your Aten connector is conflicting. You could try another or just get the EQdir cable.
Cheers
Mike
2 months 6 days ago #36658

Please Log in or Create an account to join the conversation.

  • Posts: 23
  • Thank you received: 0

Replied by freddylq on topic Atlas EQ-G

Thanks but going back to your original suggestion. Just using the Aten USB/serial adapter, do I even need an EQDIR adapter in between the mount & laptop/RPI or will it work with just the Aten USB/Serial adapter alone? My setup with the hand controller works fine with Win7/Ascom. Also don't I need to install the Aten drivers? I did notice that the yellow LED on the Aten adapter doesn't light up but it did with my Win7/Ascom setup once I installed the drivers.
2 months 5 days ago #36684

Please Log in or Create an account to join the conversation.

  • Posts: 23
  • Thank you received: 0

Replied by freddylq on topic Atlas EQ-G

Ok I'm testing as I type and it seems to be working fine with the hand controller in between. I will next test it with Skycharts. Thanks. But can you still answer my question regarding using only the Aten adapter in my previous post.
2 months 5 days ago #36685

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 4

Replied by Spartacus on topic Atlas EQ-G

Hi,

OK so I have just tested your setup using a serial to USB adaptor like the Aten. I know that this works as I have used it to update the firmware on a few handboxes (sometimes the chipsets in the cheaper ones do not work). I can also confirm that this setup will not work as a direct connection from mount to RPi, you have to use the handbox. I am not sure of the differences between the EQDir cable and these generic serial to USB but the EQDir is designed specifically for this purpose whereas the others are not.
Maybe others can help in defining the differences but my feeling is that you may be wasting your time trying to get the Aten cable to work when really the answer (certainly in terms of a reliable connection) is the EQDir cable.
Sorry I don't have a better answer.
Good luck
Mike
The following user(s) said Thank You: freddylq
2 months 5 days ago #36692

Please Log in or Create an account to join the conversation.

  • Posts: 23
  • Thank you received: 0

Replied by freddylq on topic Atlas EQ-G

Thanks Spartacus.....Everything seems to be working fine with the hand controller in the middle....I do have an EQDIR adapter somewhere around here. I just wanted to confirm that using the USB/Serial adapter alone would work without an EQDIR in the middle. I don't want to fry anything. Thanks.
2 months 5 days ago #36696

Please Log in or Create an account to join the conversation.

  • Posts: 17
  • Thank you received: 4

Replied by Spartacus on topic Atlas EQ-G

Hi,
The EQDir cable is all you need. Straight from serial connector of the mount to USB on your computer. Thats why so many people use it cos its soooo easy.
BTW just a precaution - don't hot swap a serial cable to mount. Always switch off before plugging/unplugging. I blew a board once doing this, you only do it once. It's easy to forget when experimenting with cable/adaptor configurations.
Cheers
Mike
2 months 5 days ago #36699

Please Log in or Create an account to join the conversation.

Moderators: Kaczorek
Time to create page: 0.607 seconds