×

INDI Library v1.9.3 Released (11 Nov 2021)

Bimonthly Stable INDI Library release introduces new drivers and fixes for existing ones. Some highlights:

Astroberry Server 2.0.0 is available now!

  • Posts: 1067
  • Thank you received: 136
I have changed the password three times to my own from Astroberry, and still it needs Astroberry password on a few things and my own works on others, which is really annoying as I don’t know which one it wants and have to try both till one works, sometimes my own works and sometimes Astroberry works... ☹️☹️???
Stellarmate OS on Raspberry pi4b
Skywatcher EQ8 pro, on steel pier
Takahashi FSQ85, FS60cb & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar x2 Guide Camera
Pegasus Ultimate Hub V2 for all USB & Power
Pegasus focus motors on all scopes
2 years 1 week ago #46119
The topic has been locked.
  • Posts: 236
  • Thank you received: 14
I managed to get rid of it. Just i am not sure how I done it. :( very random steps....
Skywatcher AZEQ5GT using EQMod
Pentax 100 SDUFII for the light
QHY168C mains with ASI120MC on guidescope
SX filter wheel
Robofocus focusers with DIY Moonlite compatible controller
RPI 4B, Stellarmate & Astroberry
2 years 1 week ago #46122
The topic has been locked.
  • Posts: 968
  • Thank you received: 367
Thanks for the feedback guys. They are very useful and will let me improve a few things in this version.

@TomAstro
Only stable releases are available at the moment.

@AstroNerd
Default keyboard layout used in the image is QUERTY . Change your keyboard layout using raspi-config or gui_rc to align system configuration and your keyboard.
GPS does not use any extra configuration. If you don't get fix it means no enough satellites are in view. Try to test it outside.

@Avocette
I don't know if RealVNC supports 4K at all. This resolution might be available only over HDMI. If your /boot/config.txt files are the same the behavior must be the same. No other changes to buster has been introduced.
Welcome pop-up coming back every boot is a bug. It should pop-up only the first boot. It will be fixed over regular update. A quick workaround is to run: sudo sed -i "s/^astroberry-init.sh/#astroberry-init.sh/g" /etc/xdg/lxsession/LXDE-astroberry/autostart
--
Radek Kaczorek
Astroberry Server | Orion CT8 | Askar FRA 400 | NEQ6 (hypermod) | Atik 460EX | ASI 1600 | ASI 120MM | Atik EFW2
The following user(s) said Thank You: andy forster
Last edit: 2 years 1 week ago by Radek Kaczorek.
2 years 1 week ago #46147
The topic has been locked.
  • Posts: 1067
  • Thank you received: 136


Sorry but I did not mention anything to do with keyboard, or anything to do with GPS, think you have me mixed up.....

One thing I will say is that 4k does work perfectly on raspbian buster, over VNC, RDP and noVNC, but does not work at all with this Astroberry...so something is different, also there is no way to enable it on here, but there is in raspbian buster....
The config text file here is different, on buster there was a setting to enable 4K, this is now omitted, the highest it will go is 2560 x 1600 which is mode 77, for 4k you need mode 97 which does not work....
Stellarmate OS on Raspberry pi4b
Skywatcher EQ8 pro, on steel pier
Takahashi FSQ85, FS60cb & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar x2 Guide Camera
Pegasus Ultimate Hub V2 for all USB & Power
Pegasus focus motors on all scopes
Last edit: 2 years 1 week ago by AstroNerd.
2 years 1 week ago #46149
The topic has been locked.
  • Posts: 968
  • Thank you received: 367
First of all WHY have you removed several posts from this thread? I have received all these messages on my email and they DO NOT breach any forum rules! The fact that they do not suit you is not enough. It's gonna be reported.

Now regarding your post. Take it as a fact - there is no change to raspbian buster operating system in astroberry whatsoever. If there is a way to activate 4K in raspbian buster just share it.
--
Radek Kaczorek
Astroberry Server | Orion CT8 | Askar FRA 400 | NEQ6 (hypermod) | Atik 460EX | ASI 1600 | ASI 120MM | Atik EFW2
2 years 1 week ago #46150
The topic has been locked.
  • Posts: 1067
  • Thank you received: 136

Removing them was my mistake, I used the wrong moderate button, I am new to this...appologies...
As for the 4k issue, I have nothing to share as the settings that are in buster to set up the 4k, I have enabled in Astroberry but do not produce the same result, so I have no idea on that...it’s just one line on the config text file, that needed uncommenting, but does not work the same and I have no idea why....so I can’t help with that, if I could I would...in raspbian I set the mode to 97 and it sets up the 4k, but in Astroberry it stops the rpi from booting...
Stellarmate OS on Raspberry pi4b
Skywatcher EQ8 pro, on steel pier
Takahashi FSQ85, FS60cb & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar x2 Guide Camera
Pegasus Ultimate Hub V2 for all USB & Power
Pegasus focus motors on all scopes
Last edit: 2 years 1 week ago by AstroNerd.
2 years 1 week ago #46153
The topic has been locked.
  • Posts: 1067
  • Thank you received: 136
FYI I have reported my errors to Jasem, so appologies again..
Stellarmate OS on Raspberry pi4b
Skywatcher EQ8 pro, on steel pier
Takahashi FSQ85, FS60cb & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar x2 Guide Camera
Pegasus Ultimate Hub V2 for all USB & Power
Pegasus focus motors on all scopes
2 years 1 week ago #46155
The topic has been locked.
  • Posts: 236
  • Thank you received: 14
Will see whether I can combine AstroPi3 script into Astoberry to get the latest kstars and INDI or not.

Thanks a lot.
Skywatcher AZEQ5GT using EQMod
Pentax 100 SDUFII for the light
QHY168C mains with ASI120MC on guidescope
SX filter wheel
Robofocus focusers with DIY Moonlite compatible controller
RPI 4B, Stellarmate & Astroberry
2 years 1 week ago #46160
The topic has been locked.
  • Posts: 236
  • Thank you received: 14
Having this issue......

[2019-11-23T22:15:19.767 +08 DEBG ][ org.kde.kstars.indi] - Adding managed driver "QHY CCD"
[2019-11-23T22:15:19.767 +08 DEBG ][ org.kde.kstars.indi] - Starting INDI Driver "indi_qhy_ccd"
[2019-11-23T22:15:19.767 +08 DEBG ][ org.kde.kstars.indi] - INDI Server: "FIFO: start indi_qhy_ccd"
[2019-11-23T22:15:19.768 +08 DEBG ][ org.kde.kstars.indi] - INDI Server: "FIFO: Starting driver indi_qhy_ccd"
[2019-11-23T22:15:19.768 +08 DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-11-23T22:15:19.768 +08 DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-11-23T14:15:19: Driver indi_qhy_ccd: pid=2356 rfd=10 wfd=30 efd=31"
[2019-11-23T22:15:19.768 +08 DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-11-23T22:15:19.769 +08 DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-11-23T14:15:19: Driver indi_qhy_ccd: indi_qhy_ccd: error while loading shared libraries: libqhyccd.so.6: wrong ELF class: ELFCLASS64"
[2019-11-23T22:15:19.769 +08 DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-11-23T22:15:19.770 +08 DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-11-23T14:15:19: Driver indi_qhy_ccd: stderr EOF"
[2019-11-23T22:15:19.770 +08 DEBG ][ org.kde.kstars.indi] - INDI Server: "Child process 2356 died"
[2019-11-23T22:15:19.770 +08 DEBG ][ org.kde.kstars.indi] - INDI Server: "2019-11-23T14:15:19: Driver indi_qhy_ccd: Terminated after #0 restarts."
[2019-11-23T22:15:19.770 +08 DEBG ][ org.kde.kstars.indi] - INDI Server: ""
[2019-11-23T22:15:19.770 +08 CRIT ][ org.kde.kstars.indi] - INDI driver "indi_qhy_ccd" crashed!

Any idea?
Skywatcher AZEQ5GT using EQMod
Pentax 100 SDUFII for the light
QHY168C mains with ASI120MC on guidescope
SX filter wheel
Robofocus focusers with DIY Moonlite compatible controller
RPI 4B, Stellarmate & Astroberry
2 years 1 week ago #46175
The topic has been locked.
  • Posts: 968
  • Thank you received: 367
Welcome pop-up is fixed now.
Astro panel is fixed now. By default it uses GPS, but you can disable it and use static configuration from /etc/astropanel.config

Update with sudo apt update && sudo apt upgrade
--
Radek Kaczorek
Astroberry Server | Orion CT8 | Askar FRA 400 | NEQ6 (hypermod) | Atik 460EX | ASI 1600 | ASI 120MM | Atik EFW2
The following user(s) said Thank You: Craig, Avocette
2 years 1 week ago #46179
The topic has been locked.
  • Posts: 968
  • Thank you received: 367

Cannot reproduce it
2019-11-23T16:14:56: startup: indiserver indi_qhy_ccd 
2019-11-23T16:14:56: Driver indi_qhy_ccd: QHYCCD|QHYCCD.CPP|InitQHYCCDResource| START
2019-11-23T16:14:56: Driver indi_qhy_ccd: QHYCCD|QHYCCD.CPP|InitQHYCCDResourceInside|InitQHYCCDResourceInside   START
2019-11-23T16:14:56: Driver indi_qhy_ccd: QHYCCD|QHYCCD.CPP|InitQHYCCDResourceInside|    InitQHYCCDResourceInside   END
2019-11-23T16:14:56: Driver indi_qhy_ccd: QHYCCD|QHYCCD.CPP|ScanQHYCCD|START
2019-11-23T16:14:56: Driver indi_qhy_ccd: QHYCCD|QHYCCD.CPP|ScanQHYCCD|ScanQHYCCD numdev=0
2019-11-23T16:14:56: Driver indi_qhy_ccd: QHYCCD|QHYCCD.CPP|ScanQHYCCD|Scan  finished. Return nid=0
2019-11-23T16:14:56: Driver indi_qhy_ccd: QHYCCD|QHYCCD.CPP|ScanQHYCCD|numdev =  0
2019-11-23T16:14:56: Driver indi_qhy_ccd: QHYCCD|QHYCCD.CPP|InitQHYCCDResource| END
--
Radek Kaczorek
Astroberry Server | Orion CT8 | Askar FRA 400 | NEQ6 (hypermod) | Atik 460EX | ASI 1600 | ASI 120MM | Atik EFW2
2 years 1 week ago #46180
The topic has been locked.
  • Posts: 407
  • Thank you received: 74
Update completed - no report problems.
First load Pop Up appears then next boot no pop up ,plus location detail still ok - great thanks!
RPI3 Ubuntu 16.04 / AMD desktop Kstars under Ubuntu 16.04 Mounts :azeq6 ,SWAZGoTo

RPI3 Fedora testing out on AMD desktop Fedpra 28 - running kstars 2.9.4 , Indilib 1.7.4 ?????
The following user(s) said Thank You: Radek Kaczorek
2 years 1 week ago #46181
The topic has been locked.
Moderators: Radek Kaczorek
Time to create page: 0.598 seconds