×

INDI Library v1.9.5 Released (08 Mar 2022)

Bi-monthly INDI Library released with new drivers and bug fixes.

Astroberry Server 2.0.0 is available now!

  • Posts: 387
  • Thank you received: 15
Hello,

When I first installed AB2.0, I “kicked the tires” and discovered ASTAP was installed. Cool. I opened KSTARS and selected ASTAP. I immediately received the message that ASTAP was not installed. But, I confirmed the ASTAP icon was there.

I went to the ASTAP site and downloaded the bits necessary to get it running. I then installed it.

I then went into KSTARS and selected ASTAP for PolarAlign. No error message was given this time.

To me, this looked like out of order install sequence. No problem. We are on the bleeding edge.
2 years 5 months ago #46658
The topic has been locked.
  • Posts: 7
  • Thank you received: 0
Hello!

I'll start by thanking the developers of this awesome software package!

I was having issues in connecting an EQMod compatible equipment but finally solved it, so I want to share it since the may need some attention.
By the way, I'm an absolute zero in linux.

I was connecting my EQStar Pro (cool GoTo kit from Astro-gadget), but the INDI was always presenting an error.
After multiple attempts, trying different drivers (Synscan, syscan legacy, etc...) I dumped into a old forum where some people had problems with a GPS device.
I don't even have a GPS, but gave it a try and it worked.
The solution was to type the command:

sudo systemctl stop gpsd gpsd.socket

More information here:
www.cloudynights.com/topic/599293-eqdriv...other-options/page-2

In other forums I found that this gps issue has been giving headaches since at least 2012...

Many thanks for all the great help!
2 years 5 months ago #46663
The topic has been locked.
  • Posts: 238
  • Thank you received: 15

It won't work with apt-get update and full-upgrade. :)

Looks like i need AstroPi3 script to get PHD2 from source.
Skywatcher AZEQ5GT using EQMod
Pentax 100 SDUFII for the light
QHY168C mains with ASI120MC on guidescope
SX filter wheel
Robofocus focusers with DIY Moonlite compatible controller
RPI 4B, Stellarmate & Astroberry
2 years 5 months ago #46677
The topic has been locked.
  • Posts: 16
  • Thank you received: 0
This week my new rapsberry PI 4 arrived. I installed Astroberry without any problems.

I have noticed that in Kstars the reference to ASTAP is /usr/local/share/bin/ASTAP, but ASTAP is installed in /opt/astap/ASTAP. So I made a symbolic link in /usr/local/share/bin to the binary. Then ASTAP works fine in KStars.

When I performed plate solving with Astromery.net (online) it took 101 s. Performing plate solving with Astrometry.net (offline) took 29s. ASTAP managed the job in 8s.

Now I'm waiting for some clear skies to perform the ultimate test :)

Kind regards,
Gunther
Remote PI : Raspberry PI 3B+ with Stellarmate 1.16.2 /
Telescope : Skywatcher HEQ5 /
Camera : Canon 700D
2 years 5 months ago #46681
The topic has been locked.
  • Posts: 1067
  • Thank you received: 137

There is no need for a symlink, there is an option in the ekos ASTAP settings to change the exe directory, mine is wrong to and had to change... :)
Stellarmate OS on Raspberry pi4b
Skywatcher EQ8 pro, on steel pier
Takahashi FSQ85, FS60cb & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar x2 Guide Camera
Pegasus Ultimate Hub V2 for all USB & Power
Pegasus focus motors on all scopes
2 years 5 months ago #46683
The topic has been locked.
  • Posts: 1067
  • Thank you received: 137
An issue I have found with Astroberry, is that the QHY polemaster does NOT WORK on it, I have tried everything...it does not work in Ekos at all, which I don’t understand.... any ideas....?
Stellarmate OS on Raspberry pi4b
Skywatcher EQ8 pro, on steel pier
Takahashi FSQ85, FS60cb & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar x2 Guide Camera
Pegasus Ultimate Hub V2 for all USB & Power
Pegasus focus motors on all scopes
2 years 5 months ago #46690
The topic has been locked.
  • Posts: 387
  • Thank you received: 15
Hello,

I think I may have found one problem between EKOS and QHY PoleMaster. Partly, mine is a possible design issue. I am finding USB hubs are not consistent. Inside my house, EKOS and PoleMaster work fine.

My USB hub in my house is from a different vendor and temperature. Both are 7 port. The OTA is outside and USB 2.0. The inside hub is USB 3.0.

I am thinking I need to split up to 2 4 port hubs. I think both the hub and the RPI3B+ are limited on bandwidth. The RS232, GPS and AstroEQ, needs on one. The CCD types on the other hub. This pushes the RPI3B+. But it keeps the bandwidth needs down.
2 years 5 months ago #46699
The topic has been locked.
  • Posts: 1067
  • Thank you received: 137

I have it plugged directly into rpi and still does not work with Astroberry and ekos...., not sure why
Stellarmate OS on Raspberry pi4b
Skywatcher EQ8 pro, on steel pier
Takahashi FSQ85, FS60cb & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar x2 Guide Camera
Pegasus Ultimate Hub V2 for all USB & Power
Pegasus focus motors on all scopes
2 years 5 months ago #46710
The topic has been locked.
  • Posts: 387
  • Thank you received: 15
Hello,

I went to the QHYCCD site and pulled down the PoleMaster_QT. For AstroBerry 2.0, the install is dated. But, it gives a non-INDI status of PoleMaster. After installation, go get the latest RPI SDK kit from QHYCCD. Install the Kit.
2 years 5 months ago #46711
The topic has been locked.
  • Posts: 1067
  • Thank you received: 137

Yes, done all that...still no joy, I got the software installed and running, but it will not recognise the camera....either in the polemaster software or in Ekos...
Stellarmate OS on Raspberry pi4b
Skywatcher EQ8 pro, on steel pier
Takahashi FSQ85, FS60cb & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar x2 Guide Camera
Pegasus Ultimate Hub V2 for all USB & Power
Pegasus focus motors on all scopes
2 years 5 months ago #46712
The topic has been locked.
  • Posts: 387
  • Thank you received: 15
Hello,

Using LSUSB, do you see 0940 or 0941?
2 years 5 months ago #46717
The topic has been locked.
  • Posts: 1067
  • Thank you received: 137

No, it’s not showing there either...
Stellarmate OS on Raspberry pi4b
Skywatcher EQ8 pro, on steel pier
Takahashi FSQ85, FS60cb & Meade 8” SCT (de-forked)
Starlight Xpress SXVR H18, SXVR M25c, Lodestar x2 Guide Camera
Pegasus Ultimate Hub V2 for all USB & Power
Pegasus focus motors on all scopes
2 years 5 months ago #46727
The topic has been locked.
Moderators: Radek Kaczorek
Time to create page: 1.068 seconds